summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-05-13 20:05:10 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-05-13 20:05:10 +0000
commit29c860cae4e733257085230e66b47c471e8ac39b (patch)
tree9069090999ed4868f5110fb7e3ab556a6b149fc0 /www-apache/mod_jk
parentFix indentation of site file. (diff)
downloadgentoo-2-29c860cae4e733257085230e66b47c471e8ac39b.tar.gz
gentoo-2-29c860cae4e733257085230e66b47c471e8ac39b.tar.bz2
gentoo-2-29c860cae4e733257085230e66b47c471e8ac39b.zip
Remove Apache1 support (part of fix for #178380).
(Portage version: 2.1.2.7)
Diffstat (limited to 'www-apache/mod_jk')
-rw-r--r--www-apache/mod_jk/ChangeLog6
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild17
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.22.ebuild17
3 files changed, 9 insertions, 31 deletions
diff --git a/www-apache/mod_jk/ChangeLog b/www-apache/mod_jk/ChangeLog
index 5bd7fc980867..560fefa2156a 100644
--- a/www-apache/mod_jk/ChangeLog
+++ b/www-apache/mod_jk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_jk
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.29 2007/04/18 17:43:08 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.30 2007/05/13 20:05:10 chtekk Exp $
+
+ 13 May 2007; Luca Longinotti <chtekk@gentoo.org> mod_jk-1.2.21-r2.ebuild,
+ mod_jk-1.2.22.ebuild:
+ Remove Apache1 support (part of fix for #178380).
*mod_jk-1.2.22 (18 Apr 2007)
diff --git a/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild b/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild
index 58845ab231bd..1fb7f1b8121e 100644
--- a/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild
+++ b/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild,v 1.2 2007/03/08 19:16:39 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild,v 1.3 2007/05/13 20:05:10 chtekk Exp $
inherit apache-module autotools
@@ -18,10 +18,6 @@ IUSE=""
S="${WORKDIR}/${MY_P}/native"
-APACHE1_MOD_FILE="${S}/apache-1.3/${PN}.so"
-APACHE1_MOD_CONF="88_${PN}"
-APACHE1_MOD_DEFINE="JK"
-
APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
APACHE2_MOD_CONF="88_${PN}"
APACHE2_MOD_DEFINE="JK"
@@ -38,12 +34,8 @@ src_unpack() {
}
src_compile() {
- local apxs
- use apache2 && apxs="${APXS2}"
- use apache2 || apxs="${APXS1}"
-
econf \
- --with-apxs=${apxs} \
+ --with-apxs=${APXS2} \
--with-apr-config=/usr/bin/apr-config \
|| die "econf failed"
emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
@@ -56,11 +48,6 @@ src_install() {
# call the nifty default src_install :-)
apache-module_src_install
-
- if ! use apache2 ; then
- sed -i -e 's:/apache2/:/apache/:' "${D}${APACHE_CONFDIR}/modules.d/88_${PN}.conf" \
- || die "Could not update jk-workers.properties for apache"
- fi
}
pkg_postinst() {
diff --git a/www-apache/mod_jk/mod_jk-1.2.22.ebuild b/www-apache/mod_jk/mod_jk-1.2.22.ebuild
index 601e8710f796..531727f7841b 100644
--- a/www-apache/mod_jk/mod_jk-1.2.22.ebuild
+++ b/www-apache/mod_jk/mod_jk-1.2.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.22.ebuild,v 1.1 2007/04/18 17:43:08 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.22.ebuild,v 1.2 2007/05/13 20:05:10 chtekk Exp $
inherit apache-module autotools
@@ -18,10 +18,6 @@ IUSE=""
S="${WORKDIR}/${MY_P}/native"
-APACHE1_MOD_FILE="${S}/apache-1.3/${PN}.so"
-APACHE1_MOD_CONF="88_${PN}"
-APACHE1_MOD_DEFINE="JK"
-
APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
APACHE2_MOD_CONF="88_${PN}"
APACHE2_MOD_DEFINE="JK"
@@ -38,12 +34,8 @@ src_unpack() {
}
src_compile() {
- local apxs
- use apache2 && apxs="${APXS2}"
- use apache2 || apxs="${APXS1}"
-
econf \
- --with-apxs=${apxs} \
+ --with-apxs=${APXS2} \
--with-apr-config=/usr/bin/apr-config \
|| die "econf failed"
emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
@@ -56,11 +48,6 @@ src_install() {
# call the nifty default src_install :-)
apache-module_src_install
-
- if ! use apache2 ; then
- sed -i -e 's:/apache2/:/apache/:' "${D}${APACHE_CONFDIR}/modules.d/88_${PN}.conf" \
- || die "Could not update jk-workers.properties for apache"
- fi
}
pkg_postinst() {