summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-10-14 17:24:30 +0000
committerSteve Dibb <beandog@gentoo.org>2011-10-14 17:24:30 +0000
commit88778e01c85049bb07ea856ea62baa3af63329fa (patch)
tree44fca3e1efce349c943be11411e0e960fd708b2d /www-apache/mod_authn_sasl
parentVersion bump (diff)
downloadgentoo-2-88778e01c85049bb07ea856ea62baa3af63329fa.tar.gz
gentoo-2-88778e01c85049bb07ea856ea62baa3af63329fa.tar.bz2
gentoo-2-88778e01c85049bb07ea856ea62baa3af63329fa.zip
Initial ebuild, bug 330781; Thanks to Phil Turmel
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_authn_sasl')
-rw-r--r--www-apache/mod_authn_sasl/ChangeLog10
-rw-r--r--www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf5
-rw-r--r--www-apache/mod_authn_sasl/metadata.xml5
-rw-r--r--www-apache/mod_authn_sasl/mod_authn_sasl-1.1.ebuild27
4 files changed, 47 insertions, 0 deletions
diff --git a/www-apache/mod_authn_sasl/ChangeLog b/www-apache/mod_authn_sasl/ChangeLog
new file mode 100644
index 000000000000..923fdc12e9c7
--- /dev/null
+++ b/www-apache/mod_authn_sasl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apache/mod_authn_sasl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_authn_sasl/ChangeLog,v 1.1 2011/10/14 17:24:30 beandog Exp $
+
+*mod_authn_sasl-1.1 (14 Oct 2011)
+
+ 14 Oct 2011; Steve Dibb <beandog@gentoo.org> +files/10_mod_authn_sasl.conf,
+ +mod_authn_sasl-1.1.ebuild:
+ Initial ebuild, bug 330781; Thanks to Phil Turmel
+
diff --git a/www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf b/www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf
new file mode 100644
index 000000000000..05f71c156e41
--- /dev/null
+++ b/www-apache/mod_authn_sasl/files/10_mod_authn_sasl.conf
@@ -0,0 +1,5 @@
+<IfDefine AUTHN_SASL>
+LoadModule authn_sasl_module modules/mod_authn_sasl.so
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_authn_sasl/metadata.xml b/www-apache/mod_authn_sasl/metadata.xml
new file mode 100644
index 000000000000..64a719ea1bfd
--- /dev/null
+++ b/www-apache/mod_authn_sasl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>apache</herd>
+</pkgmetadata>
diff --git a/www-apache/mod_authn_sasl/mod_authn_sasl-1.1.ebuild b/www-apache/mod_authn_sasl/mod_authn_sasl-1.1.ebuild
new file mode 100644
index 000000000000..05fc33e3a586
--- /dev/null
+++ b/www-apache/mod_authn_sasl/mod_authn_sasl-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2010-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_authn_sasl/mod_authn_sasl-1.1.ebuild,v 1.1 2011/10/14 17:24:30 beandog Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Cyrus SASL authentication module for Apache."
+HOMEPAGE="http://mod-authn-sasl.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/project/mod-authn-sasl/mod-authn-sasl/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/cyrus-sasl"
+RDEPEND="${DEPEND}"
+
+APXS2_ARGS="-c ${PN}.c -lsasl2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHN_SASL"
+
+need_apache2_2
+
+src_install() {
+ apache-module_src_install
+}