summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-31 17:08:34 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-31 17:08:34 +0000
commitd4ee6c8992b33fcb86e1036b9e0627f1258c77f5 (patch)
treea5c22ecd19a1dbc0b79c7f399a395506477e5b80 /www-apache/mod_auth_pam
parentVersion bump (diff)
downloadgentoo-2-d4ee6c8992b33fcb86e1036b9e0627f1258c77f5.tar.gz
gentoo-2-d4ee6c8992b33fcb86e1036b9e0627f1258c77f5.tar.bz2
gentoo-2-d4ee6c8992b33fcb86e1036b9e0627f1258c77f5.zip
fix depend.apache usage wrt #208033; cleanup
(Portage version: 2.1.4)
Diffstat (limited to 'www-apache/mod_auth_pam')
-rw-r--r--www-apache/mod_auth_pam/ChangeLog7
-rw-r--r--www-apache/mod_auth_pam/files/10_mod_auth_pam.conf52
-rw-r--r--www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild6
-rw-r--r--www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild6
4 files changed, 32 insertions, 39 deletions
diff --git a/www-apache/mod_auth_pam/ChangeLog b/www-apache/mod_auth_pam/ChangeLog
index 72934c2300e0..462d44e2a841 100644
--- a/www-apache/mod_auth_pam/ChangeLog
+++ b/www-apache/mod_auth_pam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_auth_pam
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_pam/ChangeLog,v 1.3 2008/01/27 18:56:19 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_pam/ChangeLog,v 1.4 2008/01/31 17:08:34 hollow Exp $
+
+ 31 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ files/10_mod_auth_pam.conf, mod_auth_pam-1.1.1-r1.ebuild,
+ mod_auth_pam-1.1.1-r2.ebuild:
+ fix depend.apache usage wrt #208033; cleanup
27 Jan 2008; Benedikt Böhm <hollow@gentoo.org> metadata.xml:
update metadata; fix changelog
diff --git a/www-apache/mod_auth_pam/files/10_mod_auth_pam.conf b/www-apache/mod_auth_pam/files/10_mod_auth_pam.conf
index afcc4ef8974c..e437ac90d75d 100644
--- a/www-apache/mod_auth_pam/files/10_mod_auth_pam.conf
+++ b/www-apache/mod_auth_pam/files/10_mod_auth_pam.conf
@@ -1,37 +1,25 @@
<IfDefine AUTH_PAM>
- <IfModule !mod_auth_pam.c>
- LoadModule auth_pam_module modules/mod_auth_pam.so
- </IfModule>
- <IfModule !mod_auth_sys_group.c>
- LoadModule auth_sys_group_module modules/mod_auth_sys_group.so
- </IfModule>
-</IfDefine>
+LoadModule auth_pam_module modules/mod_auth_pam.so
+LoadModule auth_sys_group_module modules/mod_auth_sys_group.so
-### EXAMPLE 1: authentificate against a single PAM account
-###
-# <IfModule mod_auth_pam.c>
-# AuthPAM_Enabled on
-#
-# # If you want to make mod_auth_pam work with apache-2.2, please uncomment
-# # the following line:
-# AuthBasicAuthoritative Off
-# AuthType Basic
-# AuthName "secure area"
-# Require user webmaster
-# </IfModule>
+# EXAMPLE 1: authentificate against a single PAM account
+#AuthPAM_Enabled on
+# If you want to make mod_auth_pam work with apache-2.2, please uncomment
+# the following line:
+#AuthBasicAuthoritative Off
+#AuthType Basic
+#AuthName "secure area"
+#Require user webmaster
-### EXAMPLE 2: authentificate against a a PAM group, so, that each user
-### beeing in this group may access this "secure area"
-###
-# <IfModule mod_auth_sys_group.c>
-# AuthPAM_Enabled on
-#
-# # If you want to make mod_auth_pam work with apache-2.2, please uncomment
-# # the following line:
-# AuthBasicAuthoritative Off
-# AuthType Basic
-# AuthName "secure area"
-# Require group staff
-# </IfModule>
+# EXAMPLE 2: authentificate against a a PAM group, so, that each user
+# beeing in this group may access this "secure area"
+#AuthPAM_Enabled on
+# If you want to make mod_auth_pam work with apache-2.2, please uncomment
+# the following line:
+#AuthBasicAuthoritative Off
+#AuthType Basic
+#AuthName "secure area"
+#Require group staff
+</IfDefine>
# vim:syntax=apache
diff --git a/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild b/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
index a6145fbfee78..b6a7ec3dd6ce 100644
--- a/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
+++ b/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.1 2007/07/29 16:15:21 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.2 2008/01/31 17:08:34 hollow Exp $
inherit eutils apache-module
@@ -37,7 +37,7 @@ src_unpack() {
src_compile() {
apache-module_src_compile
- ${APXS2} -c mod_auth_sys_group.c
+ ${APXS} -c mod_auth_sys_group.c
}
src_install() {
diff --git a/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild b/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild
index fd90201ff756..d05e3d074552 100644
--- a/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild
+++ b/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild,v 1.1 2007/07/29 16:15:21 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_pam/mod_auth_pam-1.1.1-r2.ebuild,v 1.2 2008/01/31 17:08:34 hollow Exp $
inherit eutils apache-module
@@ -37,7 +37,7 @@ src_unpack() {
src_compile() {
apache-module_src_compile
- ${APXS2} -c mod_auth_sys_group.c
+ ${APXS} -c mod_auth_sys_group.c
}
src_install() {