summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-27 17:17:24 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-27 17:17:24 +0000
commit880705fb54170ef12c424599ba0cc1eb028c1551 (patch)
treecf89cab32b8304285615d591a41b63207ca1a4bb /www-apache/mod_auth_nufw
parentCleanup. (diff)
downloadgentoo-2-880705fb54170ef12c424599ba0cc1eb028c1551.tar.gz
gentoo-2-880705fb54170ef12c424599ba0cc1eb028c1551.tar.bz2
gentoo-2-880705fb54170ef12c424599ba0cc1eb028c1551.zip
version bump; cleanup
(Portage version: 2.1.4)
Diffstat (limited to 'www-apache/mod_auth_nufw')
-rw-r--r--www-apache/mod_auth_nufw/ChangeLog10
-rw-r--r--www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf17
-rw-r--r--www-apache/mod_auth_nufw/files/digest-mod_auth_nufw-2.2.13
-rw-r--r--www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild49
4 files changed, 62 insertions, 17 deletions
diff --git a/www-apache/mod_auth_nufw/ChangeLog b/www-apache/mod_auth_nufw/ChangeLog
index b042f77691ed..dbac198cfca1 100644
--- a/www-apache/mod_auth_nufw/ChangeLog
+++ b/www-apache/mod_auth_nufw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_auth_nufw
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.4 2007/12/28 16:42:59 hollow Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.5 2008/01/27 17:17:24 hollow Exp $
+
+*mod_auth_nufw-2.2.1 (27 Jan 2008)
+
+ 27 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ files/50_mod_auth_nufw.conf, +mod_auth_nufw-2.2.1.ebuild:
+ version bump; cleanup
28 Dec 2007; Benedikt Böhm <hollow@gentoo.org>
mod_auth_nufw-2.2.0.ebuild:
diff --git a/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf b/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf
index 3b0aa0dc3f06..23e03dcf1760 100644
--- a/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf
+++ b/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf
@@ -1,18 +1,5 @@
<IfDefine AUTH_NUFW>
- <IfModule !mod_auth_nufw.c>
- LoadModule mod_auth_nufw extramodules/mod_auth_nufw.so
- </IfModule>
+LoadModule mod_auth_nufw extramodules/mod_auth_nufw.so
</IfDefine>
-<IfModule mod_auth_nufw.c>
-
-#
-#This module allows for a totally transparent, and strict, identification of users.
-#It uses Nufw as backend, performs SQL requests on the Nufw-fed SQL tables, and
-#optionnaly resolves numeric userids through a LDAP directory.
-#It also features LDAP basic caching features.
-#This module is probably of no use if not used with Nufw, as it lays
-#on a database constantly up-to-date with user network activity.
-#
-
-</IfModule>
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_auth_nufw/files/digest-mod_auth_nufw-2.2.1 b/www-apache/mod_auth_nufw/files/digest-mod_auth_nufw-2.2.1
new file mode 100644
index 000000000000..bd1b8efd0445
--- /dev/null
+++ b/www-apache/mod_auth_nufw/files/digest-mod_auth_nufw-2.2.1
@@ -0,0 +1,3 @@
+MD5 5aa5c12e753de23368a5b84b882206fa mod_auth_nufw-2.2.1.tar.gz 104300
+RMD160 87b5e86f50fa169ed9e9224405f1dd27bcc504f0 mod_auth_nufw-2.2.1.tar.gz 104300
+SHA256 fee066dd68c602dd5082691e19e419c4e451a631158611d5992e52e91df154b9 mod_auth_nufw-2.2.1.tar.gz 104300
diff --git a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild
new file mode 100644
index 000000000000..071290882413
--- /dev/null
+++ b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild,v 1.1 2008/01/27 17:17:24 hollow Exp $
+
+inherit eutils apache-module autotools
+
+DESCRIPTION="A NuFW authentication module for Apache."
+HOMEPAGE="http://software.inl.fr/trac/wiki/EdenWall/mod_auth_nufw"
+SRC_URI="http://software.inl.fr/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_FILE="mod_auth_nufw.so"
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="AUTH_NUFW"
+
+DOCFILES="doc/mod_auth_nufw.html"
+
+need_apache2_2
+
+pkg_setup() {
+ local cnt=0
+ use mysql && cnt="$((${cnt} + 1))"
+ use postgres && cnt="$((${cnt} + 1))"
+ if [[ "${cnt}" -ne 1 ]] ; then
+ eerror "You have set ${P} to use multiple SQL engines."
+ eerror "I don't know which to use!"
+ eerror "You can use /etc/portage/package.use to set per-package USE flags."
+ eerror "Set it so only one SQL engine type, mysql or postgres, is enabled."
+ die "Please set only one SQL engine type!"
+ fi
+}
+
+src_compile() {
+ CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) ${CPPFLAGS}" \
+ econf \
+ --with-apache22 \
+ --with-apxs=${APXS2} \
+ $(use_with mysql) \
+ || die "econf failed"
+ emake || die "emake failed"
+}