summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-31 17:05:34 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-31 17:05:34 +0000
commit05c4ec065aad40f41e0ad30c6eee80413a47530c (patch)
tree6cc897d6b40ea121aa4904019aecc3c250fcbaf3 /www-apache/mod_auth_nufw
parentcleanup (diff)
downloadgentoo-2-05c4ec065aad40f41e0ad30c6eee80413a47530c.tar.gz
gentoo-2-05c4ec065aad40f41e0ad30c6eee80413a47530c.tar.bz2
gentoo-2-05c4ec065aad40f41e0ad30c6eee80413a47530c.zip
fix depend.apache usage wrt #208033; fix module loading
(Portage version: 2.1.4)
Diffstat (limited to 'www-apache/mod_auth_nufw')
-rw-r--r--www-apache/mod_auth_nufw/ChangeLog7
-rw-r--r--www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf2
-rw-r--r--www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild6
-rw-r--r--www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild4
4 files changed, 12 insertions, 7 deletions
diff --git a/www-apache/mod_auth_nufw/ChangeLog b/www-apache/mod_auth_nufw/ChangeLog
index dbac198cfca1..534e881c495a 100644
--- a/www-apache/mod_auth_nufw/ChangeLog
+++ b/www-apache/mod_auth_nufw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_auth_nufw
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.5 2008/01/27 17:17:24 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.6 2008/01/31 17:05:33 hollow Exp $
+
+ 31 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ files/50_mod_auth_nufw.conf, mod_auth_nufw-2.2.0.ebuild,
+ mod_auth_nufw-2.2.1.ebuild:
+ fix depend.apache usage wrt #208033; fix module loading
*mod_auth_nufw-2.2.1 (27 Jan 2008)
diff --git a/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf b/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf
index 23e03dcf1760..6897d3b6b5ac 100644
--- a/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf
+++ b/www-apache/mod_auth_nufw/files/50_mod_auth_nufw.conf
@@ -1,5 +1,5 @@
<IfDefine AUTH_NUFW>
-LoadModule mod_auth_nufw extramodules/mod_auth_nufw.so
+LoadModule mod_auth_nufw modules/mod_auth_nufw.so
</IfDefine>
# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild
index c8272216618f..fd453d5a9039 100644
--- a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild
+++ b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild,v 1.3 2007/12/28 16:42:59 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild,v 1.4 2008/01/31 17:05:33 hollow Exp $
inherit eutils apache-module autotools
@@ -50,7 +50,7 @@ src_unpack() {
src_compile() {
CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) ${CPPFLAGS}" \
econf --with-apache22 \
- --with-apxs=${APXS2} \
+ --with-apxs=${APXS} \
$(use_with ldap ldap-uids) \
$(use_with mysql) \
|| die "econf failed"
diff --git a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild
index 071290882413..7b30499671bf 100644
--- a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild
+++ b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild,v 1.1 2008/01/27 17:17:24 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.1.ebuild,v 1.2 2008/01/31 17:05:33 hollow Exp $
inherit eutils apache-module autotools
@@ -42,7 +42,7 @@ src_compile() {
CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) ${CPPFLAGS}" \
econf \
--with-apache22 \
- --with-apxs=${APXS2} \
+ --with-apxs=${APXS} \
$(use_with mysql) \
|| die "econf failed"
emake || die "emake failed"