summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-27 21:05:45 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-27 21:05:45 +0000
commitf84764fe8847940a57f76b9cb7a6c40740089146 (patch)
tree039fce6283302ea02eaf329c69941200bc371d26 /virtual
parentAdd ruby22. (diff)
downloadgentoo-2-f84764fe8847940a57f76b9cb7a6c40740089146.tar.gz
gentoo-2-f84764fe8847940a57f76b9cb7a6c40740089146.tar.bz2
gentoo-2-f84764fe8847940a57f76b9cb7a6c40740089146.zip
New version for ruby22.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/ruby-rdoc/ChangeLog7
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-5.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/virtual/ruby-rdoc/ChangeLog b/virtual/ruby-rdoc/ChangeLog
index 99b86bbb5430..f1d7e7f69a12 100644
--- a/virtual/ruby-rdoc/ChangeLog
+++ b/virtual/ruby-rdoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/ruby-rdoc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.31 2014/10/10 09:03:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.32 2014/12/27 21:05:45 graaff Exp $
+
+*ruby-rdoc-5 (27 Dec 2014)
+
+ 27 Dec 2014; Hans de Graaff <graaff@gentoo.org> +ruby-rdoc-5.ebuild:
+ New version for ruby22.
10 Oct 2014; Hans de Graaff <graaff@gentoo.org> -ruby-rdoc-2.ebuild:
Remove masked jruby 1.6 version.
diff --git a/virtual/ruby-rdoc/ruby-rdoc-5.ebuild b/virtual/ruby-rdoc/ruby-rdoc-5.ebuild
new file mode 100644
index 000000000000..9313c0d84974
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-5.ebuild,v 1.1 2014/12/27 21:05:45 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ruby22] )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.