summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-13 23:37:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-13 23:37:28 +0000
commit55e48aeaffdb08b4a6e0b2085e3a7f0a939e60b2 (patch)
treedfcdfa51dde8e80b1db2ec8e568d88c176e182d6 /virtual
parentStable on amd64 wrt bug #332577 (diff)
downloadgentoo-2-55e48aeaffdb08b4a6e0b2085e3a7f0a939e60b2.tar.gz
gentoo-2-55e48aeaffdb08b4a6e0b2085e3a7f0a939e60b2.tar.bz2
gentoo-2-55e48aeaffdb08b4a6e0b2085e3a7f0a939e60b2.zip
Add virtual ebuild for the OpenSSL binding for all the Ruby implementations.
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/ruby-ssl/ChangeLog14
-rw-r--r--virtual/ruby-ssl/metadata.xml5
-rw-r--r--virtual/ruby-ssl/ruby-ssl-0.ebuild45
-rw-r--r--virtual/ruby-ssl/ruby-ssl-1.ebuild45
-rw-r--r--virtual/ruby-ssl/ruby-ssl-2.ebuild45
-rw-r--r--virtual/ruby-ssl/ruby-ssl-3.ebuild45
6 files changed, 199 insertions, 0 deletions
diff --git a/virtual/ruby-ssl/ChangeLog b/virtual/ruby-ssl/ChangeLog
new file mode 100644
index 000000000000..0840b7f81c8d
--- /dev/null
+++ b/virtual/ruby-ssl/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for virtual/ruby-ssl
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ChangeLog,v 1.1 2010/08/13 23:37:28 flameeyes Exp $
+
+*ruby-ssl-3 (13 Aug 2010)
+*ruby-ssl-2 (13 Aug 2010)
+*ruby-ssl-1 (13 Aug 2010)
+*ruby-ssl-0 (13 Aug 2010)
+
+ 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org> +ruby-ssl-0.ebuild,
+ +ruby-ssl-1.ebuild, +ruby-ssl-2.ebuild, +ruby-ssl-3.ebuild, +metadata.xml:
+ Add virtual ebuild for the OpenSSL binding for all the Ruby
+ implementations.
+
diff --git a/virtual/ruby-ssl/metadata.xml b/virtual/ruby-ssl/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/virtual/ruby-ssl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/virtual/ruby-ssl/ruby-ssl-0.ebuild b/virtual/ruby-ssl/ruby-ssl-0.ebuild
new file mode 100644
index 000000000000..1c6174d7ccab
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ruby-ssl-0.ebuild,v 1.1 2010/08/13 23:37:28 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/ruby:1.8[ssl]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/ruby-ssl/ruby-ssl-1.ebuild b/virtual/ruby-ssl/ruby-ssl-1.ebuild
new file mode 100644
index 000000000000..dda6edfba42b
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ruby-ssl-1.ebuild,v 1.1 2010/08/13 23:37:28 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/ruby:1.9[ssl]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/ruby-ssl/ruby-ssl-2.ebuild b/virtual/ruby-ssl/ruby-ssl-2.ebuild
new file mode 100644
index 000000000000..fb753eaf6c71
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ruby-ssl-2.ebuild,v 1.1 2010/08/13 23:37:28 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="jruby"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ruby/jruby-openssl"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/ruby-ssl/ruby-ssl-3.ebuild b/virtual/ruby-ssl/ruby-ssl-3.ebuild
new file mode 100644
index 000000000000..131960394911
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-ssl/ruby-ssl-3.ebuild,v 1.1 2010/08/13 23:37:28 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/ruby-enterprise:1.8[ssl]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.