summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-27 20:58:04 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-27 20:58:04 +0000
commitc1279d4e52d7243c3c9a46b3e9ecd76c3fcc1ca7 (patch)
treef66704608788bf93f666ec9fb8cb68c513d86828 /virtual/rubygems
parentVersion bump (diff)
downloadgentoo-2-c1279d4e52d7243c3c9a46b3e9ecd76c3fcc1ca7.tar.gz
gentoo-2-c1279d4e52d7243c3c9a46b3e9ecd76c3fcc1ca7.tar.bz2
gentoo-2-c1279d4e52d7243c3c9a46b3e9ecd76c3fcc1ca7.zip
New version for ruby22.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual/rubygems')
-rw-r--r--virtual/rubygems/ChangeLog7
-rw-r--r--virtual/rubygems/rubygems-8.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/virtual/rubygems/ChangeLog b/virtual/rubygems/ChangeLog
index b87efbd9c9ed..b1af73cf48c1 100644
--- a/virtual/rubygems/ChangeLog
+++ b/virtual/rubygems/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/rubygems
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/ChangeLog,v 1.62 2014/10/10 09:04:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/ChangeLog,v 1.63 2014/12/27 20:58:04 graaff Exp $
+
+*rubygems-8 (27 Dec 2014)
+
+ 27 Dec 2014; Hans de Graaff <graaff@gentoo.org> +rubygems-8.ebuild:
+ New version for ruby22.
10 Oct 2014; Hans de Graaff <graaff@gentoo.org> -rubygems-2.ebuild:
Remove masked jruby 1.6 version.
diff --git a/virtual/rubygems/rubygems-8.ebuild b/virtual/rubygems/rubygems-8.ebuild
new file mode 100644
index 000000000000..c1a5c14cf091
--- /dev/null
+++ b/virtual/rubygems/rubygems-8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/rubygems-8.ebuild,v 1.1 2014/12/27 20:58:04 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for rubygems"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-ruby/rubygems-2.0.14[ruby_targets_ruby22]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.