summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-05 09:10:10 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-05 09:10:10 +0000
commita0ac1c7a7b8355f92f7873645b2f5fe36c8597fb (patch)
tree01989de29e6a16a2f3177cec3dd0e195c9e65828 /virtual/ruby-threads/ruby-threads-0.ebuild
parentAdd virtual/ruby-threads to the ruby 1.9 mask. (diff)
downloadgentoo-2-a0ac1c7a7b8355f92f7873645b2f5fe36c8597fb.tar.gz
gentoo-2-a0ac1c7a7b8355f92f7873645b2f5fe36c8597fb.tar.bz2
gentoo-2-a0ac1c7a7b8355f92f7873645b2f5fe36c8597fb.zip
Virtual to be able to request a version of the ruby interpreter with threads enabled.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'virtual/ruby-threads/ruby-threads-0.ebuild')
-rw-r--r--virtual/ruby-threads/ruby-threads-0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/virtual/ruby-threads/ruby-threads-0.ebuild b/virtual/ruby-threads/ruby-threads-0.ebuild
new file mode 100644
index 000000000000..baf9abe914b5
--- /dev/null
+++ b/virtual/ruby-threads/ruby-threads-0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ruby-threads-0.ebuild,v 1.1 2011/06/05 09:10:10 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for a ruby interpreter with threading enabled."
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/ruby:1.8[threads]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.