summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-18 10:26:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-18 10:26:21 +0000
commitbba905dbd66b5bee264bd427ddb7adba6ce9e53e (patch)
tree85615fe11f14724aed5169b73426686a3a832f76 /virtual/ruby-rdoc
parentAdd another Ruby virtual with four versions. (diff)
downloadgentoo-2-bba905dbd66b5bee264bd427ddb7adba6ce9e53e.tar.gz
gentoo-2-bba905dbd66b5bee264bd427ddb7adba6ce9e53e.tar.bz2
gentoo-2-bba905dbd66b5bee264bd427ddb7adba6ce9e53e.zip
Import the rdoc virtual for Ruby.
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'virtual/ruby-rdoc')
-rw-r--r--virtual/ruby-rdoc/ChangeLog14
-rw-r--r--virtual/ruby-rdoc/metadata.xml5
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-0.ebuild45
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-1.ebuild45
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-2.ebuild45
-rw-r--r--virtual/ruby-rdoc/ruby-rdoc-3.ebuild45
6 files changed, 199 insertions, 0 deletions
diff --git a/virtual/ruby-rdoc/ChangeLog b/virtual/ruby-rdoc/ChangeLog
new file mode 100644
index 000000000000..992be2f31658
--- /dev/null
+++ b/virtual/ruby-rdoc/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for virtual/ruby-rdoc
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ChangeLog,v 1.1 2010/08/18 10:26:21 flameeyes Exp $
+
+*ruby-rdoc-3 (18 Aug 2010)
+*ruby-rdoc-2 (18 Aug 2010)
+*ruby-rdoc-1 (18 Aug 2010)
+*ruby-rdoc-0 (18 Aug 2010)
+
+ 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org> +ruby-rdoc-0.ebuild,
+ +ruby-rdoc-1.ebuild, +ruby-rdoc-2.ebuild, +ruby-rdoc-3.ebuild,
+ +metadata.xml:
+ Import the rdoc virtual for Ruby.
+
diff --git a/virtual/ruby-rdoc/metadata.xml b/virtual/ruby-rdoc/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/virtual/ruby-rdoc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/virtual/ruby-rdoc/ruby-rdoc-0.ebuild b/virtual/ruby-rdoc/ruby-rdoc-0.ebuild
new file mode 100644
index 000000000000..84527a865d00
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-0.ebuild,v 1.1 2010/08/18 10:26:21 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ruby18] dev-lang/ruby:1.8 )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/ruby-rdoc/ruby-rdoc-1.ebuild b/virtual/ruby-rdoc/ruby-rdoc-1.ebuild
new file mode 100644
index 000000000000..de870b3d9a3b
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-1.ebuild,v 1.1 2010/08/18 10:26:21 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ruby19] <dev-lang/ruby-1.9.2_rc2-r1:1.9 )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/ruby-rdoc/ruby-rdoc-2.ebuild b/virtual/ruby-rdoc/ruby-rdoc-2.ebuild
new file mode 100644
index 000000000000..ee10c3fd01ed
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-2.ebuild,v 1.1 2010/08/18 10:26:21 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="jruby"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_jruby] dev-java/jruby )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/ruby-rdoc/ruby-rdoc-3.ebuild b/virtual/ruby-rdoc/ruby-rdoc-3.ebuild
new file mode 100644
index 000000000000..afe9e9eb93e5
--- /dev/null
+++ b/virtual/ruby-rdoc/ruby-rdoc-3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-rdoc/ruby-rdoc-3.ebuild,v 1.1 2010/08/18 10:26:21 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for bundled and unbundled RDoc"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-ruby/rdoc[ruby_targets_ree18] dev-lang/ruby-enterprise )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.