summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-06-24 22:11:25 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-06-24 22:11:25 +0000
commite0d2ad5a49914f75c734af2abac096a9e0b167c7 (patch)
tree7dea8ecb569d6703c849aa23d7fbbd7628196fc8 /sys-process
parentVersion bump (diff)
downloadgentoo-2-e0d2ad5a49914f75c734af2abac096a9e0b167c7.tar.gz
gentoo-2-e0d2ad5a49914f75c734af2abac096a9e0b167c7.tar.bz2
gentoo-2-e0d2ad5a49914f75c734af2abac096a9e0b167c7.zip
Another debug fix, bug 372911.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog6
-rw-r--r--sys-process/htop/files/htop-0.9-debug.patch31
-rw-r--r--sys-process/htop/htop-0.9.ebuild6
3 files changed, 39 insertions, 4 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index a492e3612c94..2583f36e1b6c 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.89 2011/06/24 19:59:48 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.90 2011/06/24 22:11:25 idl0r Exp $
+
+ 24 Jun 2011; Christian Ruppert <idl0r@gentoo.org> htop-0.9.ebuild,
+ +files/htop-0.9-debug.patch:
+ Another debug fix, bug 372911.
24 Jun 2011; Christian Ruppert <idl0r@gentoo.org> htop-0.9.ebuild,
metadata.xml:
diff --git a/sys-process/htop/files/htop-0.9-debug.patch b/sys-process/htop/files/htop-0.9-debug.patch
new file mode 100644
index 000000000000..a1aa1b9ea3ec
--- /dev/null
+++ b/sys-process/htop/files/htop-0.9-debug.patch
@@ -0,0 +1,31 @@
+--- trunk/DebugMemory.c 2006/11/08 20:40:10 66
++++ trunk/DebugMemory.c 2011/03/22 20:37:08 216
+@@ -90,7 +90,7 @@
+ return data;
+ }
+
+-void* DebugMemory_strdup(char* str, char* file, int line) {
++void* DebugMemory_strdup(const char* str, char* file, int line) {
+ assert(str);
+ char* data = strdup(str);
+ DebugMemory_registerAllocation(data, file, line);
+@@ -102,7 +102,7 @@
+ }
+
+ void DebugMemory_free(void* data, char* file, int line) {
+- assert(data);
++ if (!data) return;
+ DebugMemory_registerDeallocation(data, file, line);
+ if (singleton->file) {
+ if (singleton->totals) fprintf(singleton->file, "%d\t", singleton->size);
+--- trunk/Process.c 2010/11/22 12:40:20 206
++++ trunk/Process.c 2011/03/22 20:37:08 216
+@@ -471,7 +471,7 @@
+ RichString_setAttr(out, CRT_colors[PROCESS_SHADOW]);
+ if (this->tag == true)
+ RichString_setAttr(out, CRT_colors[PROCESS_TAG]);
+- assert(out->len > 0);
++ assert(out->chlen > 0);
+ }
+
+ void Process_delete(Object* cast) {
diff --git a/sys-process/htop/htop-0.9.ebuild b/sys-process/htop/htop-0.9.ebuild
index f24d06b7f05e..f945644c092a 100644
--- a/sys-process/htop/htop-0.9.ebuild
+++ b/sys-process/htop/htop-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.9.ebuild,v 1.4 2011/06/24 19:59:49 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.9.ebuild,v 1.5 2011/06/24 22:11:25 idl0r Exp $
EAPI=3
@@ -38,8 +38,8 @@ src_prepare() {
sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
scripts/MakeHeader.py || die
- # bug 352024
- sed -i -e 's:assert(out->len > 0);:assert(out->chlen > 0);:' Process.c || die
+ # bug 352024, 372911
+ epatch "${FILESDIR}/${P}-debug.patch"
}
src_configure() {