summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-19 14:47:30 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-19 14:47:30 +0000
commitd5dd25a7a970657aa1adee6112775ea81cd96cf7 (patch)
tree8cfc35dff4e61e82d90703210ec706b8d30138ff /sys-process
parentold (diff)
downloadgentoo-2-d5dd25a7a970657aa1adee6112775ea81cd96cf7.tar.gz
gentoo-2-d5dd25a7a970657aa1adee6112775ea81cd96cf7.tar.bz2
gentoo-2-d5dd25a7a970657aa1adee6112775ea81cd96cf7.zip
Fix default crontab file and push it out #98189.
(Portage version: 2.2_rc60/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/dcron/ChangeLog8
-rw-r--r--sys-process/dcron/dcron-3.2-r1.ebuild51
-rw-r--r--sys-process/dcron/files/crontab18
3 files changed, 64 insertions, 13 deletions
diff --git a/sys-process/dcron/ChangeLog b/sys-process/dcron/ChangeLog
index 047e7ce8fdb6..ca48aad37888 100644
--- a/sys-process/dcron/ChangeLog
+++ b/sys-process/dcron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/dcron
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/ChangeLog,v 1.14 2009/05/12 20:59:20 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/ChangeLog,v 1.15 2009/12/19 14:47:28 vapier Exp $
+
+*dcron-3.2-r1 (19 Dec 2009)
+
+ 19 Dec 2009; Mike Frysinger <vapier@gentoo.org> +dcron-3.2-r1.ebuild,
+ files/crontab:
+ Fix default crontab file and push it out #98189.
12 May 2009; Thilo Bangert <bangert@gentoo.org> files/dcron.confd,
files/dcron.init:
diff --git a/sys-process/dcron/dcron-3.2-r1.ebuild b/sys-process/dcron/dcron-3.2-r1.ebuild
new file mode 100644
index 000000000000..6328726e1bb3
--- /dev/null
+++ b/sys-process/dcron/dcron-3.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/dcron-3.2-r1.ebuild,v 1.1 2009/12/19 14:47:28 vapier Exp $
+
+inherit cron toolchain-funcs
+
+DESCRIPTION="A cute little cron from Matt Dillon"
+HOMEPAGE="http://apollo.backplane.com/FreeSrc/"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${PV//.}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/dcron-2.9-Makefile.patch
+ epatch "${FILESDIR}"/dcron-3.2-pidfile.patch
+ epatch "${FILESDIR}"/dcron-2.9-EDITOR.patch
+ epatch "${FILESDIR}"/${P}-build.patch #181043
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE # for asprintf()
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ docrondir
+ docron crond -m0700 -o root -g wheel
+ docrontab
+
+ dodoc CHANGELOG README "${FILESDIR}"/crontab
+ doman crontab.1 crond.8
+
+ newinitd "${FILESDIR}"/dcron.init dcron
+ newconfd "${FILESDIR}"/dcron.confd dcron
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/dcron.logrotate dcron
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+}
diff --git a/sys-process/dcron/files/crontab b/sys-process/dcron/files/crontab
index 29a7ead6766a..afee25203a6a 100644
--- a/sys-process/dcron/files/crontab
+++ b/sys-process/dcron/files/crontab
@@ -1,5 +1,5 @@
# for dcron
-# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/files/crontab,v 1.2 2009/05/12 09:18:29 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/dcron/files/crontab,v 1.3 2009/12/19 14:47:30 vapier Exp $
# dcron:
# This is NOT the system crontab! dcron does not support a system crontab.
@@ -8,15 +8,9 @@
# as root.
# NOTE: This will REPLACE root's current crontab!!
-# Global variables
-SHELL=/bin/bash
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-MAILTO=root
-HOME=/
-
# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
-59 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
-9 3 * * * root rm -f /var/spool/cron/lastrun/cron.daily
-19 4 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
-29 5 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
-*/10 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+59 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+9 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
+19 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+29 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+*/10 * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons