summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-14 00:06:16 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-14 00:06:16 +0000
commita134629eaede19178dcf8935f4aed1cfba3912c7 (patch)
tree888a5d3fa7c33f3fc79c36216f1df39e7fbddfa8 /sys-process
parentRe-introduce ruby-ssl dependency now that is in tree indeed. (diff)
downloadgentoo-2-a134629eaede19178dcf8935f4aed1cfba3912c7.tar.gz
gentoo-2-a134629eaede19178dcf8935f4aed1cfba3912c7.tar.bz2
gentoo-2-a134629eaede19178dcf8935f4aed1cfba3912c7.zip
Version bump #332215 by Michal Fojtik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/ChangeLog10
-rw-r--r--sys-process/numactl/files/numactl-2.0.5-protos.patch12
-rw-r--r--sys-process/numactl/numactl-2.0.5.ebuild48
3 files changed, 68 insertions, 2 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index 31c395e3931f..f7d911b0e1f0 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/numactl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.13 2009/12/22 23:24:25 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.14 2010/08/14 00:06:16 vapier Exp $
+
+*numactl-2.0.5 (14 Aug 2010)
+
+ 14 Aug 2010; Mike Frysinger <vapier@gentoo.org> +numactl-2.0.5.ebuild,
+ +files/numactl-2.0.5-protos.patch:
+ Version bump #332215 by Michal Fojtik.
22 Dec 2009; Robin H. Johnson <robbat2@gentoo.org> numactl-2.0.2.ebuild:
Update src_test for minimal kernels without some parts of sysfs.
diff --git a/sys-process/numactl/files/numactl-2.0.5-protos.patch b/sys-process/numactl/files/numactl-2.0.5-protos.patch
new file mode 100644
index 000000000000..1f1bedc5e0fa
--- /dev/null
+++ b/sys-process/numactl/files/numactl-2.0.5-protos.patch
@@ -0,0 +1,12 @@
+fix missing fstat64() prototype
+
+--- a/shm.c
++++ b/shm.c
+@@ -25,6 +25,7 @@
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+ #include <sys/fcntl.h>
++#include <sys/stat.h>
+ #include <stdarg.h>
+ #include <errno.h>
+ #include <unistd.h>
diff --git a/sys-process/numactl/numactl-2.0.5.ebuild b/sys-process/numactl/numactl-2.0.5.ebuild
new file mode 100644
index 000000000000..ee79da848096
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.5.ebuild,v 1.1 2010/08/14 00:06:16 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-protos.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" BENCH_CFLAGS="" || die
+}
+
+src_test() {
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+}
+
+src_install() {
+ emake install prefix="${D}/usr" || die
+ # delete man pages provided by the man-pages package #238805
+ rm -rf "${D}"/usr/share/man/man[25]
+ doman *.8 || die # makefile doesnt get them all
+ dodoc README TODO CHANGES DESIGN
+ if ! use perl ; then
+ rm "${D}"/usr/bin/numastat "${D}"/usr/share/man/man8/numastat.8 || die
+ fi
+}