summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2007-10-27 21:21:48 +0000
committerThilo Bangert <bangert@gentoo.org>2007-10-27 21:21:48 +0000
commit983604efb1a954975d79e38ba8b830b340402506 (patch)
tree08a378206c06931d3026bf069fd11ae2368afb23 /sys-process
parentmore crons than vixie support the system crontab - bug #89213 (diff)
downloadgentoo-2-983604efb1a954975d79e38ba8b830b340402506.tar.gz
gentoo-2-983604efb1a954975d79e38ba8b830b340402506.tar.bz2
gentoo-2-983604efb1a954975d79e38ba8b830b340402506.zip
fix quoting - use the cron eclass
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/bcron/ChangeLog5
-rw-r--r--sys-process/bcron/bcron-0.09.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/sys-process/bcron/ChangeLog b/sys-process/bcron/ChangeLog
index 030039735f2a..774a7ec85c06 100644
--- a/sys-process/bcron/ChangeLog
+++ b/sys-process/bcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/bcron
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/ChangeLog,v 1.8 2007/10/10 08:45:58 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/ChangeLog,v 1.9 2007/10/27 21:21:48 bangert Exp $
+
+ 27 Oct 2007; Thilo Bangert <bangert@gentoo.org> bcron-0.09.ebuild:
+ fix quoting - use eclass
10 Oct 2007; Christian Faulhammer <opfer@gentoo.org> bcron-0.09.ebuild:
stable x86, bug 195303
diff --git a/sys-process/bcron/bcron-0.09.ebuild b/sys-process/bcron/bcron-0.09.ebuild
index 54794a846626..05a704bfd509 100644
--- a/sys-process/bcron/bcron-0.09.ebuild
+++ b/sys-process/bcron/bcron-0.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/bcron-0.09.ebuild,v 1.7 2007/10/10 08:45:58 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/bcron-0.09.ebuild,v 1.8 2007/10/27 21:21:48 bangert Exp $
CRON_SYSTEM_CRONTAB="yes"
@@ -30,7 +30,7 @@ src_compile() {
echo "${D}/usr/bin" > conf-bin
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
- make || die "make failed"
+ make || die "make failed" #no emake b/c jobserver
}
src_install() {
@@ -59,7 +59,7 @@ src_install() {
dodir /etc/bcron
insinto /etc
- doins ${FILESDIR}/crontab
+ doins "${FILESDIR}"/crontab
insinto /var/lib/supervise/bcron
doins bcron-sched.run
@@ -75,27 +75,27 @@ src_install() {
}
pkg_config() {
- cd /var/lib/supervise/bcron
+ cd "${ROOT}"var/lib/supervise/bcron
[ -e run ] && cp run bcron-sched.run.`date +%Y%m%d%H%M%S`
cp bcron-sched.run run
chmod u+x run
- cd /var/lib/supervise/bcron/log
+ cd "${ROOT}"/var/lib/supervise/bcron/log
[ -e run ] && cp run bcron-sched-log.run.`date +%Y%m%d%H%M%S`
cp bcron-sched-log.run run
chmod u+x run
- cd /var/lib/supervise/bcron-spool
+ cd "${ROOT}"/var/lib/supervise/bcron-spool
[ -e run ] && cp run bcron-spool.run.`date +%Y%m%d%H%M%S`
cp bcron-spool.run run
chmod u+x run
- cd /var/lib/supervise/bcron-update
+ cd "${ROOT}"/var/lib/supervise/bcron-update
[ -e run ] && cp run bcron-update.run.`date +%Y%m%d%H%M%S`
cp bcron-update.run run
chmod u+x run
- [ ! -e /var/spool/cron/trigger ] && mkfifo /var/spool/cron/trigger
+ [ ! -e "${ROOT}"/var/spool/cron/trigger ] && mkfifo "${ROOT}"var/spool/cron/trigger
chown cron:cron /var/spool/cron/trigger
chmod go-rwx /var/spool/cron/trigger
}
@@ -109,5 +109,5 @@ pkg_postinst() {
elog " /var/lib/supervise/bcron-spool (crontab receiver) and"
elog " /var/lib/supervise/bcron-update (system crontab updater)"
-# cron_pkg_postinst
+ cron_pkg_postinst
}