summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-10 15:48:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-10 15:48:41 +0000
commit97c26adaa8d0ade025f2bd8bd9015d7eb052d574 (patch)
tree92036547a14a79219c580f5d19b850b99538d9a4 /sys-process
parentold (diff)
downloadgentoo-2-97c26adaa8d0ade025f2bd8bd9015d7eb052d574.tar.gz
gentoo-2-97c26adaa8d0ade025f2bd8bd9015d7eb052d574.tar.bz2
gentoo-2-97c26adaa8d0ade025f2bd8bd9015d7eb052d574.zip
Version bump wrt #461272 by Roman Žilka
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procps/ChangeLog8
-rw-r--r--sys-process/procps/files/procps-3.3.6-error_at_line.patch12
-rw-r--r--sys-process/procps/procps-3.3.6.ebuild47
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 19454cadc2cc..6810e307a284 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/procps
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.78 2013/03/10 15:38:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.79 2013/03/10 15:48:41 ssuominen Exp $
+
+*procps-3.3.6 (10 Mar 2013)
+
+ 10 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> +procps-3.3.6.ebuild,
+ +files/procps-3.3.6-error_at_line.patch:
+ Version bump wrt #461272 by Roman Žilka
10 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
-files/3.2.5-top-sort.patch, -procps-3.2.8.ebuild, -procps-3.2.8-r1.ebuild,
diff --git a/sys-process/procps/files/procps-3.3.6-error_at_line.patch b/sys-process/procps/files/procps-3.3.6-error_at_line.patch
new file mode 100644
index 000000000000..4329a49666d9
--- /dev/null
+++ b/sys-process/procps/files/procps-3.3.6-error_at_line.patch
@@ -0,0 +1,12 @@
+ps/display.c:65:7: warning: implicit declaration of function ‘error_at_line’ [-Wimplicit-function-declaration]
+
+--- ps/display.c
++++ ps/display.c
+@@ -25,6 +25,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <error.h> /* error_at_line */
+
+ #include <sys/sysmacros.h>
+ #include <sys/types.h>
diff --git a/sys-process/procps/procps-3.3.6.ebuild b/sys-process/procps/procps-3.3.6.ebuild
new file mode 100644
index 000000000000..7a71af4b746c
--- /dev/null
+++ b/sys-process/procps/procps-3.3.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.6.ebuild,v 1.1 2013/03/10 15:48:41 ssuominen Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="standard informational utilities and process-handling tools"
+# http://packages.debian.org/sid/procps
+HOMEPAGE="http://procps.sourceforge.net/ http://gitorious.org/procps"
+# SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.xz
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}-ng/${PN}-ng-${PV}.tar.xz/0a050d9be531921db3cd38f1371e73e3/${PN}-ng-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="+ncurses static-libs unicode"
+
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.7-r7[unicode?] )"
+DEPEND="${RDEPEND}
+ ncurses? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/${PN}-ng-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-error_at_line.patch
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}/" \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ $(use_with ncurses) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode watch8bit)
+}
+
+src_install() {
+ default
+# dodoc sysctl.conf
+
+ # The configure script is completely whacked in the head
+ mv "${ED}"/lib* "${ED}"/usr/ || die
+ gen_usr_ldscript -a procps
+ prune_libtool_files
+}