summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-01 08:04:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-01 08:04:14 +0000
commit926e5d6346f485126c1a1b0c7a2ebfb071a5a73e (patch)
treea776d287406edf2ebaae02c8c6a231a61be926f9 /sys-process
parentFixing missing unzip dep, closes #283209 (diff)
downloadgentoo-2-926e5d6346f485126c1a1b0c7a2ebfb071a5a73e.tar.gz
gentoo-2-926e5d6346f485126c1a1b0c7a2ebfb071a5a73e.tar.bz2
gentoo-2-926e5d6346f485126c1a1b0c7a2ebfb071a5a73e.zip
Bump to 0.8.3, fixes #282523
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog9
-rw-r--r--sys-process/htop/htop-0.8.3.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index fac3cf42a64c..eee979ac27a9 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.75 2009/06/13 12:40:41 gentoofan23 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.76 2009/09/01 08:04:14 patrick Exp $
+
+*htop-0.8.3 (01 Sep 2009)
+
+ 01 Sep 2009; Patrick Lauer <patrick@gentoo.org> +htop-0.8.3.ebuild:
+ Bump to 0.8.3, fixes #282523
*htop-0.8.2 (13 Jun 2009)
diff --git a/sys-process/htop/htop-0.8.3.ebuild b/sys-process/htop/htop-0.8.3.ebuild
new file mode 100644
index 000000000000..198e2898dfe5
--- /dev/null
+++ b/sys-process/htop/htop-0.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.3.ebuild,v 1.1 2009/09/01 08:04:14 patrick Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="sys-libs/ncurses[unicode]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use elibc_FreeBSD && ! [[ -f "${ROOT}"/proc/stat && -f "${ROOT}"/proc/meminfo ]] ; then
+ eerror
+ eerror "htop needs /proc mounted to compile and work, to mount it type"
+ eerror "mount -t linprocfs none /proc"
+ eerror "or uncomment the example in /etc/fstab"
+ eerror
+ die "htop needs /proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof ; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.1-non-printable-char-filter.patch
+}
+
+src_configure() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf \
+ --enable-taskstats \
+ --enable-unicode
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO || die "documentation installation failed."
+ rmdir "${D}"/usr/{include,$(get_libdir)} || die "Removing empty directory failed."
+}