summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-10-10 19:18:37 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-10-10 19:18:37 +0000
commit8fb0c14c3d297d3f1ace2a207afa7cf4216a75ca (patch)
tree22abc1b86e5dd1c0cd69fde6278574cb47b68939 /sys-process
parentAdd a wifi USE flag to pull in wpa_supplicant only for that case (#473180 by ... (diff)
downloadgentoo-2-8fb0c14c3d297d3f1ace2a207afa7cf4216a75ca.tar.gz
gentoo-2-8fb0c14c3d297d3f1ace2a207afa7cf4216a75ca.tar.bz2
gentoo-2-8fb0c14c3d297d3f1ace2a207afa7cf4216a75ca.zip
Version bump as requested by "teidakankan" in bug #483076. Rediffed existing cross-compile & nogets patches. Texi fix is by Dmitrijs Ledkovs and from Debian bug #696204.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/acct/ChangeLog11
-rw-r--r--sys-process/acct/acct-6.6.1.ebuild45
-rw-r--r--sys-process/acct/files/acct-6.6.1-cross-compile.patch314
-rw-r--r--sys-process/acct/files/acct-6.6.1-no-gets.patch14
-rw-r--r--sys-process/acct/files/acct-6.6.1-texi-failure.patch32
5 files changed, 415 insertions, 1 deletions
diff --git a/sys-process/acct/ChangeLog b/sys-process/acct/ChangeLog
index a2974a6c5290..d3f912291505 100644
--- a/sys-process/acct/ChangeLog
+++ b/sys-process/acct/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-process/acct
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/ChangeLog,v 1.68 2013/10/09 13:39:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/ChangeLog,v 1.69 2013/10/10 19:18:37 chainsaw Exp $
+
+*acct-6.6.1 (10 Oct 2013)
+
+ 10 Oct 2013; Tony Vroon <chainsaw@gentoo.org> +acct-6.6.1.ebuild,
+ +files/acct-6.6.1-cross-compile.patch, +files/acct-6.6.1-no-gets.patch,
+ +files/acct-6.6.1-texi-failure.patch:
+ Version bump as requested by "teidakankan" in bug #483076. Rediffed existing
+ cross-compile & nogets patches. Texi fix is by Dmitrijs Ledkovs and from
+ Debian bug #696204.
09 Oct 2013; Jeroen Roovers <jer@gentoo.org> acct-6.5.5-r3.ebuild:
Stable for HPPA (bug #485338).
diff --git a/sys-process/acct/acct-6.6.1.ebuild b/sys-process/acct/acct-6.6.1.ebuild
new file mode 100644
index 000000000000..0419c6096227
--- /dev/null
+++ b/sys-process/acct/acct-6.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/acct-6.6.1.ebuild,v 1.1 2013/10/10 19:18:37 chainsaw Exp $
+
+EAPI=5
+inherit autotools base systemd
+
+DESCRIPTION="GNU system accounting utilities"
+HOMEPAGE="https://savannah.gnu.org/projects/acct/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+PATCHES=( "${FILESDIR}/${P}-cross-compile.patch"
+ "${FILESDIR}/${P}-no-gets.patch"
+ "${FILESDIR}/${P}-texi-failure.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-linux-multiformat
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+ keepdir /var/account
+ newinitd "${FILESDIR}"/acct.initd acct
+ newconfd "${FILESDIR}"/acct.confd acct
+ systemd_dounit "${FILESDIR}"/acct.service
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/acct.logrotate acct
+
+ # sys-apps/sysvinit already provides this
+ rm "${ED}"/usr/bin/last "${ED}"/usr/share/man/man1/last.1 || die
+
+ # accton in / is only a temp workaround for #239748
+ dodir /sbin
+ mv "${ED}"/usr/sbin/accton "${ED}"/sbin/ || die
+}
diff --git a/sys-process/acct/files/acct-6.6.1-cross-compile.patch b/sys-process/acct/files/acct-6.6.1-cross-compile.patch
new file mode 100644
index 000000000000..4dbfcfb33ebc
--- /dev/null
+++ b/sys-process/acct/files/acct-6.6.1-cross-compile.patch
@@ -0,0 +1,314 @@
+diff -uNr acct-6.6.1.ORIG/configure.ac acct-6.6.1/configure.ac
+--- acct-6.6.1.ORIG/configure.ac 2013-10-10 20:00:31.581225736 +0100
++++ acct-6.6.1/configure.ac 2013-10-10 20:03:42.393231583 +0100
+@@ -228,102 +228,6 @@
+ AC_EGREP_HEADER([comp_t],[sys/acct.h],[AC_DEFINE(HAVE_COMP_T, 1, Define if <sys/acct.h> uses the COMP_T type.)])
+ ) ]
+ )
+-dnl
+-dnl find out where utmp/pacct are stored
+-dnl
+-AC_RUN_IFELSE([AC_LANG_SOURCE([[
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <sys/types.h>
+-#include <stdint.h> /* GNU/kFreeBSD */
+-#include <sys/acct.h>
+-#include <utmp.h>
+-
+-#ifndef WTMP_FILE
+-# if defined(__FreeBSD__) || defined (__NetBSD__) || defined(__linux__) \
+- || defined(__FreeBSD_kernel__) || defined(__GLIBC__)
+-# define WTMP_FILE "/var/log/account/wtmp"
+-# else
+-# if defined(sun) || defined(AMIX)
+-# define WTMP_FILE "/var/adm/wtmp"
+-# else
+-# if defined(sgi) || defined(SVR4)
+-# define WTMP_FILE "/usr/adm/wtmp"
+-# else
+-# define WTMP_FILE "/usr/adm/wtmp"
+-# endif
+-# endif
+-# endif
+-#endif
+-
+-#ifndef ACCT_FILE
+-# if defined(__FreeBSD__) || defined(__linux__) \
+- || defined(__FreeBSD_kernel__) || defined(__GLIBC__)
+-# define ACCT_FILE "/var/log/account/pacct"
+-# else
+-# if defined(__NetBSD__)
+-# define ACCT_FILE "/var/log/account/acct"
+-# else
+-# if defined(sun) || defined(AMIX)
+-# define ACCT_FILE "/var/adm/pacct"
+-# else
+-# if defined(sgi) || defined(SVR4) || defined(M_XENIX)
+-# define ACCT_FILE "/usr/adm/pacct"
+-# else
+-# define ACCT_FILE "/usr/adm/acct"
+-# endif
+-# endif
+-# endif
+-# endif
+-#endif
+-
+-#ifndef SAVACCT_FILE
+-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__linux__) \
+- || defined(__FreeBSD_kernel__) || defined(__GLIBC__)
+-# define SAVACCT_FILE "/var/log/account/savacct"
+-# else
+-# if defined(sun) || defined(AMIX)
+-# define SAVACCT_FILE "/var/adm/savacct"
+-# else
+-# if defined(sgi) || defined(SVR4)
+-# define SAVACCT_FILE "/usr/adm/savacct"
+-# else
+-# define SAVACCT_FILE "/usr/adm/savacct"
+-# endif
+-# endif
+-# endif
+-#endif
+-
+-#ifndef USRACCT_FILE
+-# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__linux__) \
+- || defined(__FreeBSD_kernel__) || defined(__GLIBC__)
+-# define USRACCT_FILE "/var/log/account/usracct"
+-# else
+-# if defined(sun) || defined(AMIX)
+-# define USRACCT_FILE "/var/adm/usracct"
+-# else
+-# if defined(sgi) || defined(SVR4)
+-# define USRACCT_FILE "/usr/adm/usracct"
+-# else
+-# define USRACCT_FILE "/usr/adm/usracct"
+-# endif
+-# endif
+-# endif
+-#endif
+-
+-main ()
+-{
+- FILE *fp;
+- fp = fopen ("locs", "w");
+- fprintf (fp, "WTMP_FILE_LOC=%s\n", WTMP_FILE);
+- fprintf (fp, "ACCT_FILE_LOC=%s\n", ACCT_FILE);
+- fprintf (fp, "SAVACCT_FILE_LOC=%s\n", SAVACCT_FILE);
+- fprintf (fp, "USRACCT_FILE_LOC=%s\n", USRACCT_FILE);
+- fclose (fp);
+- exit(0);
+-}
+-]])],[. ./locs; rm locs],[echo "Error -- could not locate your wtmp and acct files."; exit 1],[echo "Sorry -- you cannot cross-compile this package (FIXME)."; exit 1 ])
+-
+ dnl types
+ AC_TYPE_PID_T dnl for sys/acct.h
+ AC_TYPE_UID_T dnl same as above
+@@ -366,12 +270,6 @@
+ AC_SUBST(LASTCOMM_MAN)
+ AC_SUBST(SA_MAN)
+
+-dnl Substitutions for file locations
+-AC_SUBST(WTMP_FILE_LOC)
+-AC_SUBST(ACCT_FILE_LOC)
+-AC_SUBST(SAVACCT_FILE_LOC)
+-AC_SUBST(USRACCT_FILE_LOC)
+-
+ dnl Dump the makefiles and etc.
+-AC_CONFIG_FILES([Makefile lib/Makefile files.h version.h])
++AC_CONFIG_FILES([Makefile lib/Makefile version.h])
+ AC_OUTPUT
+diff -uNr acct-6.6.1.ORIG/files.h acct-6.6.1/files.h
+--- acct-6.6.1.ORIG/files.h 1970-01-01 01:00:00.000000000 +0100
++++ acct-6.6.1/files.h 2013-10-10 20:01:36.314227720 +0100
+@@ -0,0 +1,123 @@
++/* files.h
++ *
++ * file locations
++ *
++ */
++
++#ifndef FILES_H
++#define FILES_H
++
++#include "config.h"
++
++#include <stdio.h>
++#include <stdlib.h>
++#include <sys/types.h>
++#include <stdint.h> /* GNU/kFreeBSD */
++
++#ifdef LINUX_MULTIFORMAT
++# include "linux-acct.h"
++#else
++# include <stdint.h> /* GNU/kFreeBSD */
++# include <sys/acct.h>
++# if defined __FreeBSD__ || defined __FreeBSD_kernel__
++# include <osreldate.h>
++# if __FreeBSD_kernel__
++# define __FreeBSD_version __FreeBSD_kernel_version
++# endif /* __FreeBSD_kernel__ */
++# if __FreeBSD_version >= 700100 /* FreeBSD 7.0-STABLE */
++# define acct acctv2
++# define ac_flag ac_flagx
++# endif
++# endif
++#endif
++
++#include <utmp.h>
++
++#ifndef WTMP_FILE
++# if defined(__FreeBSD__) || defined (__NetBSD__) || defined(__linux__) \
++ || defined(__FreeBSD_kernel__)
++# define WTMP_FILE "/var/log/wtmp"
++# else
++# if defined(sun) || defined(AMIX)
++# define WTMP_FILE "/var/adm/wtmp"
++# else
++# if defined(sgi) || defined(SVR4)
++# define WTMP_FILE "/usr/adm/wtmp"
++# else
++# define WTMP_FILE "/usr/adm/wtmp"
++# endif
++# endif
++# endif
++#endif
++
++#ifndef ACCT_FILE
++# if defined(__FreeBSD__) || defined(__linux__) \
++ || defined(__FreeBSD_kernel__)
++# define ACCT_FILE "/var/account/pacct"
++# else
++# if defined(__NetBSD__)
++# define ACCT_FILE "/var/account/acct"
++# else
++# if defined(sun) || defined(AMIX)
++# define ACCT_FILE "/var/adm/pacct"
++# else
++# if defined(sgi) || defined(SVR4) || defined(M_XENIX)
++# define ACCT_FILE "/usr/adm/pacct"
++# else
++# define ACCT_FILE "/usr/adm/acct"
++# endif
++# endif
++# endif
++# endif
++#endif
++
++#ifndef SAVACCT_FILE
++# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__linux__) \
++ || defined(__FreeBSD_kernel__)
++# define SAVACCT_FILE "/var/account/savacct"
++# else
++# if defined(sun) || defined(AMIX)
++# define SAVACCT_FILE "/var/adm/savacct"
++# else
++# if defined(sgi) || defined(SVR4)
++# define SAVACCT_FILE "/usr/adm/savacct"
++# else
++# define SAVACCT_FILE "/usr/adm/savacct"
++# endif
++# endif
++# endif
++#endif
++
++#ifndef USRACCT_FILE
++# if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__linux__) \
++ || defined(__FreeBSD_kernel__)
++# define USRACCT_FILE "/var/account/usracct"
++# else
++# if defined(sun) || defined(AMIX)
++# define USRACCT_FILE "/var/adm/usracct"
++# else
++# if defined(sgi) || defined(SVR4)
++# define USRACCT_FILE "/usr/adm/usracct"
++# else
++# define USRACCT_FILE "/usr/adm/usracct"
++# endif
++# endif
++# endif
++#endif
++
++#define WTMP_FILE_LOC WTMP_FILE
++#define ACCT_FILE_LOC ACCT_FILE
++#define SAVACCT_FILE_LOC SAVACCT_FILE
++#define USRACCT_FILE_LOC USRACCT_FILE
++
++/* Workaround for a kernel includes problem */
++#if defined(__linux__) && defined(__alpha__)
++#undef AHZ
++#define AHZ 1024
++#endif
++
++#ifndef AHZ
++#define AHZ 64
++#endif
++
++#endif /* ! FILES_H */
+diff -uNr acct-6.6.1.ORIG/files.h.in acct-6.6.1/files.h.in
+--- acct-6.6.1.ORIG/files.h.in 2013-10-10 20:00:31.584225736 +0100
++++ acct-6.6.1/files.h.in 1970-01-01 01:00:00.000000000 +0100
+@@ -1,48 +0,0 @@
+-/* files.h.in
+- *
+- * file locations
+- *
+- */
+-
+-#ifndef FILES_H
+-#define FILES_H
+-
+-#include "config.h"
+-
+-#include <sys/types.h>
+-
+-#ifdef LINUX_MULTIFORMAT
+-# include "linux-acct.h"
+-#else
+-# include <stdint.h> /* GNU/kFreeBSD */
+-# include <sys/acct.h>
+-# if defined __FreeBSD__ || defined __FreeBSD_kernel__
+-# include <osreldate.h>
+-# if __FreeBSD_kernel__
+-# define __FreeBSD_version __FreeBSD_kernel_version
+-# endif /* __FreeBSD_kernel__ */
+-# if __FreeBSD_version >= 700100 /* FreeBSD 7.0-STABLE */
+-# define acct acctv2
+-# define ac_flag ac_flagx
+-# endif
+-# endif
+-#endif
+-
+-#include <utmp.h>
+-
+-#define WTMP_FILE_LOC "@WTMP_FILE_LOC@"
+-#define ACCT_FILE_LOC "@ACCT_FILE_LOC@"
+-#define SAVACCT_FILE_LOC "@SAVACCT_FILE_LOC@"
+-#define USRACCT_FILE_LOC "@USRACCT_FILE_LOC@"
+-
+-/* Workaround for a kernel includes problem */
+-#if defined(__linux__) && defined(__alpha__)
+-#undef AHZ
+-#define AHZ 1024
+-#endif
+-
+-#ifndef AHZ
+-#define AHZ 64
+-#endif
+-
+-#endif /* ! FILES_H */
+diff -uNr acct-6.6.1.ORIG/Makefile.am acct-6.6.1/Makefile.am
+--- acct-6.6.1.ORIG/Makefile.am 2013-10-10 20:00:31.585225736 +0100
++++ acct-6.6.1/Makefile.am 2013-10-10 20:01:36.313227720 +0100
+@@ -66,11 +66,6 @@
+ SYS_AC = @SYS_AC@
+ SYS_SA = @SYS_SA@
+
+-WTMP_FILE_LOC = @WTMP_FILE_LOC@
+-ACCT_FILE_LOC = @ACCT_FILE_LOC@
+-SAVACCT_FILE_LOC = @SAVACCT_FILE_LOC@
+-USRACCT_FILE_LOC = @USRACCT_FILE_LOC@
+-
+ compare-ac: ac
+ @echo
+ @echo "Running tests for ac"
diff --git a/sys-process/acct/files/acct-6.6.1-no-gets.patch b/sys-process/acct/files/acct-6.6.1-no-gets.patch
new file mode 100644
index 000000000000..6362122b7ca5
--- /dev/null
+++ b/sys-process/acct/files/acct-6.6.1-no-gets.patch
@@ -0,0 +1,14 @@
+diff -uNr acct-6.6.1.ORIG/lib/stdio.in.h acct-6.6.1/lib/stdio.in.h
+--- acct-6.6.1.ORIG/lib/stdio.in.h 2013-10-10 20:06:21.740236465 +0100
++++ acct-6.6.1/lib/stdio.in.h 2013-10-10 20:08:09.969239782 +0100
+@@ -699,10 +699,6 @@
+ so any use of gets warrants an unconditional warning; besides, C11
+ removed it. */
+ #undef gets
+-#if HAVE_RAW_DECL_GETS
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-#endif
+-
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
+ struct obstack;
diff --git a/sys-process/acct/files/acct-6.6.1-texi-failure.patch b/sys-process/acct/files/acct-6.6.1-texi-failure.patch
new file mode 100644
index 000000000000..aa9f3c3586b8
--- /dev/null
+++ b/sys-process/acct/files/acct-6.6.1-texi-failure.patch
@@ -0,0 +1,32 @@
+Description: Fix FTBFS with new texinfo.
+Author: Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
+
+--- acct-6.5.5.orig/accounting.texi
++++ acct-6.5.5/accounting.texi
+@@ -66,7 +66,7 @@ approved by the Foundation.
+ @end titlepage
+
+ @c ----------------------------------------------------------------------
+-@ifinfo
++@ifnottex
+ @node Top, Preface, (dir), (dir)
+
+ Welcome to the GNU Accounting Utilities! If you don't have a clue about
+@@ -77,7 +77,7 @@ program's name.
+ This is Edition @value{EDITION} of the documentation, updated
+ @value{UPDATED} for version @value{VERSION} of the GNU Accounting
+ Utilities.
+-@end ifinfo
++@end ifnottex
+
+ @menu
+ * Preface:: general information about the accounting utilities
+@@ -468,7 +468,7 @@ overhead, it is forseeable that the entr
+ wrong order. GNU @code{ac} automatically compensates for this, but some
+ other @code{ac}s may not... beware.
+
+-@unnumberedsubsubsec The FTP Problem
++@unnumberedsubsec The FTP Problem
+
+ I've tested the standard @code{ac} in Ultrix 4.2 (DECstation/DECsystem),
+ SunOS 4.1.1 (Sun3, Sun4, Sparc), Mach 2.5 (Omron/Luna), and DomainOS