summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-02 02:19:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-02 02:19:45 +0000
commit8d98764a8091be25df973a3e8424c6451c790fca (patch)
treedb90f2d3539f5e3a8a9ecf14760afa280bbad13e /sys-process
parentold (diff)
downloadgentoo-2-8d98764a8091be25df973a3e8424c6451c790fca.tar.gz
gentoo-2-8d98764a8091be25df973a3e8424c6451c790fca.tar.bz2
gentoo-2-8d98764a8091be25df973a3e8424c6451c790fca.zip
Version bump again.
(Portage version: 2.1.3.11)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/ChangeLog7
-rw-r--r--sys-process/audit/audit-1.6.2.ebuild88
-rw-r--r--sys-process/audit/files/digest-audit-1.6.23
3 files changed, 97 insertions, 1 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index 6ccccb9d8577..38799b655109 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/audit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.25 2007/10/02 01:48:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.26 2007/10/02 02:19:44 robbat2 Exp $
+
+*audit-1.6.2 (02 Oct 2007)
+
+ 02 Oct 2007; Robin H. Johnson <robbat2@gentoo.org> +audit-1.6.2.ebuild:
+ Version bump again.
*audit-1.6.1 (02 Oct 2007)
diff --git a/sys-process/audit/audit-1.6.2.ebuild b/sys-process/audit/audit-1.6.2.ebuild
new file mode 100644
index 000000000000..3989dada1bd8
--- /dev/null
+++ b/sys-process/audit/audit-1.6.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-1.6.2.ebuild,v 1.1 2007/10/02 02:19:44 robbat2 Exp $
+
+inherit autotools multilib toolchain-funcs python
+
+DESCRIPTION="Userspace utilities for storing and processing auditing records"
+HOMEPAGE="http://people.redhat.com/sgrubb/audit/"
+SRC_URI="http://people.redhat.com/sgrubb/audit/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ >=sys-kernel/linux-headers-2.6.22-r2"
+# Do not use os-headers as this is linux specific
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Old patch applies fine
+ EPATCH_OPTS="-p0 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-build.patch
+
+ # Applied by upstream
+ #EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-swig-gcc-attribute.patch
+
+ # Do not build GUI tools
+ sed -i -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' ${S}/configure.ac
+ sed -i -e 's,system-config-audit,,g' -e '/^SUBDIRS/s,\\$,,g' ${S}/Makefile.am
+ rm -rf "${S}"/system-config-audit
+
+ # Regenerate autotooling
+ eautoreconf
+}
+
+src_compile() {
+ #append-flags -D'__attribute__(x)='
+ econf --sbindir=/sbin || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README* THANKS TODO contrib/*
+
+ newinitd "${FILESDIR}"/auditd-init.d-1.2.3 auditd
+ newconfd "${FILESDIR}"/auditd-conf.d-1.2.3 auditd
+
+ # things like shadow use this so we need to be in /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libaudit.so libauparse.so
+
+ # remove RedHat garbage
+ rm -r "${D}"/etc/{rc.d,sysconfig} || die
+
+ # Gentoo rules
+ insinto /etc/audit/
+ doins "${FILESDIR}"/audit.rules*
+
+ # audit logs go here
+ keepdir /var/log/audit/
+
+ # Security
+ lockdown_perms "${D}"
+}
+
+pkg_postinst() {
+ lockdown_perms "${ROOT}"
+ python_mod_optimize
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
+
+lockdown_perms() {
+ # upstream wants these to have restrictive perms
+ basedir="$1"
+ chmod 0750 "${basedir}"/sbin/au{ditctl,report,dispd,ditd,search,trace} 2>/dev/null
+ chmod 0750 "${basedir}"/var/log/audit/ 2>/dev/null
+ chmod 0640 "${basedir}"/etc/{audit/,}{auditd.conf,audit.rules*} 2>/dev/null
+}
diff --git a/sys-process/audit/files/digest-audit-1.6.2 b/sys-process/audit/files/digest-audit-1.6.2
new file mode 100644
index 000000000000..d4424a8936c3
--- /dev/null
+++ b/sys-process/audit/files/digest-audit-1.6.2
@@ -0,0 +1,3 @@
+MD5 a95dbfa22e65669e4449f3accbe84aef audit-1.6.2.tar.gz 776148
+RMD160 e22d294e797f1903bfc10a7ef116f0b8123d2488 audit-1.6.2.tar.gz 776148
+SHA256 c8168604d14ccbd0db3f8972035fe7e4363925a4aa6b2998d973af659796de5c audit-1.6.2.tar.gz 776148