summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-11 11:45:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-11 11:45:41 +0000
commit87bf45985b5097e762d4df8563232c4e84f71ba8 (patch)
treead331094ff71af6d69fcf13c795237d5ad8946de /sys-process
parentversion bump. (diff)
downloadgentoo-2-87bf45985b5097e762d4df8563232c4e84f71ba8.tar.gz
gentoo-2-87bf45985b5097e762d4df8563232c4e84f71ba8.tar.bz2
gentoo-2-87bf45985b5097e762d4df8563232c4e84f71ba8.zip
Version bump.
(Portage version: 2.2_rc56/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/psmisc/ChangeLog7
-rw-r--r--sys-process/psmisc/files/psmisc-22.2-gcc2.patch40
-rw-r--r--sys-process/psmisc/files/psmisc-22.5-sockets.patch87
-rw-r--r--sys-process/psmisc/files/psmisc-22.5-user-header.patch11
-rw-r--r--sys-process/psmisc/psmisc-22.5-r2.ebuild52
-rw-r--r--sys-process/psmisc/psmisc-22.8.ebuild (renamed from sys-process/psmisc/psmisc-22.6.ebuild)14
6 files changed, 12 insertions, 199 deletions
diff --git a/sys-process/psmisc/ChangeLog b/sys-process/psmisc/ChangeLog
index a049c4044e1f..720a8cc43988 100644
--- a/sys-process/psmisc/ChangeLog
+++ b/sys-process/psmisc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/psmisc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.90 2009/10/31 14:17:59 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.91 2009/12/11 11:45:40 ssuominen Exp $
+
+*psmisc-22.8 (11 Dec 2009)
+
+ 11 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> +psmisc-22.8.ebuild:
+ Version bump wrt #296498.
31 Oct 2009; Brent Baude <ranger@gentoo.org> psmisc-22.7.ebuild:
Marking psmisc-22.7 ppc64 for bug 287739
diff --git a/sys-process/psmisc/files/psmisc-22.2-gcc2.patch b/sys-process/psmisc/files/psmisc-22.2-gcc2.patch
deleted file mode 100644
index 181fb78b9c98..000000000000
--- a/sys-process/psmisc/files/psmisc-22.2-gcc2.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-cheesy ass workaround for gcc-2:
-i686-pc-linux-gnu-gcc -Wall -DLOCALEDIR=\"/usr/share/locale\" -march=i686 -O2 -pipe -o pstree pstree.o -lncurses
-fuser.c:103: warning: preprocessing directive not recognized within macro arg
-fuser.c:103: warning: preprocessing directive not recognized within macro arg
-fuser.c:103: warning: preprocessing directive not recognized within macro arg
-fuser.c:103: warning: preprocessing directive not recognized within macro arg
-fuser.c:103: warning: preprocessing directive not recognized within macro arg
-fuser.c:103: warning: preprocessing directive not recognized within macro arg
-fuser.c: In function `usage':
-fuser.c:98: undefined or invalid # directive
-fuser.c:101: undefined or invalid # directive
-make[3]: *** [fuser.o] Error 1
-
---- src/fuser.c
-+++ src/fuser.c
-@@ -82,6 +82,11 @@ static void usage (const char *errormsg)
- if (errormsg != NULL)
- fprintf(stderr, "%s\n", errormsg);
-
-+#ifdef WITH_IPV6
-+# define _IPv6(x) x
-+#else
-+# define _IPv6(x)
-+#endif
- fprintf (stderr, _(
- "Usage: fuser [ -a | -s | -c ] [ -n SPACE ] [ -SIGNAL ] [ -kimuv ] NAME...\n"
- " [ - ] [ -n SPACE ] [ -SIGNAL ] [ -kimuv ] NAME...\n"
-@@ -101,10 +106,10 @@ static void usage (const char *errormsg)
- " -u display user IDs\n"
- " -v verbose output\n"
- " -V display version information\n"
--#ifdef WITH_IPV6
-+_IPv6(
- " -4 search IPv4 sockets only\n"
- " -6 search IPv6 sockets only\n"
--#endif
-+)
- " - reset options\n\n"
- " udp/tcp names: [local_port][,[rmt_host][,[rmt_port]]]\n\n"));
- exit (1);
diff --git a/sys-process/psmisc/files/psmisc-22.5-sockets.patch b/sys-process/psmisc/files/psmisc-22.5-sockets.patch
deleted file mode 100644
index 99ea96828aa2..000000000000
--- a/sys-process/psmisc/files/psmisc-22.5-sockets.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-=== modified file 'src/fuser.c'
---- src/fuser.c 2007-05-30 13:45:07 +0000
-+++ src/fuser.c 2007-05-30 13:48:30 +0000
-@@ -60,7 +60,8 @@
- #define NAME_FIELD 20 /* space reserved for file name */
- /* Function defines */
- static void add_matched_proc(struct names *name_list, const pid_t pid, const uid_t uid, const char access);
--static void check_dir(const pid_t pid, const char *dirname, struct device_list *dev_head, struct inode_list *ino_head, const uid_t uid, const char access);
-+static void check_dir(const pid_t pid, const char *dirname, struct device_list *dev_head, struct inode_list *ino_head, const uid_t uid, const char access,
-+ struct unixsocket_list *sockets, dev_t netdev);
- static void check_map(const pid_t pid, const char *filename, struct device_list *dev_head, struct inode_list *ino_head, const uid_t uid, const char access);
- static struct stat *get_pidstat(const pid_t pid, const char *filename);
- static uid_t getpiduid(const pid_t pid);
-@@ -72,7 +73,7 @@
- void scan_mount_devices(const opt_type opts, struct mountdev_list **mount_devices);
- void fill_unix_cache(struct unixsocket_list **unixsocket_head);
- static dev_t find_net_dev(void);
--static void scan_procs(struct names *names_head, struct inode_list *ino_head, struct device_list *dev_head);
-+static void scan_procs(struct names *names_head, struct inode_list *ino_head, struct device_list *dev_head, struct unixsocket_list *sockets, dev_t netdev);
- #ifdef NFS_CHECKS
- static void scan_knfsd(struct names *names_head, struct device_list *dev_head);
- #endif /* NFS_CHECKS */
-@@ -125,7 +126,7 @@
- "For more information about these matters, see the files named COPYING.\n"));
- }
-
--static void scan_procs(struct names *names_head, struct inode_list *ino_head, struct device_list *dev_head)
-+static void scan_procs(struct names *names_head, struct inode_list *ino_head, struct device_list *dev_head, struct unixsocket_list *sockets, dev_t netdev)
- {
- DIR *topproc_dir;
- struct dirent *topproc_dent;
-@@ -185,9 +186,9 @@
- }
- }
- }
-- check_dir(pid, "lib", dev_head, ino_head, uid, ACCESS_MMAP);
-- check_dir(pid, "mmap", dev_head, ino_head, uid, ACCESS_MMAP);
-- check_dir(pid, "fd", dev_head, ino_head, uid, ACCESS_FILE);
-+ check_dir(pid, "lib", dev_head, ino_head, uid, ACCESS_MMAP, sockets, netdev);
-+ check_dir(pid, "mmap", dev_head, ino_head, uid, ACCESS_MMAP, sockets, netdev);
-+ check_dir(pid, "fd", dev_head, ino_head, uid, ACCESS_FILE, sockets, netdev);
- check_map(pid, "maps", dev_head, ino_head, uid, ACCESS_MMAP);
-
- } /* while topproc_dent */
-@@ -863,7 +864,7 @@
- #ifdef DEBUG
- debug_match_lists(names_head, match_inodes, match_devices);
- #endif
-- scan_procs(names_head, match_inodes, match_devices);
-+ scan_procs(names_head, match_inodes, match_devices, unixsockets, netdev);
- #ifdef NFS_CHECKS
- scan_knfsd(names_head, match_devices);
- #endif /* NFS_CHECKS */
-@@ -983,13 +984,15 @@
- return st;
- }
-
--static void check_dir(const pid_t pid, const char *dirname, struct device_list *dev_head, struct inode_list *ino_head, const uid_t uid, const char access)
-+static void check_dir(const pid_t pid, const char *dirname, struct device_list *dev_head, struct inode_list *ino_head, const uid_t uid, const char access,
-+ struct unixsocket_list *sockets, dev_t netdev)
- {
- char *dirpath, *filepath;
- DIR *dirp;
- struct dirent *direntry;
- struct inode_list *ino_tmp;
- struct device_list *dev_tmp;
-+ struct unixsocket_list *sock_tmp;
- struct stat st, lst;
-
- if ( (dirpath = malloc(MAX_PATHNAME)) == NULL)
-@@ -1009,6 +1012,15 @@
- if (stat(filepath, &st) != 0) {
- fprintf(stderr, _("Cannot stat file %s: %s\n"),filepath, strerror(errno));
- } else {
-+ if (st.st_dev == netdev) {
-+ for (sock_tmp = sockets; sock_tmp != NULL; sock_tmp = sock_tmp->next) {
-+ if (sock_tmp->net_inode == st.st_ino) {
-+ st.st_ino = sock_tmp->inode;
-+ st.st_dev = sock_tmp->dev;
-+ break;
-+ }
-+ }
-+ }
- for (dev_tmp = dev_head ; dev_tmp != NULL ; dev_tmp = dev_tmp->next) {
- if (st.st_dev == dev_tmp->device) {
- if (access == ACCESS_FILE && (lstat(filepath, &lst)==0) && (lst.st_mode & S_IWUSR)) {
-
diff --git a/sys-process/psmisc/files/psmisc-22.5-user-header.patch b/sys-process/psmisc/files/psmisc-22.5-user-header.patch
deleted file mode 100644
index c982dde795fa..000000000000
--- a/sys-process/psmisc/files/psmisc-22.5-user-header.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/peekfd.c
-+++ src/peekfd.c
-@@ -26,7 +26,7 @@
- #include <sys/ptrace.h>
- #include <sys/types.h>
- #include <sys/wait.h>
--#include <linux/user.h>
-+#include <sys/user.h>
- #include <stdlib.h>
- #include <getopt.h>
- #include <ctype.h>
diff --git a/sys-process/psmisc/psmisc-22.5-r2.ebuild b/sys-process/psmisc/psmisc-22.5-r2.ebuild
deleted file mode 100644
index b6fea3d0bce6..000000000000
--- a/sys-process/psmisc/psmisc-22.5-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.5-r2.ebuild,v 1.11 2007/10/06 14:14:01 vapier Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="A set of tools that use the proc filesystem"
-HOMEPAGE="http://psmisc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="ipv6 nls selinux X"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-22.2-gcc2.patch
- epatch "${FILESDIR}"/${P}-user-header.patch
- epatch "${FILESDIR}"/${P}-sockets.patch
- # this package doesnt actually need C++
- sed -i '/AC_PROG_CXX/d' configure.ac || die
- use nls || epatch "${FILESDIR}"/${P}-no-nls.patch #193920
- eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_enable selinux) \
- $(use_enable nls) \
- $(use_enable ipv6) \
- || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog NEWS README
- use X || rm "${D}"/usr/bin/pstree.x11
- # fuser is needed by init.d scripts
- dodir /bin
- mv "${D}"/usr/bin/fuser "${D}"/bin/ || die
- # easier to do this than forcing regen of autotools
- [[ -e ${D}/usr/bin/peekfd ]] || rm -f "${D}"/usr/share/man/man1/peekfd.1
-}
diff --git a/sys-process/psmisc/psmisc-22.6.ebuild b/sys-process/psmisc/psmisc-22.8.ebuild
index 7f9af055ea29..cb0b8d77c7e6 100644
--- a/sys-process/psmisc/psmisc-22.6.ebuild
+++ b/sys-process/psmisc/psmisc-22.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.6.ebuild,v 1.8 2009/05/14 18:16:53 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.8.ebuild,v 1.1 2009/12/11 11:45:40 ssuominen Exp $
inherit eutils autotools
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="ipv6 nls selinux X"
RDEPEND=">=sys-libs/ncurses-5.2-r2
@@ -22,9 +22,6 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-22.5-sockets.patch
- # this package doesnt actually need C++
- sed -i '/AC_PROG_CXX/d' configure.ac || die
use nls || epatch "${FILESDIR}"/${PN}-22.5-no-nls.patch #193920
eautoreconf
}
@@ -34,15 +31,16 @@ src_compile() {
# above when USE=-nls. this should get cleaned up so we dont have to patch
# it out, but until then, let's not confuse users ... #220787
econf \
+ --disable-dependency-tracking \
$(use_enable selinux) \
- $(use nls && use_enable nls) \
$(use_enable ipv6) \
- || die
+ $(use nls && use_enable nls)
+
emake || die
}
src_install() {
- emake install DESTDIR="${D}" || die
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README
use X || rm "${D}"/usr/bin/pstree.x11
# fuser is needed by init.d scripts