summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-04-14 15:57:05 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-04-14 15:57:05 +0000
commit7fd17e3bc27f65a109a424d68f905caa55a294d5 (patch)
treebe9c254588722ff9d0f2a7341ee0ad990f12219b /sys-process
parentAdd libXpm location, remove virtual/x11, thanks to Martin Salzer <stoky at gm... (diff)
downloadgentoo-2-7fd17e3bc27f65a109a424d68f905caa55a294d5.tar.gz
gentoo-2-7fd17e3bc27f65a109a424d68f905caa55a294d5.tar.bz2
gentoo-2-7fd17e3bc27f65a109a424d68f905caa55a294d5.zip
fix bug #174349
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog5
-rwxr-xr-xsys-process/fcron/files/fcron.init6
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index c3c6f2595667..c3a174906db1 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/fcron
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.39 2007/04/13 11:42:40 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.40 2007/04/14 15:57:05 wschlich Exp $
+
+ 14 Apr 2007; Wolfram Schlich <wschlich@gentoo.org> files/fcron.init:
+ fix bug #174349
13 Apr 2007; Wolfram Schlich <wschlich@gentoo.org> fcron-3.0.2-r2.ebuild:
really use upstream default spooldir (/var/spool/fcron instead of
diff --git a/sys-process/fcron/files/fcron.init b/sys-process/fcron/files/fcron.init
index 30d5e0405888..e57421a97b8f 100755
--- a/sys-process/fcron/files/fcron.init
+++ b/sys-process/fcron/files/fcron.init
@@ -1,20 +1,20 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/files/fcron.init,v 1.2 2007/02/13 16:33:57 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/files/fcron.init,v 1.3 2007/04/14 15:57:05 wschlich Exp $
depend() {
use logger slapd mysql postgresql
need clock hostname
# provide the cron service if we are the main instance
- if [ "${SVCNAME}" == "fcron" ]; then
+ if [ "${SVCNAME}" = "fcron" ]; then
provide cron
fi
}
checkconfig() {
FCRON_INSTANCE=${SVCNAME##*.}
- if [[ -n "${FCRON_INSTANCE}" && "${SVCNAME}" != "fcron" ]]; then
+ if [ -n "${FCRON_INSTANCE}" -a "${SVCNAME}" != "fcron" ]; then
FCRON_CONF=/etc/fcron/fcron.${FCRON_INSTANCE}.conf
else
FCRON_CONF=/etc/fcron/fcron.conf