summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-07 03:12:43 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-07 03:12:43 +0000
commit7d8eba57392e4d87b360ed7d796ceb844c568a5f (patch)
tree3e78eb473f56ba9b928eea0e168805cd53294683 /sys-process
parentFix mozilla/firefox deps, bug 204682 (diff)
downloadgentoo-2-7d8eba57392e4d87b360ed7d796ceb844c568a5f.tar.gz
gentoo-2-7d8eba57392e4d87b360ed7d796ceb844c568a5f.tar.bz2
gentoo-2-7d8eba57392e4d87b360ed7d796ceb844c568a5f.zip
Version bump.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/ChangeLog10
-rw-r--r--sys-process/numactl/files/digest-numactl-1.0.23
-rw-r--r--sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff34
-rw-r--r--sys-process/numactl/numactl-1.0.2.ebuild45
4 files changed, 90 insertions, 2 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index c61210560bde..53424cc32354 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/numactl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.4 2007/05/11 08:59:20 robbat2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.5 2008/01/07 03:12:42 vapier Exp $
+
+*numactl-1.0.2 (07 Jan 2008)
+
+ 07 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/numactl-1.0.2-migrate_pages-fix.diff, +numactl-1.0.2.ebuild:
+ Version bump.
*numactl-0.9.11 (11 May 2007)
diff --git a/sys-process/numactl/files/digest-numactl-1.0.2 b/sys-process/numactl/files/digest-numactl-1.0.2
new file mode 100644
index 000000000000..6caef27a1cef
--- /dev/null
+++ b/sys-process/numactl/files/digest-numactl-1.0.2
@@ -0,0 +1,3 @@
+MD5 392a5bc3e79f016edcaee0cb6ceadf90 numactl-1.0.2.tar.gz 49927
+RMD160 775fcc70348f54c57c3cfa152643d58ec8010f58 numactl-1.0.2.tar.gz 49927
+SHA256 328ca8a25dc6ded2f8a4e28134f587a13b95aedf7cd0d6836c2a33a40ecc7941 numactl-1.0.2.tar.gz 49927
diff --git a/sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff b/sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff
new file mode 100644
index 000000000000..e2fb26476863
--- /dev/null
+++ b/sys-process/numactl/files/numactl-1.0.2-migrate_pages-fix.diff
@@ -0,0 +1,34 @@
+Date: Thu, 1 Nov 2007 21:32:25 +0900
+From: Paul Mundt <lethal@linux-sh.org>
+To: Andi Kleen <ak@suse.de>
+Subject: [PATCH] numactl: Fix bogus __NR_migrate_pages reference.
+Message-ID: <20071101123225.GA28035@linux-sh.org>
+MIME-Version: 1.0
+Content-Type: text/plain; charset=us-ascii
+Content-Disposition: inline
+User-Agent: Mutt/1.5.13 (2006-08-11)
+Status: RO
+
+syscall.c does a bunch of ifdefs to make sure a platform has all of the
+syscall numbers defined in the headers or falls back on provided
+defaults. Unfortunately __NR_migrate_pages was wrong (it was written as
+NR_migratepages), so the common definitions were never picked up.
+
+Signed-off-by: Paul Mundt <lethal@linux-sh.org>
+
+---
+
+ syscall.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- numactl-1.0.2.orig/syscall.c 2007-08-16 23:36:23.000000000 +0900
++++ numactl-1.0.2/syscall.c 2007-11-01 21:22:47.000000000 +0900
+@@ -23,7 +23,7 @@
+ #define WEAK __attribute__((weak))
+
+ #if !defined(__NR_mbind) || !defined(__NR_set_mempolicy) || \
+- !defined(__NR_get_mempolicy) || !defined(NR_migratepages)
++ !defined(__NR_get_mempolicy) || !defined(__NR_migrate_pages)
+
+ #if defined(__x86_64__)
+
diff --git a/sys-process/numactl/numactl-1.0.2.ebuild b/sys-process/numactl/numactl-1.0.2.ebuild
new file mode 100644
index 000000000000..8e0ab2abad48
--- /dev/null
+++ b/sys-process/numactl/numactl-1.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-1.0.2.ebuild,v 1.1 2008/01/07 03:12:42 vapier Exp $
+
+inherit base eutils toolchain-funcs
+
+DESCRIPTION="Utilities and libraries for NUMA systems."
+HOMEPAGE="ftp://ftp.suse.com/pub/people/ak/numa/"
+SRC_URI="ftp://ftp.suse.com/pub/people/ak/numa/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ sys-apps/groff"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/numactl-1.0.2-migrate_pages-fix.diff
+ sed -i 's:/man2:/man5:' Makefile || die
+}
+
+src_compile() {
+ emake all html \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake install prefix="${D}/usr" || die
+ doman *.8 || die # makefile doesnt get them all
+ dodoc README TODO CHANGES DESIGN
+ dohtml html/*html
+}
+
+src_test() {
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+}