summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-02-02 12:08:04 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-02-02 12:08:04 +0000
commit681936d358a78f701a4c2af453ca5803fe0ca7e6 (patch)
tree853e627884ba0b736cf35b1643b3aadf264a0149 /sys-process
parentCleanup vulnerable version, bug #498760 (diff)
downloadgentoo-2-681936d358a78f701a4c2af453ca5803fe0ca7e6.tar.gz
gentoo-2-681936d358a78f701a4c2af453ca5803fe0ca7e6.tar.bz2
gentoo-2-681936d358a78f701a4c2af453ca5803fe0ca7e6.zip
Added selinux (bug #499010) and systemd (bug #498888) support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procps/ChangeLog7
-rw-r--r--sys-process/procps/procps-3.3.9-r1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 5fa6c997c347..3d07406f395b 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/procps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.115 2014/01/18 03:51:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.116 2014/02/02 12:08:04 polynomial-c Exp $
+
+*procps-3.3.9-r1 (02 Feb 2014)
+
+ 02 Feb 2014; Lars Wendler <polynomial-c@gentoo.org> +procps-3.3.9-r1.ebuild:
+ Added selinux (bug #499010) and systemd (bug #498888) support.
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> procps-3.3.8-r2.ebuild,
procps-3.3.9.ebuild:
diff --git a/sys-process/procps/procps-3.3.9-r1.ebuild b/sys-process/procps/procps-3.3.9-r1.ebuild
new file mode 100644
index 000000000000..071724961197
--- /dev/null
+++ b/sys-process/procps/procps-3.3.9-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.9-r1.ebuild,v 1.1 2014/02/02 12:08:04 polynomial-c Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="standard informational utilities and process-handling tools"
+# http://packages.debian.org/sid/procps
+HOMEPAGE="http://procps.sourceforge.net/ http://gitorious.org/procps"
+# SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.xz"
+FEDORA_HASH="0980646fa25e0be58f7afb6b98f79d74"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}-ng/${PN}-ng-${PV}.tar.xz/${FEDORA_HASH}/${PN}-ng-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="+ncurses nls selinux static-libs systemd test unicode"
+
+RDEPEND="!<sys-apps/sysvinit-2.88-r6
+ ncurses? ( >=sys-libs/ncurses-5.7-r7[unicode?] )
+ systemd? ( >=sys-apps/systemd-206 )"
+DEPEND="${RDEPEND}
+ ncurses? ( virtual/pkgconfig )
+ selinux? ( sys-libs/libselinux )
+ systemd? ( virtual/pkgconfig )
+ test? ( dev-util/dejagnu )"
+
+S=${WORKDIR}/${PN}-ng-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3.8-kill-neg-pid.patch
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}" \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ $(use_with ncurses) \
+ $(use_enable nls) \
+ $(use_enable selinux libselinux) \
+ $(use_enable static-libs static) \
+ $(use_with systemd) \
+ $(use_enable unicode watch8bit)
+}
+
+src_install() {
+ default
+# dodoc sysctl.conf
+
+ mv "${ED}"/usr/bin/pidof "${ED}"/bin/ || die
+
+ # The configure script is completely whacked in the head
+ mv "${ED}"/lib* "${ED}"/usr/ || die
+ gen_usr_ldscript -a procps
+ prune_libtool_files
+}