summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-01-31 19:13:33 +0000
committerThilo Bangert <bangert@gentoo.org>2009-01-31 19:13:33 +0000
commit648f7ddf9fe161254b58270e226441778fc1b58b (patch)
tree386c7036031ba114086746da43e16cdc50235a94 /sys-process
parentBump to 2.3.28. Use GIO, bug fixes. (diff)
downloadgentoo-2-648f7ddf9fe161254b58270e226441778fc1b58b.tar.gz
gentoo-2-648f7ddf9fe161254b58270e226441778fc1b58b.tar.bz2
gentoo-2-648f7ddf9fe161254b58270e226441778fc1b58b.zip
version bump - fixes for bugs #229203, #238335, #244884 and #252970
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/ChangeLog12
-rw-r--r--sys-process/at/at-3.1.10.2.ebuild64
-rw-r--r--sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch12
-rw-r--r--sys-process/at/files/at-3.1.10.2-configure.in-fix-PAM-automagick-dep.patch18
-rw-r--r--sys-process/at/files/at.pamd10
5 files changed, 114 insertions, 2 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index 3b7f633a6c9c..d7b9c3004df3 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-process/at
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.13 2008/10/29 12:45:26 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.14 2009/01/31 19:13:33 bangert Exp $
+
+*at-3.1.10.2 (31 Jan 2009)
+
+ 31 Jan 2009; Thilo Bangert <bangert@gentoo.org>
+ +files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch,
+ +files/at-3.1.10.2-configure.in-fix-PAM-automagick-dep.patch,
+ +files/at.pamd, +at-3.1.10.2.ebuild:
+ version bump - fixes for bugs #229203, #238335, #244884 and #252970
29 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> at-3.1.10.1.ebuild:
Force -j1, see bug #244884.
diff --git a/sys-process/at/at-3.1.10.2.ebuild b/sys-process/at/at-3.1.10.2.ebuild
new file mode 100644
index 000000000000..f24eaccf7c3a
--- /dev/null
+++ b/sys-process/at/at-3.1.10.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.2.ebuild,v 1.1 2009/01/31 19:13:33 bangert Exp $
+
+inherit eutils flag-o-matic autotools pam
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/at_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+DEPEND="virtual/mta
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.10.1-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${P}-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${P}-configure.in-fix-PAM-automagick-dep.patch
+
+ # fixing version string shown on "at -V" - bug #252970
+ sed -e "/^VERSION=/s:3\.1\.9:${PV}:" -i "${S}"/configure.in \
+ || die "sed configure.in failed"
+ eautoconf
+}
+
+src_compile() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install IROOT="${D}" || die
+
+ newinitd "${FILESDIR}"/atd.rc6 atd
+ newpamd "${FILESDIR}"/at.pamd at
+ prepalldocs
+}
diff --git a/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch b/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch
new file mode 100644
index 000000000000..8fd82e639b05
--- /dev/null
+++ b/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur at-3.1.10.2.orig/Makefile.in at-3.1.10.2/Makefile.in
+--- at-3.1.10.2.orig/Makefile.in 2009-01-31 15:38:54.000000000 +0100
++++ at-3.1.10.2/Makefile.in 2009-01-31 15:39:22.000000000 +0100
+@@ -78,7 +78,7 @@
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+-lex.yy.c: parsetime.l
++lex.yy.c: parsetime.l y.tab.h
+ $(LEX) -i parsetime.l
+
+ atrun: atrun.in
diff --git a/sys-process/at/files/at-3.1.10.2-configure.in-fix-PAM-automagick-dep.patch b/sys-process/at/files/at-3.1.10.2-configure.in-fix-PAM-automagick-dep.patch
new file mode 100644
index 000000000000..108fc930e025
--- /dev/null
+++ b/sys-process/at/files/at-3.1.10.2-configure.in-fix-PAM-automagick-dep.patch
@@ -0,0 +1,18 @@
+diff -Naur at-3.1.10.2.orig/configure.in at-3.1.10.2/configure.in
+--- at-3.1.10.2.orig/configure.in 2009-01-31 15:38:54.000000000 +0100
++++ at-3.1.10.2/configure.in 2009-01-31 17:01:00.000000000 +0100
+@@ -79,8 +79,13 @@
+ AC_FUNC_VPRINTF
+ AC_FUNC_GETLOADAVG
+ AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
+-AC_CHECK_HEADERS(security/pam_appl.h, [PAMLIB="-lpam"
++
++AC_ARG_WITH([pam], AS_HELP_STRING([--without-pam], [Build without PAM support(default: enabled)]))
++
++if test "x$with_pam" != "xno"; then
++ AC_CHECK_HEADERS(security/pam_appl.h, [PAMLIB="-lpam"
+ AC_DEFINE(HAVE_PAM)])
++fi
+
+ dnl Checking for programs
+
diff --git a/sys-process/at/files/at.pamd b/sys-process/at/files/at.pamd
new file mode 100644
index 000000000000..2d5d00e74540
--- /dev/null
+++ b/sys-process/at/files/at.pamd
@@ -0,0 +1,10 @@
+#
+# The PAM configuration file for the at daemon
+#
+
+auth required pam_env.so
+@include common-auth
+@include common-account
+@include common-session
+session required pam_limits.so
+