summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-26 03:34:13 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-26 03:34:13 +0000
commit644d3ae3427cc4c118832ef18c31c276c25b0e52 (patch)
treebea928f53b2d943e91ccd7efd40d24de3ed80b03 /sys-process
parentarm/s390/sh stable (diff)
downloadgentoo-2-644d3ae3427cc4c118832ef18c31c276c25b0e52.tar.gz
gentoo-2-644d3ae3427cc4c118832ef18c31c276c25b0e52.tar.bz2
gentoo-2-644d3ae3427cc4c118832ef18c31c276c25b0e52.zip
Version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/ChangeLog7
-rw-r--r--sys-process/lsof/lsof-4.81.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index d0c08a38f41d..513b06ff29d6 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.50 2008/10/03 16:50:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.51 2008/10/26 03:34:13 vapier Exp $
+
+*lsof-4.81 (26 Oct 2008)
+
+ 26 Oct 2008; Mike Frysinger <vapier@gentoo.org> +lsof-4.81.ebuild:
+ Version bump.
*lsof-4.80-r1 (03 Oct 2008)
diff --git a/sys-process/lsof/lsof-4.81.ebuild b/sys-process/lsof/lsof-4.81.ebuild
new file mode 100644
index 000000000000..0d371db49874
--- /dev/null
+++ b/sys-process/lsof/lsof-4.81.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.81.ebuild,v 1.1 2008/10/26 03:34:13 vapier Exp $
+
+inherit eutils flag-o-matic fixheadtails toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
+SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.bz2"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ unpack ./${MY_P}_src.tar
+
+ # now patch the scripts to automate everything
+ cd "${S}"
+ ht_fix_file Configure Customize
+ touch .neverInv
+ epatch "${FILESDIR}"/${PN}-4.78-answer-config.patch
+ #Fix automagic dependency on libselinux. Bug 188272.
+ if ! use selinux; then
+ sed -i \
+ -e 's/ -DHASSELINUX//' \
+ -e 's/ -lselinux//' \
+ Configure || die "Sed failed. 404. WTF..."
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local target="linux"
+ use kernel_FreeBSD && target=freebsd
+ ./Configure ${target} || die "configure failed"
+
+ # Make sure we use proper toolchain
+ sed -i \
+ -e "/^CC=/s:cc:$(tc-getCC):" \
+ -e "/^AR=/s:ar:$(tc-getAR):" \
+ -e "/^RANLIB=/s:ranlib:$(tc-getRANLIB):" \
+ Makefile lib/Makefile
+
+ emake DEBUG="" all || die "emake failed"
+}
+
+src_install() {
+ dobin lsof || die "dosbin"
+
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+
+ doman lsof.8
+ dodoc 00*
+}