summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 06:38:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 06:38:24 +0000
commit235373cc31114153fdef8054dac65c6338ce095f (patch)
tree426061a1027b64abb11b95c2d3fc8870ab7ebb70 /sys-process
parentold (diff)
downloadgentoo-2-235373cc31114153fdef8054dac65c6338ce095f.tar.gz
gentoo-2-235373cc31114153fdef8054dac65c6338ce095f.tar.bz2
gentoo-2-235373cc31114153fdef8054dac65c6338ce095f.zip
Fix pkg_setup().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop/iotop-0.4.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-process/iotop/iotop-0.4.1.ebuild b/sys-process/iotop/iotop-0.4.1.ebuild
index b6b3b20980c8..a3fc796c75c3 100644
--- a/sys-process/iotop/iotop-0.4.1.ebuild
+++ b/sys-process/iotop/iotop-0.4.1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.4.1.ebuild,v 1.1 2010/06/28 06:34:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.4.1.ebuild,v 1.2 2010/06/28 06:38:24 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2:2.5"
PYTHON_USE_WITH="ncurses"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
inherit distutils linux-info
@@ -20,11 +21,15 @@ IUSE=""
DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="2.4 3.*"
CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
DOCS="NEWS README THANKS"
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
src_install() {
distutils_src_install
doman iotop.1