summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-20 01:11:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-20 01:11:48 +0000
commit171c48108ad9d1d9dac86b4f5c4a9625f1f253aa (patch)
tree7c7dc639b6ed82264d2a5516fe60239cf9f15aa8 /sys-process
parentQA: bump to 1.2 so that package can build with --as-needed (bug #424371); als... (diff)
downloadgentoo-2-171c48108ad9d1d9dac86b4f5c4a9625f1f253aa.tar.gz
gentoo-2-171c48108ad9d1d9dac86b4f5c4a9625f1f253aa.tar.bz2
gentoo-2-171c48108ad9d1d9dac86b4f5c4a9625f1f253aa.zip
QA: add patch to build with gcc 4.7 (bug #423935).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/incron/ChangeLog7
-rw-r--r--sys-process/incron/files/incron-0.5.10+gcc-4.7.patch12
-rw-r--r--sys-process/incron/incron-0.5.10.ebuild6
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-process/incron/ChangeLog b/sys-process/incron/ChangeLog
index 4f261121b006..d3d3286de39e 100644
--- a/sys-process/incron/ChangeLog
+++ b/sys-process/incron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/incron
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.22 2012/10/30 20:22:04 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.23 2012/11/20 01:11:48 flameeyes Exp $
+
+ 20 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/incron-0.5.10+gcc-4.7.patch, incron-0.5.10.ebuild:
+ QA: add patch to build with gcc 4.7 (bug #423935).
30 Oct 2012; Christian Ruppert <idl0r@gentoo.org> -incron-0.5.8.ebuild,
-incron-0.5.9-r1.ebuild, -files/incron-0.5.8-gcc44.patch,
@@ -93,4 +97,3 @@
19 Dec 2007; Benedikt Böhm <hollow@gentoo.org>
+files/incron-0.5.7-gentoo.patch, +metadata.xml, +incron-0.5.7.ebuild:
initial incron ebuild
-
diff --git a/sys-process/incron/files/incron-0.5.10+gcc-4.7.patch b/sys-process/incron/files/incron-0.5.10+gcc-4.7.patch
new file mode 100644
index 000000000000..a1b690510f34
--- /dev/null
+++ b/sys-process/incron/files/incron-0.5.10+gcc-4.7.patch
@@ -0,0 +1,12 @@
+Index: incron-0.5.10/icd-main.cpp
+===================================================================
+--- incron-0.5.10.orig/icd-main.cpp
++++ incron-0.5.10/icd-main.cpp
+@@ -24,6 +24,7 @@
+ #include <dirent.h>
+ #include <syslog.h>
+ #include <errno.h>
++#include <unistd.h>
+ #include <sys/poll.h>
+ #include <sys/stat.h>
+ #include <cstdio>
diff --git a/sys-process/incron/incron-0.5.10.ebuild b/sys-process/incron/incron-0.5.10.ebuild
index e01ac7810647..8d662abd29e9 100644
--- a/sys-process/incron/incron-0.5.10.ebuild
+++ b/sys-process/incron/incron-0.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.10.ebuild,v 1.4 2012/04/17 16:08:03 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.10.ebuild,v 1.5 2012/11/20 01:11:48 flameeyes Exp $
EAPI="4"
@@ -22,6 +22,10 @@ RDEPEND=""
# It should be ok to expect at least 2.6.18
CONFIG_CHECK="~INOTIFY_USER"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+gcc-4.7.patch
+}
+
src_compile() {
emake CXX=$(tc-getCXX)
}