summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-22 12:36:02 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-22 12:36:02 +0000
commit90a35db9da5315af4aea4b4a44276f030f1e6325 (patch)
tree86733d8bb120be9e2f4df942491fee71d6af8ff4 /sys-process/supervise-scripts
parentCleanup. (diff)
downloadgentoo-2-90a35db9da5315af4aea4b4a44276f030f1e6325.tar.gz
gentoo-2-90a35db9da5315af4aea4b4a44276f030f1e6325.tar.bz2
gentoo-2-90a35db9da5315af4aea4b4a44276f030f1e6325.zip
Fixup head/tail stuff missed by the eclass #152307 by Richard Scott.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'sys-process/supervise-scripts')
-rw-r--r--sys-process/supervise-scripts/ChangeLog9
-rw-r--r--sys-process/supervise-scripts/files/supervise-scripts-3.5-head-tails-syntax.patch19
-rw-r--r--sys-process/supervise-scripts/supervise-scripts-3.5.ebuild5
3 files changed, 29 insertions, 4 deletions
diff --git a/sys-process/supervise-scripts/ChangeLog b/sys-process/supervise-scripts/ChangeLog
index 59be64fc9f7c..fa74e3e425ca 100644
--- a/sys-process/supervise-scripts/ChangeLog
+++ b/sys-process/supervise-scripts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/supervise-scripts
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/supervise-scripts/ChangeLog,v 1.4 2006/06/06 01:34:30 eradicator Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/supervise-scripts/ChangeLog,v 1.5 2006/10/22 12:36:02 vapier Exp $
+
+ 22 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/supervise-scripts-3.5-head-tails-syntax.patch,
+ supervise-scripts-3.5.ebuild:
+ Fixup head/tail stuff missed by the eclass #152307 by Richard Scott.
06 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
supervise-scripts-3.5.ebuild:
diff --git a/sys-process/supervise-scripts/files/supervise-scripts-3.5-head-tails-syntax.patch b/sys-process/supervise-scripts/files/supervise-scripts-3.5-head-tails-syntax.patch
new file mode 100644
index 000000000000..6a38a544724a
--- /dev/null
+++ b/sys-process/supervise-scripts/files/supervise-scripts-3.5-head-tails-syntax.patch
@@ -0,0 +1,19 @@
+fixheadtails.eclass can't handle shell scripts so we need to fix ourselves
+
+http://bugs.gentoo.org/152307
+
+--- svscan-add-to-inittab.in
++++ svscan-add-to-inittab.in
+@@ -53,10 +53,10 @@
+
+ # Splice the new lines into the old file
+ {
+- catit | head -$(($lineno-1))
++ catit | head -n $(($lineno-1))
+ echo "SV:2345:respawn:$conf_bin/svscan-start /service"
+ echo "SX:S016:wait:$conf_bin/svscan-stopall /service"
+- catit | tail +$lineno
++ catit | tail -n +$lineno
+ } >"$tmpfile"
+
+ # And move it over the existing file
diff --git a/sys-process/supervise-scripts/supervise-scripts-3.5.ebuild b/sys-process/supervise-scripts/supervise-scripts-3.5.ebuild
index 7bc33463c1d1..c24cc6d59bc9 100644
--- a/sys-process/supervise-scripts/supervise-scripts-3.5.ebuild
+++ b/sys-process/supervise-scripts/supervise-scripts-3.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.4 2006/10/22 06:34:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.5 2006/10/22 12:36:02 vapier Exp $
-inherit fixheadtails toolchain-funcs
+inherit eutils fixheadtails toolchain-funcs
DESCRIPTION="Starting and stopping daemontools managed services"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
@@ -26,6 +26,7 @@ src_unpack() {
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
ht_fix_file svscan-add-to-inittab.in Makefile
+ epatch "${FILESDIR}"/${P}-head-tails-syntax.patch #152307
}
src_compile() {