summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2011-11-30 00:19:33 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2011-11-30 00:19:33 +0000
commit8071d9d10d79385b6c9353fc09cb2e9b23841564 (patch)
treeb44880b710cf4d44935c39ab9a0c5121be93444a /sys-process/runit
parentMask USE="jit" for x11-libs/qt-webkit. (diff)
downloadgentoo-2-8071d9d10d79385b6c9353fc09cb2e9b23841564.tar.gz
gentoo-2-8071d9d10d79385b6c9353fc09cb2e9b23841564.tar.bz2
gentoo-2-8071d9d10d79385b6c9353fc09cb2e9b23841564.zip
Added rev 2.2.1-r1. Fixes #392453.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/runit')
-rw-r--r--sys-process/runit/ChangeLog7
-rw-r--r--sys-process/runit/runit-2.1.1-r1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-process/runit/ChangeLog b/sys-process/runit/ChangeLog
index c085ff22f4e5..ad78ef8a3671 100644
--- a/sys-process/runit/ChangeLog
+++ b/sys-process/runit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/runit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.32 2011/06/15 18:55:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.33 2011/11/30 00:19:33 mschiff Exp $
+
+*runit-2.1.1-r1 (30 Nov 2011)
+
+ 30 Nov 2011; Marc Schiffbauer <mschiff@gentoo.org> +runit-2.1.1-r1.ebuild:
+ Added rev 2.2.1-r1. Fixes #392453.
15 Jun 2011; Diego E. Pettenò <flameeyes@gentoo.org> runit-2.1.1.ebuild:
QA: actually make runit build, since it was broken with a blind version bump.
diff --git a/sys-process/runit/runit-2.1.1-r1.ebuild b/sys-process/runit/runit-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..c4e827d74bac
--- /dev/null
+++ b/sys-process/runit/runit-2.1.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-2.1.1-r1.ebuild,v 1.1 2011/11/30 00:19:33 mschiff Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="http://smarden.org/runit/"
+SRC_URI="http://smarden.org/runit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+S=${WORKDIR}/admin/${P}/src
+
+src_prepare() {
+ # we either build everything or nothing static
+ sed -i -e 's:-static: :' src/Makefile
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ dodir /var
+ keepdir /etc/runit{,/runsvdir{,/default,/all}}
+ dosym default /etc/runit/runsvdir/current
+ dosym ../etc/runit/runsvdir/current /var/service
+ dosym ../etc/runit/2 /sbin/runsvdir-start
+
+ dobin $(<../package/commands) || die "dobin"
+ dodir /sbin
+ mv "${D}"/usr/bin/{runit-init,runit,utmpset} "${D}"/sbin/ || die "dosbin"
+
+ cd "${S}"/..
+ dodoc package/{CHANGES,README,THANKS,TODO}
+ dohtml doc/*.html
+ doman man/*.[18]
+
+ exeinto /etc/runit
+ doexe "${FILESDIR}"/{1,2,ctrlaltdel} || die
+ newexe "${FILESDIR}"/3-1.4 3 || die
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/runit/runsvdir/all/getty-$tty/
+ for script in run finish; do
+ newexe "${FILESDIR}"/$script.getty $script
+ dosed "s:TTY:${tty}:g" /etc/runit/runsvdir/all/getty-$tty/$script
+ done
+ dosym ../all/getty-$tty /etc/runit/runsvdir/default/getty-$tty
+ done
+
+ # make sv command work
+ cd "${S}"
+ insinto /etc/env.d
+ cat <<-EOF > env.d
+ #/etc/env.d/20runit
+ SVDIR="/var/service/"
+ EOF
+ newins env.d 20runit
+}
+
+pkg_postinst() {
+ env-update
+ ewarn "/etc/profile was updated. Please run:"
+ ewarn "source /etc/profile"
+ ewarn "to make 'sv' work correctly on your currently open shells"
+}