summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-09-14 19:28:59 +0000
committerFabian Groffen <grobian@gentoo.org>2011-09-14 19:28:59 +0000
commite0865dc06286a7eb033793f2bb973b6c0a0cfa48 (patch)
tree09df4be0e964a021a4893077734c5bd698e2db14 /sys-process/numactl
parentTransfer Prefix keywords, add Interix and PPC/Darwin fixes (diff)
downloadgentoo-2-e0865dc06286a7eb033793f2bb973b6c0a0cfa48.tar.gz
gentoo-2-e0865dc06286a7eb033793f2bb973b6c0a0cfa48.tar.bz2
gentoo-2-e0865dc06286a7eb033793f2bb973b6c0a0cfa48.zip
Bump for Prefix fixes, marked ~amd64-linux, bug #382347
(Portage version: 2.2.01.19247-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-process/numactl')
-rw-r--r--sys-process/numactl/ChangeLog7
-rw-r--r--sys-process/numactl/numactl-2.0.7-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index 54968f518ae4..77c0e089e83d 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/numactl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.17 2011/08/26 09:39:45 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.18 2011/09/14 19:28:59 grobian Exp $
+
+*numactl-2.0.7-r1 (14 Sep 2011)
+
+ 14 Sep 2011; Fabian Groffen <grobian@gentoo.org> +numactl-2.0.7-r1.ebuild:
+ Bump for Prefix fixes, marked ~amd64-linux, bug #382347
26 Aug 2011; Thomas Kahle <tomka@gentoo.org> numactl-2.0.7.ebuild:
x86 stable per bug 379807
diff --git a/sys-process/numactl/numactl-2.0.7-r1.ebuild b/sys-process/numactl/numactl-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..61d793858f98
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.7-r1.ebuild,v 1.1 2011/09/14 19:28:59 grobian Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" BENCH_CFLAGS="" || die
+}
+
+src_test() {
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+}
+
+src_install() {
+ emake install prefix="${ED}/usr" || die
+ # delete man pages provided by the man-pages package #238805
+ rm -rf "${ED}"/usr/share/man/man[25]
+ doman *.8 || die # makefile doesnt get them all
+ dodoc README TODO CHANGES DESIGN
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/numastat "${ED}"/usr/share/man/man8/numastat.8 || die
+ fi
+}