summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-05 16:10:13 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-05 16:10:13 +0000
commitcc2f739464277cdc26b05aa0ccfb9118b1e4be9e (patch)
tree4bbe4091a0e66d47407d31ece4dea083d7d35667 /sys-process/numactl/files
parentAdded myself as maintainer. Converted ebuilds to EAPI-5 (diff)
downloadgentoo-2-cc2f739464277cdc26b05aa0ccfb9118b1e4be9e.tar.gz
gentoo-2-cc2f739464277cdc26b05aa0ccfb9118b1e4be9e.tar.bz2
gentoo-2-cc2f739464277cdc26b05aa0ccfb9118b1e4be9e.zip
Version bump. Removed old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process/numactl/files')
-rw-r--r--sys-process/numactl/files/numactl-2.0.2-build.patch13
-rw-r--r--sys-process/numactl/files/numactl-2.0.5-protos.patch12
-rw-r--r--sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch12
3 files changed, 12 insertions, 25 deletions
diff --git a/sys-process/numactl/files/numactl-2.0.2-build.patch b/sys-process/numactl/files/numactl-2.0.2-build.patch
deleted file mode 100644
index acb04b8ab81b..000000000000
--- a/sys-process/numactl/files/numactl-2.0.2-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 3795115..28a9418 100755
---- a/Makefile
-+++ b/Makefile
-@@ -57,7 +57,7 @@ memhog: util.o memhog.o libnuma.so
-
- numactl.o: numactl.c
-
--numademo: override LDFLAGS += -lm
-+numademo: LDLIBS += -lm
- # GNU make 3.80 appends BENCH_CFLAGS twice. Bug? It's harmless though.
- numademo: CFLAGS += -DHAVE_STREAM_LIB -DHAVE_MT -DHAVE_CLEAR_CACHE ${BENCH_CFLAGS}
- stream_lib.o: CFLAGS += ${BENCH_CFLAGS}
diff --git a/sys-process/numactl/files/numactl-2.0.5-protos.patch b/sys-process/numactl/files/numactl-2.0.5-protos.patch
deleted file mode 100644
index 1f1bedc5e0fa..000000000000
--- a/sys-process/numactl/files/numactl-2.0.5-protos.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-fix missing fstat64() prototype
-
---- a/shm.c
-+++ b/shm.c
-@@ -25,6 +25,7 @@
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #include <sys/fcntl.h>
-+#include <sys/stat.h>
- #include <stdarg.h>
- #include <errno.h>
- #include <unistd.h>
diff --git a/sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch b/sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch
new file mode 100644
index 000000000000..27a97fdf2509
--- /dev/null
+++ b/sys-process/numactl/files/numactl-2.0.9-testsuite_fix.patch
@@ -0,0 +1,12 @@
+Tests fail with /bin/dash
+
+Singned-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- numactl-2.0.9/test/printcpu
++++ numactl-2.0.9/test/printcpu
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ #print cpu it is running on
+ declare -a arr
+ arr=( $(< /proc/self/stat) )