summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-11 06:09:07 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-11 06:09:07 +0000
commit1602f85a6ad3f06f58adf6f463449c98b001952b (patch)
tree511e8cce159bcc925a2fc880cdcdeecb63c6e040 /sys-process/lsof
parentold (diff)
downloadgentoo-2-1602f85a6ad3f06f58adf6f463449c98b001952b.tar.gz
gentoo-2-1602f85a6ad3f06f58adf6f463449c98b001952b.tar.bz2
gentoo-2-1602f85a6ad3f06f58adf6f463449c98b001952b.zip
Version bump #269341 by Lars Wendler.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/ChangeLog7
-rw-r--r--sys-process/lsof/lsof-4.82.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index ae873591de8c..9a787e3ec35d 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.61 2009/03/17 10:22:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.62 2009/05/11 06:09:07 vapier Exp $
+
+*lsof-4.82 (11 May 2009)
+
+ 11 May 2009; Mike Frysinger <vapier@gentoo.org> +lsof-4.82.ebuild:
+ Version bump #269341 by Lars Wendler.
17 Mar 2009; Raúl Porcel <armin76@gentoo.org> lsof-4.81-r2.ebuild:
m68k stable wrt #258195, thanks to kolla for testing
diff --git a/sys-process/lsof/lsof-4.82.ebuild b/sys-process/lsof/lsof-4.82.ebuild
new file mode 100644
index 000000000000..1eefb8e29888
--- /dev/null
+++ b/sys-process/lsof/lsof-4.82.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.82.ebuild,v 1.1 2009/05/11 06:09:07 vapier Exp $
+
+inherit eutils flag-o-matic fixheadtails toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
+SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.bz2"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ unpack ./${MY_P}_src.tar
+ cd "${S}"
+
+ # now patch the scripts to automate everything
+ ht_fix_file Configure Customize
+ touch .neverInv
+ epatch "${FILESDIR}"/${PN}-4.78-answer-config.patch
+ sed -i \
+ -e "/^LSOF_RANLIB/s:ranlib:$(tc-getRANLIB):" \
+ Configure
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ use selinux && export LINUX_HASSELINUX=Y
+ export LSOF_CC=$(tc-getCC)
+ export LSOF_AR="$(tc-getAR) rc"
+
+ local target="linux"
+ use kernel_FreeBSD && target=freebsd
+ ./Configure ${target} || die "configure failed"
+ emake DEBUG="" all || die "emake failed"
+}
+
+src_install() {
+ dobin lsof || die "dosbin"
+
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+
+ doman lsof.8
+ dodoc 00*
+}