summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-05-18 00:40:47 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-05-18 00:40:47 +0000
commitc476468aeb7c491fd3cdf416026aa2b713e09fe7 (patch)
tree97605f5fe9c97be7e01846a5fbb50fc3937326c9 /sys-process/htop
parentVersion bump (diff)
downloadgentoo-2-c476468aeb7c491fd3cdf416026aa2b713e09fe7.tar.gz
gentoo-2-c476468aeb7c491fd3cdf416026aa2b713e09fe7.tar.bz2
gentoo-2-c476468aeb7c491fd3cdf416026aa2b713e09fe7.zip
added unicode USE flag
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/ChangeLog8
-rw-r--r--sys-process/htop/htop-0.8-r1.ebuild (renamed from sys-process/htop/htop-0.8.ebuild)14
2 files changed, 17 insertions, 5 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index c719d402208f..eae5e2b1f082 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.55 2008/05/12 18:00:33 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.56 2008/05/18 00:40:47 wschlich Exp $
+
+*htop-0.8-r1 (17 May 2008)
+
+ 17 May 2008; Wolfram Schlich <wschlich@gentoo.org> -htop-0.8.ebuild,
+ +htop-0.8-r1.ebuild:
+ added unicode USE flag
12 May 2008; Markus Rothe <corsair@gentoo.org> htop-0.7.ebuild:
Stable on ppc64
diff --git a/sys-process/htop/htop-0.8.ebuild b/sys-process/htop/htop-0.8-r1.ebuild
index 074fe8616cf2..b79f05c7449a 100644
--- a/sys-process/htop/htop-0.8.ebuild
+++ b/sys-process/htop/htop-0.8-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.ebuild,v 1.1 2008/05/10 08:23:34 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8-r1.ebuild,v 1.1 2008/05/18 00:40:47 wschlich Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
-IUSE="debug"
+IUSE="debug unicode"
DESCRIPTION="interactive process viewer"
HOMEPAGE="http://htop.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -24,8 +24,14 @@ pkg_setup() {
}
src_compile() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ die "for unicode support of htop, sys-libs/ncurses must be emerged with USE=unicode"
+ fi
useq debug && append-flags -O -ggdb -DDEBUG
- econf || die "configure failed"
+ econf \
+ --enable-taskstats \
+ $(use_enable unicode) \
+ || die "configure failed"
emake || die "make failed"
}