summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:09:27 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:09:27 +0000
commit69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784 (patch)
tree6c477f845d2f66a460b710a6008b6dccb008f5ad /sys-process/htop
parentVersion bump. (diff)
downloadgentoo-2-69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784.tar.gz
gentoo-2-69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784.tar.bz2
gentoo-2-69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784.zip
Cleanup
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/files/htop-0.9-debug.patch31
-rw-r--r--sys-process/htop/files/htop-0.9-small-width.patch42
-rw-r--r--sys-process/htop/files/htop-0.9-uclibc.patch54
-rw-r--r--sys-process/htop/htop-0.9-r2.ebuild61
5 files changed, 6 insertions, 189 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index a81124e6680a..829d21752441 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.123 2012/10/30 15:51:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.124 2012/10/30 20:09:27 idl0r Exp $
+
+ 30 Oct 2012; Christian Ruppert <idl0r@gentoo.org> -htop-0.9-r2.ebuild,
+ -files/htop-0.9-debug.patch, -files/htop-0.9-small-width.patch,
+ -files/htop-0.9-uclibc.patch:
+ Cleanup
30 Oct 2012; Jeroen Roovers <jer@gentoo.org> htop-1.0.1-r1.ebuild:
Stable for HPPA (bug #439548).
diff --git a/sys-process/htop/files/htop-0.9-debug.patch b/sys-process/htop/files/htop-0.9-debug.patch
deleted file mode 100644
index a1aa1b9ea3ec..000000000000
--- a/sys-process/htop/files/htop-0.9-debug.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- trunk/DebugMemory.c 2006/11/08 20:40:10 66
-+++ trunk/DebugMemory.c 2011/03/22 20:37:08 216
-@@ -90,7 +90,7 @@
- return data;
- }
-
--void* DebugMemory_strdup(char* str, char* file, int line) {
-+void* DebugMemory_strdup(const char* str, char* file, int line) {
- assert(str);
- char* data = strdup(str);
- DebugMemory_registerAllocation(data, file, line);
-@@ -102,7 +102,7 @@
- }
-
- void DebugMemory_free(void* data, char* file, int line) {
-- assert(data);
-+ if (!data) return;
- DebugMemory_registerDeallocation(data, file, line);
- if (singleton->file) {
- if (singleton->totals) fprintf(singleton->file, "%d\t", singleton->size);
---- trunk/Process.c 2010/11/22 12:40:20 206
-+++ trunk/Process.c 2011/03/22 20:37:08 216
-@@ -471,7 +471,7 @@
- RichString_setAttr(out, CRT_colors[PROCESS_SHADOW]);
- if (this->tag == true)
- RichString_setAttr(out, CRT_colors[PROCESS_TAG]);
-- assert(out->len > 0);
-+ assert(out->chlen > 0);
- }
-
- void Process_delete(Object* cast) {
diff --git a/sys-process/htop/files/htop-0.9-small-width.patch b/sys-process/htop/files/htop-0.9-small-width.patch
deleted file mode 100644
index 743111137b03..000000000000
--- a/sys-process/htop/files/htop-0.9-small-width.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 17d258ff0a216dd87655c8e93d065e5e6c504f42 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Mon, 1 Aug 2011 02:51:24 +0200
-Subject: [PATCH 3/3] Fix segfault in BarMeterMode_draw() for small terminal
- widths
-
-Segfault can be triggered by running "COLUMNS=1 ./htop"
-For me, COLUMNS=40 was the first that would not crash.
----
- ChangeLog | 2 ++
- Meter.c | 11 +++++++++--
- 2 files changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/Meter.c b/Meter.c
-index 6947d9b..408b981 100644
---- a/Meter.c
-+++ b/Meter.c
-@@ -264,13 +265,19 @@ static void BarMeterMode_draw(Meter* this, int x, int y, int w) {
-
- w--;
- x++;
-- char bar[w];
-+
-+ if (w < 1) {
-+ attrset(CRT_colors[RESET_COLOR]);
-+ return;
-+ }
-+ char bar[w + 1];
-
- int blockSizes[10];
- for (int i = 0; i < w; i++)
- bar[i] = ' ';
-
-- sprintf(bar + (w-strlen(buffer)), "%s", buffer);
-+ const size_t bar_offset = w - MIN(strlen(buffer), w);
-+ snprintf(bar + bar_offset, w - bar_offset + 1, "%s", buffer);
-
- // First draw in the bar[] buffer...
- double total = 0.0;
---
-1.7.6
-
diff --git a/sys-process/htop/files/htop-0.9-uclibc.patch b/sys-process/htop/files/htop-0.9-uclibc.patch
deleted file mode 100644
index ffe4953d80a3..000000000000
--- a/sys-process/htop/files/htop-0.9-uclibc.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-http://bugs.gentoo.org/374595
-
---- CRT.c
-+++ CRT.c
-@@ -11,7 +11,9 @@ in the source distribution for its full
- #include <signal.h>
- #include <stdlib.h>
- #include <stdbool.h>
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
-
- #include "String.h"
-
-@@ -125,12 +127,14 @@ static void CRT_handleSIGSEGV(int sgn) {
- CRT_done();
- #if __linux
- fprintf(stderr, "\n\nhtop " VERSION " aborting. Please report bug at http://htop.sf.net\n");
-- #else
-- fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
-- #endif
-+ #ifdef HAVE_EXECINFO_H
- size_t size = backtrace(backtraceArray, sizeof(backtraceArray));
- fprintf(stderr, "Backtrace: \n");
- backtrace_symbols_fd(backtraceArray, size, 2);
-+ #endif
-+ #else
-+ fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
-+ #endif
- abort();
- }
-
---- CRT.h
-+++ CRT.h
-@@ -14,7 +14,9 @@ in the source distribution for its full
- #include <signal.h>
- #include <stdlib.h>
- #include <stdbool.h>
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
-
- #include "String.h"
-
---- configure.ac
-+++ configure.ac
-@@ -25,6 +25,7 @@ AC_HEADER_STDC
- AC_CHECK_HEADERS([stdlib.h string.h strings.h sys/param.h sys/time.h unistd.h curses.h],[:],[
- missing_headers="$missing_headers $ac_header"
- ])
-+AC_CHECK_HEADERS([execinfo.h],[:],[:])
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_HEADER_STDBOOL
diff --git a/sys-process/htop/htop-0.9-r2.ebuild b/sys-process/htop/htop-0.9-r2.ebuild
deleted file mode 100644
index 3f21397ca7f3..000000000000
--- a/sys-process/htop/htop-0.9-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.9-r2.ebuild,v 1.8 2012/01/04 23:50:33 xmw Exp $
-
-EAPI=4
-inherit autotools eutils flag-o-matic multilib
-
-DESCRIPTION="interactive process viewer"
-HOMEPAGE="http://htop.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="debug elibc_FreeBSD kernel_linux openvz unicode vserver"
-
-RDEPEND="sys-libs/ncurses[unicode?]"
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog README TODO )
-
-pkg_setup() {
- if use elibc_FreeBSD && ! [[ -f ${ROOT}/proc/stat && -f ${ROOT}/proc/meminfo ]]; then
- eerror
- eerror "htop needs /proc mounted to compile and work, to mount it type"
- eerror "mount -t linprocfs none /proc"
- eerror "or uncomment the example in /etc/fstab"
- eerror
- die "htop needs /proc mounted"
- fi
-
- if ! has_version sys-process/lsof; then
- ewarn "To use lsof features in htop(what processes are accessing"
- ewarn "what files), you must have sys-process/lsof installed."
- fi
-}
-
-src_prepare() {
- sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
- scripts/MakeHeader.py || die
-
- epatch "${FILESDIR}"/${P}-debug.patch #352024, 372911
- epatch "${FILESDIR}"/${P}-uclibc.patch #374595
-
- # patch accepted by upstream (bug 3383385), remove on >=0.9.1
- epatch "${FILESDIR}"/${P}-small-width.patch
-
- eautoreconf
-}
-
-src_configure() {
- use debug && append-flags -DDEBUG
-
- econf \
- $(use_enable openvz) \
- $(use_enable kernel_linux cgroup) \
- $(use_enable vserver) \
- $(use_enable unicode) \
- --enable-taskstats \
- --without-valgrind
-}