summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-16 20:01:40 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-16 20:01:40 +0000
commit70039607f0ba165ebddbe64932202a4f6ad65e24 (patch)
tree5a008559d5950ecbd1cf6742857e520a0bb57164 /sys-process/htop/htop-1.0.1.ebuild
parentarm stable, bug #403235 (diff)
downloadgentoo-2-70039607f0ba165ebddbe64932202a4f6ad65e24.tar.gz
gentoo-2-70039607f0ba165ebddbe64932202a4f6ad65e24.tar.bz2
gentoo-2-70039607f0ba165ebddbe64932202a4f6ad65e24.zip
Non maintainer version bump
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/htop/htop-1.0.1.ebuild')
-rw-r--r--sys-process/htop/htop-1.0.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-process/htop/htop-1.0.1.ebuild b/sys-process/htop/htop-1.0.1.ebuild
new file mode 100644
index 000000000000..1d0e29e78707
--- /dev/null
+++ b/sys-process/htop/htop-1.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.1.ebuild,v 1.1 2012/02/16 20:01:40 jlec Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="elibc_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+pkg_setup() {
+ if use elibc_FreeBSD && ! [[ -f ${ROOT}/proc/stat && -f ${ROOT}/proc/meminfo ]]; then
+ eerror
+ eerror "htop needs /proc mounted to compile and work, to mount it type"
+ eerror "mount -t linprocfs none /proc"
+ eerror "or uncomment the example in /etc/fstab"
+ eerror
+ die "htop needs /proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ scripts/MakeHeader.py || die
+}
+
+src_configure() {
+
+ econf \
+ $(use_enable openvz) \
+ $(use_enable kernel_linux cgroup) \
+ $(use_enable vserver) \
+ $(use_enable unicode) \
+ --enable-taskstats
+}