summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-02 03:57:36 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-02 03:57:36 +0000
commit2cc72931fdbd1bfa82fabe248524708b09824a63 (patch)
tree49160023c11bf5062d8ce3c28c6b9ddd3c917ed0 /sys-process/daemontools
parentalpha love #122726 (diff)
downloadgentoo-2-2cc72931fdbd1bfa82fabe248524708b09824a63.tar.gz
gentoo-2-2cc72931fdbd1bfa82fabe248524708b09824a63.tar.bz2
gentoo-2-2cc72931fdbd1bfa82fabe248524708b09824a63.zip
Include more headers to get proper prototypes by RiverRat #124487.
(Portage version: 2.1_pre5-r1)
Diffstat (limited to 'sys-process/daemontools')
-rw-r--r--sys-process/daemontools/ChangeLog8
-rw-r--r--sys-process/daemontools/daemontools-0.76-r5.ebuild15
-rw-r--r--sys-process/daemontools/files/0.76-warnings.patch74
3 files changed, 88 insertions, 9 deletions
diff --git a/sys-process/daemontools/ChangeLog b/sys-process/daemontools/ChangeLog
index 4be43880a56a..93e0068259c8 100644
--- a/sys-process/daemontools/ChangeLog
+++ b/sys-process/daemontools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/daemontools
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/ChangeLog,v 1.3 2005/12/11 09:49:54 uberlord Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/ChangeLog,v 1.4 2006/03/02 03:57:36 vapier Exp $
+
+ 02 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/0.76-warnings.patch, daemontools-0.76-r5.ebuild:
+ Include more headers to get proper prototypes by RiverRat #124487.
*daemontools-0.76-r5 (11 Dec 2005)
diff --git a/sys-process/daemontools/daemontools-0.76-r5.ebuild b/sys-process/daemontools/daemontools-0.76-r5.ebuild
index 10db8ba2ebad..c8d6efb0713b 100644
--- a/sys-process/daemontools/daemontools-0.76-r5.ebuild
+++ b/sys-process/daemontools/daemontools-0.76-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/daemontools-0.76-r5.ebuild,v 1.1 2005/12/11 09:49:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/daemontools-0.76-r5.ebuild,v 1.2 2006/03/02 03:57:36 vapier Exp $
inherit eutils toolchain-funcs
@@ -21,15 +21,16 @@ S=${WORKDIR}/admin/${P}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-errno.patch
- epatch ${FILESDIR}/${PV}-head-1.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-head-1.patch
+ epatch "${FILESDIR}"/${PV}-warnings.patch
use static && LDFLAGS="${LDFLAGS} -static"
echo "$(tc-getCC) ${CFLAGS}" > src/conf-cc
echo "$(tc-getCC) ${LDFLAGS}" > src/conf-ld
- echo ${S} > src/home
+ echo "${S}" > src/home
}
src_compile() {
@@ -50,7 +51,7 @@ src_install() {
dodoc CHANGES ../package/README TODO
- newinitd ${FILESDIR}/svscan.init svscan
+ newinitd "${FILESDIR}"/svscan.init svscan
}
pkg_postinst() {
diff --git a/sys-process/daemontools/files/0.76-warnings.patch b/sys-process/daemontools/files/0.76-warnings.patch
new file mode 100644
index 000000000000..f558bb18b1bf
--- /dev/null
+++ b/sys-process/daemontools/files/0.76-warnings.patch
@@ -0,0 +1,74 @@
+Fixup misc warnings
+
+Patch by RiverRat
+
+http://bugs.gentoo.org/124487
+
+--- src/chkshsgr.c
++++ src/chkshsgr.c
+@@ -1,10 +1,13 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <stdlib.h>
++#include <grp.h>
+ #include <unistd.h>
+
+ int main()
+ {
+- short x[4];
++ gid_t x[4];
+
+ x[0] = x[1] = 0;
+ if (getgroups(1,x) == 0) if (setgroups(1,x) == -1) _exit(1);
+--- src/matchtest.c
++++ src/matchtest.c
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include "match.h"
+ #include "buffer.h"
+ #include "str.h"
+--- src/multilog.c
++++ src/multilog.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/prot.c
++++ src/prot.c
+@@ -1,5 +1,8 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <unistd.h>
++#include <grp.h>
+ #include "hasshsgr.h"
+ #include "prot.h"
+
+--- src/seek_set.c
++++ src/seek_set.c
+@@ -1,6 +1,7 @@
+ /* Public domain. */
+
+ #include <sys/types.h>
++#include <unistd.h>
+ #include "seek.h"
+
+ #define SET 0 /* sigh */
+--- src/supervise.c
++++ src/supervise.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/pathexec_run.c
++++ src/pathexec_run.c
+@@ -1,5 +1,6 @@
+ /* Public domain. */
+
++#include <unistd.h>
+ #include "error.h"
+ #include "stralloc.h"
+ #include "str.h"