summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-20 00:49:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-20 00:49:05 +0000
commitc1655ec026d2d34b79299a9c6764d0968f9304ee (patch)
tree52a41993eb062c039983574439c6314db583fdfd /sys-process/cronutils
parentVersion bump. Removed old. Restore doc flag (diff)
downloadgentoo-2-c1655ec026d2d34b79299a9c6764d0968f9304ee.tar.gz
gentoo-2-c1655ec026d2d34b79299a9c6764d0968f9304ee.tar.bz2
gentoo-2-c1655ec026d2d34b79299a9c6764d0968f9304ee.zip
QA: bump to 1.2 so that package can build with --as-needed (bug #424371); also make sure to use the user-defined CFLAGS, instead of -O0.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-process/cronutils')
-rw-r--r--sys-process/cronutils/ChangeLog9
-rw-r--r--sys-process/cronutils/cronutils-1.2.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/sys-process/cronutils/ChangeLog b/sys-process/cronutils/ChangeLog
index f8e4e4e95ae4..7d7f471901d3 100644
--- a/sys-process/cronutils/ChangeLog
+++ b/sys-process/cronutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/cronutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronutils/ChangeLog,v 1.4 2012/02/29 20:27:16 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronutils/ChangeLog,v 1.5 2012/11/20 00:49:05 flameeyes Exp $
+
+*cronutils-1.2 (20 Nov 2012)
+
+ 20 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> +cronutils-1.2.ebuild:
+ QA: bump to 1.2 so that package can build with --as-needed (bug #424371); also
+ make sure to use the user-defined CFLAGS, instead of -O0.
29 Feb 2012; Jeff Horelick <jdhore@gentoo.org> cronutils-1.1.ebuild:
marked x86 per bug 406173
@@ -16,4 +22,3 @@
08 Dec 2011; Lance Albertson <ramereth@gentoo.org> +cronutils-1.1.ebuild,
+metadata.xml:
Initial ebuild
-
diff --git a/sys-process/cronutils/cronutils-1.2.ebuild b/sys-process/cronutils/cronutils-1.2.ebuild
new file mode 100644
index 000000000000..147de6b5ebd8
--- /dev/null
+++ b/sys-process/cronutils/cronutils-1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronutils/cronutils-1.2.ebuild,v 1.1 2012/11/20 00:49:05 flameeyes Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities to assist running batch processing jobs"
+HOMEPAGE="http://code.google.com/p/cronutils/"
+SRC_URI="http://cronutils.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr install
+}