summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-10-31 01:17:19 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-10-31 01:17:19 +0000
commit58ba4c21441852019a68ecaba50ac39a4f614f94 (patch)
tree34e6892e091a21e1b9352182241d96d9c3a544fd /sys-process/at
parentuse tc_version_is_at_least rather than parsing GCC_BRANCH_VER for lto handling (diff)
downloadgentoo-2-58ba4c21441852019a68ecaba50ac39a4f614f94.tar.gz
gentoo-2-58ba4c21441852019a68ecaba50ac39a4f614f94.tar.bz2
gentoo-2-58ba4c21441852019a68ecaba50ac39a4f614f94.zip
Better fix for bug #386625
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/ChangeLog6
-rw-r--r--sys-process/at/at-3.1.10.2-r1.ebuild14
-rw-r--r--sys-process/at/at-3.1.10.2-r2.ebuild14
-rw-r--r--sys-process/at/at-3.1.13.ebuild14
4 files changed, 29 insertions, 19 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index 0a0c8219a4be..7f4b410eeea1 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/at
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.30 2011/10/10 10:56:16 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.31 2011/10/31 01:17:19 polynomial-c Exp $
+
+ 31 Oct 2011; Lars Wendler <polynomial-c@gentoo.org> at-3.1.10.2-r1.ebuild,
+ at-3.1.10.2-r2.ebuild, at-3.1.13.ebuild:
+ non-maintainer commit: Better fix for bug #386625.
10 Oct 2011; Lars Wendler <polynomial-c@gentoo.org> at-3.1.13.ebuild:
non-maintainer commit: Added bug ID to comment about .SEQ file.
diff --git a/sys-process/at/at-3.1.10.2-r1.ebuild b/sys-process/at/at-3.1.10.2-r1.ebuild
index 720c98163a90..a7755abb3803 100644
--- a/sys-process/at/at-3.1.10.2-r1.ebuild
+++ b/sys-process/at/at-3.1.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.2-r1.ebuild,v 1.9 2011/10/10 10:42:43 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.2-r1.ebuild,v 1.10 2011/10/31 01:17:19 polynomial-c Exp $
inherit eutils flag-o-matic autotools pam
@@ -58,14 +58,16 @@ src_compile() {
src_install() {
make install IROOT="${D}" || die
- # Don't install .SEQ file when it's already installed (bug #386625)
- if [ -e "${ROOT}/var/spool/at/atjobs/.SEQ" ] ; then
- rm "${D}/var/spool/at/atjobs/.SEQ" || die
- fi
-
newinitd "${FILESDIR}"/atd.rc6 atd
newpamd "${FILESDIR}"/at.pamd atd
prepalldocs
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo"Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
}
pkg_postinst() {
diff --git a/sys-process/at/at-3.1.10.2-r2.ebuild b/sys-process/at/at-3.1.10.2-r2.ebuild
index c805f2cf7cf1..8e416dacdbf9 100644
--- a/sys-process/at/at-3.1.10.2-r2.ebuild
+++ b/sys-process/at/at-3.1.10.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.2-r2.ebuild,v 1.2 2011/10/10 10:42:43 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.2-r2.ebuild,v 1.3 2011/10/31 01:17:19 polynomial-c Exp $
inherit eutils flag-o-matic autotools pam
@@ -58,15 +58,17 @@ src_compile() {
src_install() {
make install IROOT="${D}" || die
- # Don't install .SEQ file when it's already installed (bug #386625)
- if [ -e "${ROOT}/var/spool/at/atjobs/.SEQ" ] ; then
- rm "${D}/var/spool/at/atjobs/.SEQ" || die
- fi
-
newinitd "${FILESDIR}"/atd.rc6 atd
newconfd "${FILESDIR}"/atd.confd atd
newpamd "${FILESDIR}"/at.pamd atd
prepalldocs
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo"Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
}
pkg_postinst() {
diff --git a/sys-process/at/at-3.1.13.ebuild b/sys-process/at/at-3.1.13.ebuild
index de98ce08fc11..e3d4b4df9d3a 100644
--- a/sys-process/at/at-3.1.13.ebuild
+++ b/sys-process/at/at-3.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13.ebuild,v 1.4 2011/10/10 10:56:16 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13.ebuild,v 1.5 2011/10/31 01:17:19 polynomial-c Exp $
EAPI=4
@@ -52,14 +52,16 @@ src_configure() {
src_install() {
make install IROOT="${D}" || die
- # Don't install .SEQ file when it's already installed (bug #386625)
- if [ -e "${ROOT}/var/spool/at/atjobs/.SEQ" ] ; then
- rm "${D}/var/spool/at/atjobs/.SEQ" || die
- fi
-
newinitd "${FILESDIR}"/atd.rc6 atd
newconfd "${FILESDIR}"/atd.confd atd
newpamd "${FILESDIR}"/at.pamd atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
}
pkg_postinst() {