summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-10 16:18:23 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-10 16:18:23 +0000
commit54c1671993c4ec640e6359fbb80f03ec5265b76e (patch)
treefda180de695bba98cb535fc375a9039d9b03053a /sys-process/acct/acct-6.5.1.ebuild
parentold (diff)
downloadgentoo-2-54c1671993c4ec640e6359fbb80f03ec5265b76e.tar.gz
gentoo-2-54c1671993c4ec640e6359fbb80f03ec5265b76e.tar.bz2
gentoo-2-54c1671993c4ec640e6359fbb80f03ec5265b76e.zip
Version bump #288374 by Markus Gothe. Stop using full paths in init.d script.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/acct/acct-6.5.1.ebuild')
-rw-r--r--sys-process/acct/acct-6.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/acct/acct-6.5.1.ebuild b/sys-process/acct/acct-6.5.1.ebuild
new file mode 100644
index 000000000000..11808e87a4d2
--- /dev/null
+++ b/sys-process/acct/acct-6.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/acct-6.5.1.ebuild,v 1.1 2009/10/10 16:18:22 vapier Exp $
+
+DESCRIPTION="GNU system accounting utilities"
+HOMEPAGE="https://savannah.gnu.org/projects/acct/"
+SRC_URI="mirror://gnu/acct/acct-6.5.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ econf --enable-linux-multiformat
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+ keepdir /var/account
+ newinitd "${FILESDIR}"/acct.rc6 acct || die
+ newconfd "${FILESDIR}"/acct.confd acct
+
+ # sys-apps/sysvinit already provides this
+ rm "${D}"/usr/bin/last "${D}"/usr/share/man/man1/last.1 || die
+
+ # accton in / is only a temp workaround for #239748
+ dodir /sbin
+ mv "${D}"/usr/sbin/accton "${D}"/sbin/ || die
+}