summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-03-07 20:30:14 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-03-07 20:30:14 +0000
commitff3401d042f37256d382ad472d806504c5e7dd06 (patch)
tree02047a41e5c0b4513b067be4f9e9fc05fa688c39 /sys-power
parentEapi2ification. USE-Deps for the win. (diff)
downloadgentoo-2-ff3401d042f37256d382ad472d806504c5e7dd06.tar.gz
gentoo-2-ff3401d042f37256d382ad472d806504c5e7dd06.tar.bz2
gentoo-2-ff3401d042f37256d382ad472d806504c5e7dd06.zip
Migrate to EAPI 2.
(Portage version: 2.2_rc20/cvs/Linux 2.6.29-rc6 i686)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nut/ChangeLog5
-rw-r--r--sys-power/nut/nut-2.2.2.ebuild33
2 files changed, 16 insertions, 22 deletions
diff --git a/sys-power/nut/ChangeLog b/sys-power/nut/ChangeLog
index 9d0a3bad6b22..5bacc4d11e9a 100644
--- a/sys-power/nut/ChangeLog
+++ b/sys-power/nut/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-power/nut
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.59 2009/03/07 20:25:38 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.60 2009/03/07 20:30:14 betelgeuse Exp $
+
+ 07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> nut-2.2.2.ebuild:
+ Migrate to EAPI 2.
07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> -nut-2.2.0.ebuild,
-nut-2.2.1.ebuild:
diff --git a/sys-power/nut/nut-2.2.2.ebuild b/sys-power/nut/nut-2.2.2.ebuild
index 5c3f7d513fde..2de2c9e7be60 100644
--- a/sys-power/nut/nut-2.2.2.ebuild
+++ b/sys-power/nut/nut-2.2.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.2.2.ebuild,v 1.5 2008/07/05 15:39:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.2.2.ebuild,v 1.6 2009/03/07 20:30:14 betelgeuse Exp $
+
+EAPI="2"
inherit eutils fixheadtails autotools
@@ -18,7 +20,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="cgi snmp usb ssl hal xml"
-RDEPEND="cgi? ( >=media-libs/gd-2 )
+RDEPEND="cgi? ( >=media-libs/gd-2[png] )
snmp? ( net-analyzer/net-snmp )
usb? ( >=dev-libs/libusb-0.1.12 )
hal? ( >=sys-apps/hal-0.5.9.1 )
@@ -37,11 +39,6 @@ NUT_PRIVATE_FILES="/etc/nut/{upsd.conf,upsd.users,upsmon.conf}"
NUT_CGI_FILES="/etc/nut/{{hosts,upsset}.conf,upsstats{,-single}.html}"
pkg_setup() {
- if use cgi && ! built_with_use media-libs/gd png ; then
- eerror "CGI support requested, bug GD not built with PNG support"
- eerror "Please rebuild gd with 'USE=png'"
- die
- fi
enewgroup nut 84
enewuser nut 84 -1 /var/lib/nut nut,uucp
# As of udev-104, NUT must be in uucp and NOT in tty.
@@ -53,11 +50,7 @@ pkg_setup() {
warningmsg ewarn
}
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
-
+src_prepare() {
ht_fix_file configure.in
epatch "${FILESDIR}"/${P}-no-libdummy.patch
@@ -71,7 +64,7 @@ src_unpack() {
WANT_AUTOCONF=2.5 eautoreconf || die "autoconf failed"
}
-src_compile() {
+src_configure() {
local myconf
if [ -n "${NUT_DRIVERS}" ]; then
@@ -98,13 +91,11 @@ src_compile() {
$(use_with cgi cgipath /usr/share/nut/cgi) \
${myconf} || die "econf failed"
- emake || die "compile problem"
-
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
dodir /sbin
dosym /lib/nut/upsdrvctl /sbin/upsdrvctl
@@ -124,14 +115,14 @@ src_install() {
done
dodoc ChangeLog INSTALL MAINTAINERS NEWS README UPGRADING \
- docs/{FAQ,*.txt}
+ docs/{FAQ,*.txt} || die
- newdoc lib/README README.lib
+ newdoc lib/README README.lib || die
- newdoc "${FILESDIR}"/lighttpd_nut.conf-2.2.0 lighttpd_nut.conf
+ newdoc "${FILESDIR}"/lighttpd_nut.conf-2.2.0 lighttpd_nut.conf || die
docinto cables
- dodoc docs/cables/*
+ dodoc docs/cables/* || die
newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsd upsd
newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsdrv upsdrv