summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-16 05:39:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-16 05:39:30 +0000
commited6d82a66b8ebd387affd1ae8024c9aab7463c99 (patch)
tree0ccc05e3bc100b56dc6e8d043ea51eb90bf58963 /sys-power
parentold (diff)
downloadgentoo-2-ed6d82a66b8ebd387affd1ae8024c9aab7463c99.tar.gz
gentoo-2-ed6d82a66b8ebd387affd1ae8024c9aab7463c99.tar.bz2
gentoo-2-ed6d82a66b8ebd387affd1ae8024c9aab7463c99.zip
Version bump wrt #410405 by "teidakankan"
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog7
-rw-r--r--sys-power/acpid/acpid-2.0.16.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 78c71850c1b2..e316a2c4270f 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.82 2012/03/24 17:26:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.83 2012/04/16 05:39:30 ssuominen Exp $
+
+*acpid-2.0.16 (16 Apr 2012)
+
+ 16 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.16.ebuild:
+ Version bump wrt #410405 by "teidakankan"
24 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> acpid-2.0.14.ebuild:
x86 stable wrt bug #406947
diff --git a/sys-power/acpid/acpid-2.0.16.ebuild b/sys-power/acpid/acpid-2.0.16.ebuild
new file mode 100644
index 000000000000..62aed1a70e05
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.16.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.16.ebuild,v 1.1 2012/04/16 05:39:30 ssuominen Exp $
+
+EAPI=4
+inherit systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://tedfelix.com/linux/acpid-netlink.html"
+SRC_URI="http://tedfelix.com/linux/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 -ppc ~x86"
+IUSE=""
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.11-init.d acpid
+ newconfd "${FILESDIR}"/${PN}-1.0.6-conf.d acpid
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ elog
+}