summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-05-06 09:38:31 +0000
committerPacho Ramos <pacho@gentoo.org>2012-05-06 09:38:31 +0000
commitd9ed9b70ad612431e0604d3f267da1f66e4a2108 (patch)
tree22a836a1bb15efa2204b0865fea3596f777c910e /sys-power
parent[bump] dev-perl/Config-IniFiles-2.720.0 (diff)
downloadgentoo-2-d9ed9b70ad612431e0604d3f267da1f66e4a2108.tar.gz
gentoo-2-d9ed9b70ad612431e0604d3f267da1f66e4a2108.tar.bz2
gentoo-2-d9ed9b70ad612431e0604d3f267da1f66e4a2108.zip
Version bump.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/bbswitch/ChangeLog7
-rw-r--r--sys-power/bbswitch/bbswitch-0.4.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-power/bbswitch/ChangeLog b/sys-power/bbswitch/ChangeLog
index d83dc53d2770..7816db46dc3b 100644
--- a/sys-power/bbswitch/ChangeLog
+++ b/sys-power/bbswitch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/bbswitch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/ChangeLog,v 1.2 2012/04/23 20:34:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/ChangeLog,v 1.3 2012/05/06 09:38:31 pacho Exp $
+
+*bbswitch-0.4.2 (06 May 2012)
+
+ 06 May 2012; Pacho Ramos <pacho@gentoo.org> +bbswitch-0.4.2.ebuild:
+ Version bump.
23 Apr 2012; Michał Górny <mgorny@gentoo.org> bbswitch-0.4.1.ebuild:
Use mirror://github.
diff --git a/sys-power/bbswitch/bbswitch-0.4.2.ebuild b/sys-power/bbswitch/bbswitch-0.4.2.ebuild
new file mode 100644
index 000000000000..3d19991d7caf
--- /dev/null
+++ b/sys-power/bbswitch/bbswitch-0.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/bbswitch-0.4.2.ebuild,v 1.1 2012/05/06 09:38:31 pacho Exp $
+
+EAPI="4"
+
+inherit linux-mod
+
+DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+SRC_URI="mirror://github/Bumblebee-Project/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/linux-sources
+ sys-kernel/linux-headers"
+
+RDEPEND=""
+
+MODULE_NAMES="bbswitch(acpi)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="default"
+ BUILD_PARAMS="KVERSION=${KV_FULL}"
+}
+
+src_install() {
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
+ dodoc NEWS
+
+ linux-mod_src_install
+}