summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-02-02 16:42:59 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-02-02 16:42:59 +0000
commitd195f979f8b078257d8390e0cabf3bda6788d1c4 (patch)
treed13192c1daca51c7a51d54302d9383e644f234c1 /sys-power
parentremove redundant ebuild (diff)
downloadgentoo-2-d195f979f8b078257d8390e0cabf3bda6788d1c4.tar.gz
gentoo-2-d195f979f8b078257d8390e0cabf3bda6788d1c4.tar.bz2
gentoo-2-d195f979f8b078257d8390e0cabf3bda6788d1c4.zip
Revert vbetool modification of this version
(Portage version: 2.1.2-r5)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.94-r46
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.94-r4.ebuild73
3 files changed, 86 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 12c816e8cd4f..00a9c18c9e8d 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.45 2007/01/30 15:33:52 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.46 2007/02/02 16:42:59 alonbl Exp $
+
+*hibernate-script-1.94-r4 (02 Feb 2007)
+
+ 02 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.94-r4.ebuild:
+ Revert vbetool modification of this version
30 Jan 2007; Andrej Kacian <ticho@gentoo.org>
hibernate-script-1.94-r3.ebuild:
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r4 b/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r4
new file mode 100644
index 000000000000..55d7b18d3d9a
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r4
@@ -0,0 +1,6 @@
+MD5 e3a14b1203a73bf142527b233b5c07a9 hibernate-script-1.94-patches-5.tar.bz2 3296
+RMD160 a0fd307e462d59dfee0a21144c3f13bcae6bdee7 hibernate-script-1.94-patches-5.tar.bz2 3296
+SHA256 0a8c6eff5bcf544dda6c1e3f0d83ad0737e6937366e7482da34b7af3beb0d63c hibernate-script-1.94-patches-5.tar.bz2 3296
+MD5 f8826d4c96e320902382f29c91694c04 hibernate-script-1.94.tar.gz 72928
+RMD160 31d105c08bf183e3bc770543e0ae01678798859b hibernate-script-1.94.tar.gz 72928
+SHA256 57ad0de0cce263c76303a5c7116550f19aaec540c6743e0b5bcd5d0cb68d2fe2 hibernate-script-1.94.tar.gz 72928
diff --git a/sys-power/hibernate-script/hibernate-script-1.94-r4.ebuild b/sys-power/hibernate-script/hibernate-script-1.94-r4.ebuild
new file mode 100644
index 000000000000..d5ce97a542a4
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.94-r4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.94-r4.ebuild,v 1.1 2007/02/02 16:42:59 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="5"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm -f "${S}"/scriptlets.d/swsusp2_15
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+ "${S}"/install.sh || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate"
+ elog "suspend images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.gz for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+ elog
+ elog "Starting with hibernate-script-1.90 the configuration files have"
+ elog "been reordered and split into method specific files. Make sure you"
+ elog "update your /etc/hibernate/ configuration files accordingly."
+ elog
+}