summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2008-05-08 19:37:30 +0000
committerMichael Imhof <tantive@gentoo.org>2008-05-08 19:37:30 +0000
commitcce1841e0dfb84cbd60a0b15fac52185026adf01 (patch)
treeb854a740c344b9d98e62fd91a43e23b33bb87a95 /sys-power
parentadd addpredict back, fix bug #220983 (diff)
downloadgentoo-2-cce1841e0dfb84cbd60a0b15fac52185026adf01.tar.gz
gentoo-2-cce1841e0dfb84cbd60a0b15fac52185026adf01.tar.bz2
gentoo-2-cce1841e0dfb84cbd60a0b15fac52185026adf01.zip
Version bumped. Closes #208188. Added -j1 to emake, should fix #176339.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/apcupsd/ChangeLog11
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.0.ebuild11
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.1.ebuild11
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.2.ebuild10
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.3.ebuild120
5 files changed, 145 insertions, 18 deletions
diff --git a/sys-power/apcupsd/ChangeLog b/sys-power/apcupsd/ChangeLog
index 28c2ccbaa684..e9d33dd72fa1 100644
--- a/sys-power/apcupsd/ChangeLog
+++ b/sys-power/apcupsd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-power/apcupsd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/ChangeLog,v 1.34 2008/01/31 20:32:56 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/ChangeLog,v 1.35 2008/05/08 19:37:30 tantive Exp $
+
+*apcupsd-3.14.3 (08 May 2008)
+
+ 08 May 2008; Michael Imhof <tantive@gentoo.org>
+ +files/3.14.3/apcupsd.in.patch, +files/3.14.3/etc.patch,
+ +files/3.14.3/apcupsd.initd, +files/3.14.3/hal-ups-policy.patch,
+ +files/3.14.3/no-parallel.patch, apcupsd-3.14.0.ebuild,
+ apcupsd-3.14.1.ebuild, apcupsd-3.14.2.ebuild, +apcupsd-3.14.3.ebuild:
+ Version bumped. Closes #208188. Added -j1 to emake, should fix #176339.
31 Jan 2008; Benedikt Böhm <hollow@gentoo.org> apcupsd-3.10.17-r1.ebuild,
apcupsd-3.10.18-r1.ebuild, apcupsd-3.10.18-r2.ebuild,
diff --git a/sys-power/apcupsd/apcupsd-3.14.0.ebuild b/sys-power/apcupsd/apcupsd-3.14.0.ebuild
index 48f053d27270..262fb14ff2e0 100644
--- a/sys-power/apcupsd/apcupsd-3.14.0.ebuild
+++ b/sys-power/apcupsd/apcupsd-3.14.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.0.ebuild,v 1.3 2007/05/03 16:10:17 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.0.ebuild,v 1.4 2008/05/08 19:37:30 tantive Exp $
WEBAPP_MANUAL_SLOT="yes"
inherit eutils webapp
@@ -34,7 +34,6 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}/apcupsd.in.patch
epatch "${FILESDIR}"/${PV}/etc.patch
epatch "${FILESDIR}"/${PV}/no-parallel.patch
-
epatch "${FILESDIR}"/${PV}/${P}-apccontrol-gentoo.patch
}
@@ -64,11 +63,11 @@ src_compile() {
$(use_enable gnome gapcmon) \
${myconf} \
|| die
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
if use doc; then
einfo "Building full documentation..."
- cd ${S}/doc/latex
+ cd "${S}"/doc/latex
make texcheck tex web pdf
fi
}
@@ -92,7 +91,7 @@ src_install() {
fi
if use cgi; then
- mv ${D}/etc/apcupsd/apcupsd.css ${D}${MY_CGIBINDIR}
+ mv "${D}"/etc/apcupsd/apcupsd.css "${D}""${MY_CGIBINDIR}"
webapp_src_install
fi
diff --git a/sys-power/apcupsd/apcupsd-3.14.1.ebuild b/sys-power/apcupsd/apcupsd-3.14.1.ebuild
index f413ec9b016e..914124de7a01 100644
--- a/sys-power/apcupsd/apcupsd-3.14.1.ebuild
+++ b/sys-power/apcupsd/apcupsd-3.14.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.1.ebuild,v 1.1 2007/07/01 20:58:00 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.1.ebuild,v 1.2 2008/05/08 19:37:30 tantive Exp $
WEBAPP_MANUAL_SLOT="yes"
inherit eutils webapp
@@ -34,7 +34,6 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}/apcupsd.in.patch
epatch "${FILESDIR}"/${PV}/etc.patch
epatch "${FILESDIR}"/${PV}/no-parallel.patch
-
epatch "${FILESDIR}"/${PV}/${P}-apccontrol-gentoo.patch
}
@@ -64,11 +63,11 @@ src_compile() {
$(use_enable gnome gapcmon) \
${myconf} \
|| die
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
if use doc; then
einfo "Building full documentation..."
- cd ${S}/doc/latex
+ cd "${S}"/doc/latex
make texcheck tex web pdf
fi
}
@@ -92,7 +91,7 @@ src_install() {
fi
if use cgi; then
- mv ${D}/etc/apcupsd/apcupsd.css ${D}${MY_CGIBINDIR}
+ mv "${D}"/etc/apcupsd/apcupsd.css "${D}""${MY_CGIBINDIR}"
webapp_src_install
fi
diff --git a/sys-power/apcupsd/apcupsd-3.14.2.ebuild b/sys-power/apcupsd/apcupsd-3.14.2.ebuild
index 7262945aa073..9428e8ee3376 100644
--- a/sys-power/apcupsd/apcupsd-3.14.2.ebuild
+++ b/sys-power/apcupsd/apcupsd-3.14.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.2.ebuild,v 1.1 2007/11/26 08:17:37 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.2.ebuild,v 1.2 2008/05/08 19:37:30 tantive Exp $
WEBAPP_MANUAL_SLOT="yes"
inherit eutils webapp
@@ -61,11 +61,11 @@ src_compile() {
$(use_enable gnome gapcmon) \
${myconf} \
|| die
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
if use doc; then
einfo "Building full documentation..."
- cd ${S}/doc/latex
+ cd "${S}"/doc/latex
make texcheck tex web pdf
fi
}
@@ -89,7 +89,7 @@ src_install() {
fi
if use cgi; then
- mv ${D}/etc/apcupsd/apcupsd.css ${D}${MY_CGIBINDIR}
+ mv "${D}"/etc/apcupsd/apcupsd.css "${D}""${MY_CGIBINDIR}"
webapp_src_install
fi
diff --git a/sys-power/apcupsd/apcupsd-3.14.3.ebuild b/sys-power/apcupsd/apcupsd-3.14.3.ebuild
new file mode 100644
index 000000000000..10528f59a3d6
--- /dev/null
+++ b/sys-power/apcupsd/apcupsd-3.14.3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/apcupsd/apcupsd-3.14.3.ebuild,v 1.1 2008/05/08 19:37:30 tantive Exp $
+
+WEBAPP_MANUAL_SLOT="yes"
+inherit eutils webapp
+
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
+HOMEPAGE="http://www.apcupsd.org/"
+SRC_URI="mirror://sourceforge/apcupsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc snmp usb cgi ncurses nls gnome"
+
+DEPEND="doc? ( virtual/tetex dev-tex/latex2html )
+ cgi? ( >=media-libs/gd-1.8.4 )
+ ncurses? ( sys-libs/ncurses )
+ nls? ( sys-devel/gettext )
+ snmp? ( net-analyzer/net-snmp )
+ gnome? ( >=x11-libs/gtk+-2.4.0
+ >=dev-libs/glib-2.0
+ >=gnome-base/gconf-2.0 )"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+pkg_setup() {
+ use cgi && webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}/apcupsd.in.patch
+ epatch "${FILESDIR}"/${PV}/etc.patch
+ epatch "${FILESDIR}"/${PV}/hal-ups-policy.patch
+}
+
+src_compile() {
+ local myconf
+ use cgi && myconf="${myconf} --enable-cgi --with-cgi-bin=${MY_CGIBINDIR}"
+ use usb && myconf="${myconf} --with-upstype=usb --with-upscable=usb --enable-usb --without-dev"
+ use !usb && myconf="${myconf} --with-upstype=apcsmart --with-upscable=smart --disable-usb"
+
+ # We force the DISTNAME to gentoo so it will use gentoo's layout also
+ # when installed on non-linux systems.
+ DISTNAME=gentoo APCUPSD_MAIL=/usr/sbin/sendmail ./configure \
+ --prefix=/usr \
+ --sbindir=/sbin \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/apcupsd \
+ --with-pwrfail-dir=/etc/apcupsd \
+ --with-lock-dir=/var/lock \
+ --with-pid-dir=/var/run \
+ --with-log-dir=/var/log \
+ --with-nis-port=3551 \
+ --enable-net \
+ $(use_enable ncurses powerflute) \
+ $(use_enable snmp net-snmp) \
+ $(use_enable nls) \
+ $(use_enable gnome gapcmon) \
+ ${myconf} \
+ || die
+ emake -j1 || die "emake failed"
+
+ if use doc; then
+ einfo "Building full documentation..."
+ cd "${S}"/doc/latex
+ make texcheck tex web pdf
+ fi
+}
+
+src_install() {
+ use cgi && webapp_src_preinst
+
+ emake DESTDIR="${D}" install || die "installed failed"
+ rm -f "${D}"/etc/init.d/halt
+
+ insinto /etc/apcupsd
+ newins examples/safe.apccontrol safe.apccontrol
+
+ dodoc ChangeLog* ReleaseNotes
+ mv doc/apctest.man doc/apctest.8; doman doc/apctest.8
+
+ if use doc; then
+ einfo "Installing full documentation..."
+ newdoc doc/latex/apcupsd.pdf manual.pdf
+ dohtml -r doc/latex/apcupsd/*
+ fi
+
+ if use cgi; then
+ mv "${D}"/etc/apcupsd/apcupsd.css "${D}""${MY_CGIBINDIR}"
+ webapp_src_install
+ fi
+
+ rm "${D}"/etc/init.d/apcupsd
+ newinitd "${FILESDIR}/${PV}/${PN}.initd" "${PN}"
+}
+
+pkg_postinst() {
+ if use cgi; then
+ elog If you are upgrading from a previous version, please note
+ elog that the CGI interface is now installed using webapp-config.
+ elog /var/www/apcupsd is no longer present.
+ webapp_pkg_postinst
+ fi
+
+ elog ""
+ elog "Since version 3.14.0 you can use multiple apcupsd instances to"
+ elog "control more than one UPS in a single box."
+ elog "To do this, create a link between /etc/init.d/apcupsd to a new"
+ elog "/etc/init.d/apcupsd.something, and it will then load the"
+ elog "configuration file at /etc/apcupsd/something.conf."
+ elog ""
+}
+
+pkg_prerm() {
+ use cgi && webapp_pkg_prerm
+}