summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-07-15 20:03:52 +0000
committerChristian Heim <phreak@gentoo.org>2006-07-15 20:03:52 +0000
commitc6ecd29f3033b3f470e065734849dac906175dd8 (patch)
treea65a62d62ed9823144de3d30b42cff9801bb9f1d /sys-power
parentpunt old #140533 (diff)
downloadgentoo-2-c6ecd29f3033b3f470e065734849dac906175dd8.tar.gz
gentoo-2-c6ecd29f3033b3f470e065734849dac906175dd8.tar.bz2
gentoo-2-c6ecd29f3033b3f470e065734849dac906175dd8.zip
Revision bump. Fixing KDE session locking (#140403 thanks to Alexandre Ferreira <alexandre at vydia.com.br>) and fixing error codes in the startup script (#140446 thanks to Alon Bar-Lev <alon.barlev at gmail.com>)
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog12
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.93-r23
-rw-r--r--sys-power/hibernate-script/files/hibernate-script-1.93-gentoo.patch4
-rw-r--r--sys-power/hibernate-script/files/hibernate-script-1.93-kde-lock-session.patch22
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.93-r2.ebuild86
5 files changed, 124 insertions, 3 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 1632256cd754..bcc008a29467 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.26 2006/07/14 06:22:38 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.27 2006/07/15 20:03:52 phreak Exp $
+
+*hibernate-script-1.93-r2 (15 Jul 2006)
+
+ 15 Jul 2006; Christian Heim <phreak@gentoo.org>
+ files/hibernate-script-1.93-gentoo.patch,
+ +files/hibernate-script-1.93-kde-lock-session.patch,
+ +hibernate-script-1.93-r2.ebuild:
+ Revision bump. Fixing KDE session locking (#140403 thanks to Alexandre
+ Ferreira <alexandre at vydia.com.br>) and fixing error codes in the startup
+ script (#140446 thanks to Alon Bar-Lev <alon.barlev at gmail.com>)
*hibernate-script-1.93-r1 (14 Jul 2006)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r2 b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r2
new file mode 100644
index 000000000000..422838b8f2d0
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r2
@@ -0,0 +1,3 @@
+MD5 903e30d67bcdf728f245a71b9ec412e2 hibernate-script-1.93.tar.gz 68644
+RMD160 bbb59d7ac5c7a26667cb00c5dd32224ad3eb8f01 hibernate-script-1.93.tar.gz 68644
+SHA256 8020d653cc09d1724f700e2b28cf5ce83eef3ffd287304141357eef2c22db366 hibernate-script-1.93.tar.gz 68644
diff --git a/sys-power/hibernate-script/files/hibernate-script-1.93-gentoo.patch b/sys-power/hibernate-script/files/hibernate-script-1.93-gentoo.patch
index 449522ddd894..be74ba32ed00 100644
--- a/sys-power/hibernate-script/files/hibernate-script-1.93-gentoo.patch
+++ b/sys-power/hibernate-script/files/hibernate-script-1.93-gentoo.patch
@@ -31,8 +31,8 @@ Index: hibernate-script-1.93/init.d/hibernate-cleanup.sh
-exit 0
+start() {
-+ ebegin "Clearing Software Suspend 2 signatures... "
++ ebegin "Clearing Software Suspend 2 signatures"
+ check_swap_sig
+ check_filewriter_sig
-+ eend $?
++ eend
+}
diff --git a/sys-power/hibernate-script/files/hibernate-script-1.93-kde-lock-session.patch b/sys-power/hibernate-script/files/hibernate-script-1.93-kde-lock-session.patch
new file mode 100644
index 000000000000..b674335c98c4
--- /dev/null
+++ b/sys-power/hibernate-script/files/hibernate-script-1.93-kde-lock-session.patch
@@ -0,0 +1,22 @@
+Index: hibernate-script-1.93/scriptlets.d/lock
+===================================================================
+--- hibernate-script-1.93.orig/scriptlets.d/lock
++++ hibernate-script-1.93/scriptlets.d/lock
+@@ -45,9 +45,14 @@ LockKDE() {
+
+ # send the lock command to all sessions
+ for session in $avail_sessions; do
+- vecho 1 "Locking $session"
+- # dev/null because dcop warns if it can't connect to X (this is normal!)
+- dcop --session "$session" --all-users kdesktop KScreensaverIface lock > /dev/null 2>&1
++ locked=`dcop --session "$session" --all-users kdesktop KScreensaverIface isBlanked 2>/dev/null`
++ if [ x"$locked" = "xtrue" ] ; then
++ vecho 1 "Session $session is already locked!"
++ else
++ vecho 1 "Locking session $session"
++ # dev/null because dcop warns if it can't connect to X (this is normal!)
++ dcop --session "$session" --all-users kdesktop KScreensaverIface lock > /dev/null 2>&1
++ fi
+ done
+
+ # returning 0 because dcop warns if it can't connect to X (this is normal!)
diff --git a/sys-power/hibernate-script/hibernate-script-1.93-r2.ebuild b/sys-power/hibernate-script/hibernate-script-1.93-r2.ebuild
new file mode 100644
index 000000000000..0d053eb6fda3
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.93-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.93-r2.ebuild,v 1.1 2006/07/15 20:03:52 phreak Exp $
+
+inherit eutils
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # remove obsolete swsusp2_15 scriptlet
+ rm -f "${S}"/scriptlets.d/swsusp2_15
+
+ epatch "${FILESDIR}"/${P}-last_result.patch
+ epatch "${FILESDIR}"/${P}-kde-lock-session.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ebegin "Applying ${P}-common.conf.patch"
+ sed -i \
+ -e "s:^# \(Distribution\).*:\1 gentoo:" \
+ "${S}"/common.conf
+ eend $?
+
+ ebegin "Applying ${P}-suspend2.conf.patch"
+ sed -i \
+ -e "s:/usr/local::" \
+ "${S}"/suspend2.conf
+ eend $?
+}
+
+src_install() {
+ BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+ "${S}"/install.sh
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should run the following command to invalidate"
+ einfo "suspend images on a clean boot."
+ einfo
+ einfo " # rc-update add hibernate-cleanup boot"
+ einfo
+ einfo "See /usr/share/doc/${PF}/README.gz for further details."
+ einfo
+ einfo "Please note that you will need to manually emerge any utilities"
+ einfo "(radeontool, vbetool, ...) enabled in the configuration files,"
+ einfo "should you wish to use them."
+ einfo
+ einfo "Starting with hibernate-script-1.90 the configuration files have"
+ einfo "been reordered and split into method specific files. Make sure you"
+ einfo "update your /etc/hibernate/ configuration files accordingly."
+ einfo
+}