summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-07-13 19:17:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-07-13 19:17:56 +0000
commitc260f99d004db916e8f12d5b74df011548ad6c2e (patch)
tree02205fe5d018e6ad8ed7a043f0913720fbe41d8d /sys-power
parentVersion bump && Cleanup (diff)
downloadgentoo-2-c260f99d004db916e8f12d5b74df011548ad6c2e.tar.gz
gentoo-2-c260f99d004db916e8f12d5b74df011548ad6c2e.tar.bz2
gentoo-2-c260f99d004db916e8f12d5b74df011548ad6c2e.zip
Bump to 1.0. Fixes #277699
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nvram-wakeup/ChangeLog7
-rw-r--r--sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-power/nvram-wakeup/ChangeLog b/sys-power/nvram-wakeup/ChangeLog
index a0a1f4596ba4..b21942573e8a 100644
--- a/sys-power/nvram-wakeup/ChangeLog
+++ b/sys-power/nvram-wakeup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/nvram-wakeup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/ChangeLog,v 1.8 2009/01/18 18:16:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/ChangeLog,v 1.9 2009/07/13 19:17:56 patrick Exp $
+
+*nvram-wakeup-1.0 (13 Jul 2009)
+
+ 13 Jul 2009; Patrick Lauer <patrick@gentoo.org> +nvram-wakeup-1.0.ebuild:
+ Bump to 1.0. Fixes #277699
*nvram-wakeup-0.99b (18 Jan 2009)
diff --git a/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild b/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild
new file mode 100644
index 000000000000..a6ae46da114c
--- /dev/null
+++ b/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild,v 1.1 2009/07/13 19:17:56 patrick Exp $
+
+inherit flag-o-matic
+
+MY_P=${P%_p*}
+[[ ${PV} == *_p* ]] && REV=${P#*_p} || unset REV
+MY_P=${MY_P/e}
+DESCRIPTION="read and write the WakeUp time in the BIOS"
+HOMEPAGE="http://sourceforge.net/projects/nvram-wakeup"
+SRC_URI="mirror://sourceforge/nvram-wakeup/${MY_P}.tar.gz
+ ${REV+http://nvram-wakeup.svn.sourceforge.net/viewvc/*checkout*/nvram-wakeup/trunk/nvram-wakeup/nvram-wakeup-mb.c?revision=${REV}}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+[[ -n ${REV} ]] && RESTRICT="mirror" #168114
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if [[ -n ${REV} ]] ; then
+ cp "${DISTDIR}"/nvram-wakeup-mb.c?revision=${REV} "${S}"/nvram-wakeup-mb.c || die
+ fi
+ cd "${S}"
+ use nls || epatch "${FILESDIR}"/${PN}-0.97-nonls.patch
+ # Need to be careful with CFLAGS since this could eat your bios
+ strip-flags
+ sed -i \
+ -e '/^CFLAGS/s:= -O2 :+= $(CPPFLAGS) :' \
+ Makefile || die "setting CFLAGS"
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ MANDIR="${D}"/usr/share/man \
+ DOCDIR="${D}"/usr/share/doc/${PF} \
+ install || die
+
+ dodoc "${D}"/usr/bin/vdrshutdown
+ rm -f "${D}"/usr/bin/vdrshutdown
+ dodoc set_timer
+
+ rm -f "${D}"/usr/sbin/time
+ rm -f "${D}"/usr/share/man/man*/time.8*
+
+ prepalldocs
+}
+
+pkg_postinst() {
+ echo
+ ewarn "WARNING:"
+ ewarn "This program writes into the NVRAM (used by BIOS to store the CMOS"
+ ewarn "settings). This is DANGEROUS. Do it at your own risk. Neither the"
+ ewarn "author of this program (nvram-wakeup) nor anyone else can be made"
+ ewarn "responsible to any damage made by this program in any way."
+ ewarn "(The worst case happened to me is that on reboot the BIOS noticed the"
+ ewarn "illegal contents of the nvram and set everything to default values."
+ ewarn "But this doesn't mean that you can't destroy even your whole computer.)"
+ echo
+ ewarn " YOU HAVE BEEN WARNED, HAVE A NICE DAY"
+ echo
+}