summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-09-03 18:15:14 +0000
committerRick Farina <zerochaos@gentoo.org>2013-09-03 18:15:14 +0000
commit875ff435e598c7c6620c090f945856b6dff70fdf (patch)
treecee989c509b73d795ed5e2d2cda4d196284d5dfc /sys-power
parentsparc stable wrt bug #455834 (diff)
downloadgentoo-2-875ff435e598c7c6620c090f945856b6dff70fdf.tar.gz
gentoo-2-875ff435e598c7c6620c090f945856b6dff70fdf.tar.bz2
gentoo-2-875ff435e598c7c6620c090f945856b6dff70fdf.zip
remove old ebuild, update HOMEPATE
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog6
-rw-r--r--sys-power/powertop/powertop-2.3.ebuild109
-rw-r--r--sys-power/powertop/powertop-9999.ebuild4
3 files changed, 7 insertions, 112 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index ed431ff648f0..9d04e39475ab 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.86 2013/09/03 09:39:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.87 2013/09/03 18:15:14 zerochaos Exp $
+
+ 03 Sep 2013; Rick Farina <zerochaos@gentoo.org> -powertop-2.3.ebuild,
+ powertop-9999.ebuild:
+ remove old ebuild, update HOMEPATE
03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> powertop-2.4.ebuild:
Stable for amd64, wrt bug #445214
diff --git a/sys-power/powertop/powertop-2.3.ebuild b/sys-power/powertop/powertop-2.3.ebuild
deleted file mode 100644
index 25cd7be3dc8b..000000000000
--- a/sys-power/powertop/powertop-2.3.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.3.ebuild,v 1.6 2013/07/24 14:09:16 zerochaos Exp $
-
-EAPI="5"
-
-inherit eutils linux-info
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
- inherit git-2 autotools
- SRC_URI=""
-else
- SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="https://01.org/powertop/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="unicode X"
-
-COMMON_DEPEND="
- dev-libs/libnl:3
- sys-apps/pciutils
- sys-libs/ncurses[unicode?]
-"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- sys-devel/gettext
-"
-RDEPEND="
- ${COMMON_DEPEND}
- X? ( x11-apps/xset )
- virtual/libintl
-"
-
-DOCS=( TODO README )
-
-pkg_setup() {
- CONFIG_CHECK="
- ~X86_MSR
- ~DEBUG_FS
- ~PERF_EVENTS
- ~TRACEPOINTS
- ~NO_HZ
- ~HIGH_RES_TIMERS
- ~HPET_TIMER
- ~CPU_FREQ_STAT
- ~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
- ~FTRACE
- ~BLK_DEV_IO_TRACE
- ~TIMER_STATS
- ~EVENT_POWER_TRACING_DEPRECATED
- ~TRACING
- "
- ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
- ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
- linux-info_pkg_setup
- if linux_config_exists; then
- if kernel_is -lt 3 7 0; then
- if linux_chkconfig_present SND_HDA_INTEL; then
- CONFIG_CHECK="~SND_HDA_POWER_SAVE"
- ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
- check_extra_config
- fi
- fi
- fi
-}
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
-}
-
-src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
- default
-}
-
-src_compile() {
- #maintainer note: there is no csstoh dir in this version, any needed changes for cross are permitted
- # This fixes cross-compiling. Please verify before deleting.
- #emake -C src csstoh
- #cp "${FILESDIR}"/csstoh src/ || die
- emake
-}
-
-src_install() {
- default
- keepdir /var/cache/powertop
-}
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 6ddf911964b6..83ac956a947d 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.22 2013/04/08 03:12:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.23 2013/09/03 18:15:14 zerochaos Exp $
EAPI="5"
@@ -15,7 +15,7 @@ else
fi
DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
+HOMEPAGE="https://01.org/powertop/"
LICENSE="GPL-2"
SLOT="0"