summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-22 13:26:18 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-22 13:26:18 +0000
commit7180c723c95f074204f2cf8aa74e6719e270637d (patch)
treee4cea8f394034c0b38d1ea55d4eddfd9cde7b74b /sys-power
parentRevbump to fix bug 408283 and bug 412383 (non-maint commit) (diff)
downloadgentoo-2-7180c723c95f074204f2cf8aa74e6719e270637d.tar.gz
gentoo-2-7180c723c95f074204f2cf8aa74e6719e270637d.tar.bz2
gentoo-2-7180c723c95f074204f2cf8aa74e6719e270637d.zip
Fix freetype[bzip2] link problem (bug 416955, thanks tokiclover)
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/suspend/ChangeLog6
-rw-r--r--sys-power/suspend/files/suspend-1.0-bzip2.patch37
-rw-r--r--sys-power/suspend/suspend-1.0.ebuild12
3 files changed, 49 insertions, 6 deletions
diff --git a/sys-power/suspend/ChangeLog b/sys-power/suspend/ChangeLog
index ddf83e1def29..24d7900eb534 100644
--- a/sys-power/suspend/ChangeLog
+++ b/sys-power/suspend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/suspend
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.22 2012/05/04 07:36:59 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.23 2012/05/22 13:26:18 xmw Exp $
+
+ 22 May 2012; Michael Weber <xmw@gentoo.org> suspend-1.0.ebuild,
+ +files/suspend-1.0-bzip2.patch:
+ Fix freetype[bzip2] link problem (bug 416955, thanks tokiclover)
04 May 2012; Jeff Horelick <jdhore@gentoo.org> suspend-0.8-r1.ebuild,
suspend-1.0.ebuild:
diff --git a/sys-power/suspend/files/suspend-1.0-bzip2.patch b/sys-power/suspend/files/suspend-1.0-bzip2.patch
new file mode 100644
index 000000000000..abe5afab819b
--- /dev/null
+++ b/sys-power/suspend/files/suspend-1.0-bzip2.patch
@@ -0,0 +1,37 @@
+--- a/Makefile.am 2011-03-07 00:24:15.000000000 +0100
++++ b/Makefile.am 2012-05-22 10:52:49.023010001 +0200
+@@ -171,7 +171,8 @@
+ fbsplash_funcs.c \
+ fbsplash-test.c
+ fbsplash_test_LDADD=\
+- $(FBSPLASH_LIBS)
++ $(FBSPLASH_LIBS) \
++ $(BZ2_LIBS)
+
+ whitelist.c: whitelist.csv
+ $(PERL) wlcsv2c.pl whitelist.csv whitelist.c
+--- a/configure.ac 2011-03-07 00:24:15.000000000 +0100
++++ b/configure.ac 2012-05-22 10:52:37.918148832 +0200
+@@ -74,6 +74,22 @@
+ ,
+ [enable_fbsplash="no"]
+ )
++BZ2_LIBS=
++AS_IF(
++ [test "x${fbsplash}" = "xyes"],
++ [
++ PKG_CHECK_MODULES(
++ [FREETYPE2],
++ [freetype2],
++ ,
++ [AC_MSG_ERROR([freetype was not found.])]
++ )
++ AC_CHECK_LIB([bz2], [BZ2_bzDecompress],
++ [BZ2_LIBS="${BZ2_LIBS} -lbz2"],
++ [AC_MSG_ERROR(['libbz2' library was not found.])]
++ )
++ ]
++)
+ AC_ARG_WITH(
+ [devdir],
+ [AC_HELP_STRING([--with-devdir=DIR], [use if --enable-create-device, put devices in this directory, default /dev])],
diff --git a/sys-power/suspend/suspend-1.0.ebuild b/sys-power/suspend/suspend-1.0.ebuild
index 87c3f1ac2bef..86f90f967746 100644
--- a/sys-power/suspend/suspend-1.0.ebuild
+++ b/sys-power/suspend/suspend-1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-1.0.ebuild,v 1.3 2012/05/04 07:36:59 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-1.0.ebuild,v 1.4 2012/05/22 13:26:18 xmw Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils
@@ -34,6 +34,8 @@ S="${WORKDIR}/${P/-/-utils-}"
src_prepare() {
epatch "${FILESDIR}"/${P}-errno.patch
+ epatch "${FILESDIR}"/${P}-bzip2.patch
+ eautoreconf
}
src_configure() {
@@ -42,12 +44,12 @@ src_configure() {
--enable-compress \
$(use_enable crypt encrypt) \
$(use_enable fbsplash) \
- $(use_enable threads) \
- || die
+ $(use_enable threads)
}
src_install() {
- emake install DESTDIR="${D}" || die
+ dodir etc
+ emake DESTDIR="${D}" install
}
pkg_postinst() {