summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-07-30 04:09:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-07-30 04:09:59 +0000
commit5b5903f8f2a98e60be47a2848b853fa4aabe4388 (patch)
treebe7273acee90d8f392a85324b79f36eb11b07ed0 /sys-power
parentAdd pkgconfig as a DEP because freeciv needs it to find gtk. If gtk is merge... (diff)
downloadgentoo-2-5b5903f8f2a98e60be47a2848b853fa4aabe4388.tar.gz
gentoo-2-5b5903f8f2a98e60be47a2848b853fa4aabe4388.tar.bz2
gentoo-2-5b5903f8f2a98e60be47a2848b853fa4aabe4388.zip
Bug #141897, version bump.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nut/ChangeLog8
-rw-r--r--sys-power/nut/files/digest-nut-2.0.43
-rw-r--r--sys-power/nut/files/upsstats-upsset-link-2.0.4.patch10
-rw-r--r--sys-power/nut/nut-2.0.4.ebuild184
4 files changed, 204 insertions, 1 deletions
diff --git a/sys-power/nut/ChangeLog b/sys-power/nut/ChangeLog
index 69d52a6fb1d8..7292a2c757e5 100644
--- a/sys-power/nut/ChangeLog
+++ b/sys-power/nut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/nut
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.12 2006/07/22 04:48:06 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.13 2006/07/30 04:09:59 robbat2 Exp $
+
+*nut-2.0.4 (30 Jul 2006)
+
+ 30 Jul 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +files/upsstats-upsset-link-2.0.4.patch, +nut-2.0.4.ebuild:
+ Bug #141897, version bump.
22 Jul 2006; Robin H. Johnson <robbat2@gentoo.org> nut-2.0.3-r1.ebuild:
As per bug #138389, add a warning message.
diff --git a/sys-power/nut/files/digest-nut-2.0.4 b/sys-power/nut/files/digest-nut-2.0.4
new file mode 100644
index 000000000000..25ad2547dc35
--- /dev/null
+++ b/sys-power/nut/files/digest-nut-2.0.4
@@ -0,0 +1,3 @@
+MD5 59b6f3038a5ef64c584913e72bd850a2 nut-2.0.4.tar.gz 699424
+RMD160 7368967572bd8b2361c6fdd642308ecbb661a994 nut-2.0.4.tar.gz 699424
+SHA256 6a8fb79fd5eb89baa36d321c8ffc1b6ec05265242c0ff3495aac49f008295db2 nut-2.0.4.tar.gz 699424
diff --git a/sys-power/nut/files/upsstats-upsset-link-2.0.4.patch b/sys-power/nut/files/upsstats-upsset-link-2.0.4.patch
new file mode 100644
index 000000000000..882889199b16
--- /dev/null
+++ b/sys-power/nut/files/upsstats-upsset-link-2.0.4.patch
@@ -0,0 +1,10 @@
+--- nut-2.0.4.orig/conf/upsstats.html 2005-02-28 01:14:07.000000000 -0800
++++ nut-2.0.4/conf/upsstats.html 2006-05-18 12:56:34.206538641 -0700
+@@ -114,4 +114,6 @@
+ </table>
+
+ </td></tr>
+-</table></body></html>
++</table>
++<p style="text-align: center"><a href="upsset.cgi">Settings &amp; Commands</a></p>
++</body></html>
diff --git a/sys-power/nut/nut-2.0.4.ebuild b/sys-power/nut/nut-2.0.4.ebuild
new file mode 100644
index 000000000000..b6d3a4fa36bf
--- /dev/null
+++ b/sys-power/nut/nut-2.0.4.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.4.ebuild,v 1.1 2006/07/30 04:09:59 robbat2 Exp $
+
+inherit eutils fixheadtails
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Network-UPS Tools"
+HOMEPAGE="http://www.networkupstools.org/"
+# Nut mirrors are presently broken
+#SRC_URI="mirror://nut/source/${PV%.*}/${MY_P}.tar.gz"
+SRC_URI="http://www.networkupstools.org/source/${PV%.*}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="cgi snmp usb ssl"
+
+RDEPEND="cgi? ( >=media-libs/gd-2 )
+ snmp? ( net-analyzer/net-snmp )
+ usb? ( dev-libs/libusb )
+ ssl? ( dev-libs/openssl )"
+DEPEND="$RDEPEND
+ >=sys-apps/sed-4
+ >=sys-devel/autoconf-2.58"
+
+# public files should be 644 root:root
+NUT_PUBLIC_FILES="/etc/nut/{{hosts,upsset,ups,upssched}.conf,upsstats{,-single}.html}"
+# private files should be 640 root:nut - readable by nut, writeable by root,
+NUT_PRIVATE_FILES="/etc/nut/{upsd.conf,upsd.users,upsmon.conf}"
+
+pkg_setup() {
+ enewgroup nut 84
+ enewuser nut 84 -1 /var/state/nut nut,tty
+ warningmsg
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/upsstats-upsset-link-${PV}.patch
+
+ cd "${S}"
+
+ sed -e "s/install: install-dirs/install: install-dirs install-conf/" \
+ -i Makefile.in || die "sed failed"
+
+ ht_fix_file configure.in
+
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ -i configure.in || die "sed failed"
+
+ ebegin "Recreating configure"
+ WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+ eend $?
+}
+
+src_compile() {
+ local myconf
+
+ if [ -n "${NUT_DRIVERS}" ]; then
+ myconf="${myconf} --with-drivers=${NUT_DRIVERS// /,}"
+ fi
+
+ econf \
+ --with-user=nut \
+ --with-group=nut \
+ --with-drvpath=/lib/nut \
+ --sysconfdir=/etc/nut \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/lib/nut \
+ $(use_with ssl) \
+ $(use_with cgi) \
+ $(use_with cgi cgipath /usr/share/nut) \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+
+ if use snmp; then
+ emake snmp || die "snmp compile problem"
+ fi
+
+ if use usb; then
+ emake usb || die "usb compile problem"
+ fi
+
+ if use cgi; then
+ emake cgi || die "cgi compile problem"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-lib || die "make install failed"
+
+ dodir /sbin
+ dosym /lib/nut/upsdrvctl /sbin/upsdrvctl
+ # This needs to exist for the scripts
+ dosym /lib/nut/upsdrvctl /usr/sbin/upsdrvctl
+
+ if use snmp; then
+ make DESTDIR="${D}" install-snmp || die "make install-snmp failed"
+ fi
+
+ if use usb; then
+ make DESTDIR="${D}" install-usb || die "make install-usb failed"
+ fi
+
+ if use cgi; then
+ make DESTDIR="${D}" install-cgi || die "make install-cgi failed"
+ make DESTDIR="${D}" install-cgi-conf || die "make install-cgi-conf failed"
+ einfo "CGI monitoring scripts are installed in /usr/share/nut."
+ einfo "copy them to your web server's ScriptPath to activate."
+ einfo "If you use lighttpd, see lighttpd_nut.conf in the documentation."
+ fi
+
+ # this must be done after all of the install phases
+ for i in "${D}"/etc/nut/*.sample ; do
+ mv "${i}" "${i/.sample/}"
+ done
+
+
+ dodoc CHANGES CREDITS INSTALL MAINTAINERS NEWS README UPGRADING \
+ docs/{FAQ,*.txt}
+
+ newdoc lib/README README.lib
+
+ dodoc ${FILESDIR}/lighttpd_nut.conf
+
+ docinto cables
+ dodoc docs/cables/*
+
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/upsd.rc6" upsd
+ newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+ newexe "${FILESDIR}/upsmon.rc6" upsmon
+
+ # This sets up permissions for nut to access a UPS
+ insinto /etc/udev/rules.d/
+ newins scripts/hotplug-ng/nut-usbups.rules 70-nut-usbups.rules
+
+ keepdir /var/lib/nut
+
+ fperms 0700 /var/lib/nut
+ fowners nut:nut /var/lib/nut
+
+ eval fperms 0640 ${NUT_PRIVATE_FILES}
+ eval fowners root:nut ${NUT_PRIVATE_FILES}
+
+ eval fperms 0644 ${NUT_PUBLIC_FILES}
+ eval fowners root:root ${NUT_PUBLIC_FILES}
+
+ # this is installed for 2.4 and fbsd guys
+ if ! has_version sys-fs/udev; then
+ insinto /etc/hotplug/usb
+ insopts -m 755
+ doins scripts/hotplug-ng/nut-usbups.hotplug
+ fi
+}
+
+pkg_postinst() {
+ # this is to ensure that everybody that installed old versions still has
+ # correct permissions
+ chown nut:nut ${ROOT}/var/lib/nut 2>/dev/null
+ chmod 0700 ${ROOT}/var/lib/nut 2>/dev/null
+
+ eval chown root:nut ${ROOT}${NUT_PRIVATE_FILES} 2>/dev/null
+ eval chmod 0640 ${ROOT}${NUT_PRIVATE_FILES} 2>/dev/null
+
+ eval chown root:root ${ROOT}${NUT_PUBLIC_FILES} 2>/dev/null
+ eval chmod 0644 ${ROOT}${NUT_PUBLIC_FILES} 2>/dev/null
+
+ warningmsg
+}
+
+warningmsg() {
+ ewarn "Please note that NUT now runs under the 'nut' user."
+ ewarn "NUT is in the tty group for access to RS-232 UPS."
+ ewarn "However if you use a USB UPS you may need to look at the udev or"
+ ewarn "hotplug rules that are installed."
+}