summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-05-22 21:13:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-05-22 21:13:42 +0000
commit3c5530935e0de7ee16857fd29ad1045aa31796df (patch)
tree39b11bbe757e083c8d51a59d1d4840d76370c834 /sys-power
parentamd64/x86 stable, bug #223243 (diff)
downloadgentoo-2-3c5530935e0de7ee16857fd29ad1045aa31796df.tar.gz
gentoo-2-3c5530935e0de7ee16857fd29ad1045aa31796df.tar.bz2
gentoo-2-3c5530935e0de7ee16857fd29ad1045aa31796df.zip
Bug #188006, version bump finally. Many thanks to Peter Alfredsen <peter.alfredsen@gmail.com> for the ebuild handling the new upstream build process.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/iasl/ChangeLog11
-rw-r--r--sys-power/iasl/iasl-20080514.ebuild116
2 files changed, 125 insertions, 2 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index a085517554b3..9d8e1fe07ef1 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/iasl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.14 2007/05/21 10:10:56 uberlord Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.15 2008/05/22 21:13:42 robbat2 Exp $
+
+*iasl-20080514 (22 May 2008)
+
+ 22 May 2008; Robin H. Johnson <robbat2@gentoo.org> +iasl-20080514.ebuild:
+ Bug #188006, version bump finally. Many thanks to Peter Alfredsen
+ <peter.alfredsen@gmail.com> for the ebuild handling the new upstream build
+ process.
21 May 2007; Roy Marples <uberlord@gentoo.org> iasl-20060912.ebuild:
Added ~x86-fbsd keyword.
diff --git a/sys-power/iasl/iasl-20080514.ebuild b/sys-power/iasl/iasl-20080514.ebuild
new file mode 100644
index 000000000000..de39366aee0b
--- /dev/null
+++ b/sys-power/iasl/iasl-20080514.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.1 2008/05/22 21:13:42 robbat2 Exp $
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+MY_TESTS_P=${MY_PN/ca/tests}-${PV}
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
+ test? ( http://www.acpica.org/download/${MY_TESTS_P}.tar.gz )"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE="test"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use test
+ then
+ ewarn 'You have selected USE="test". This will install the test results'
+ ewarn "into /usr/share/${PF}/, compressed as a tarball."
+ ewarn 'The tests themselves will only rarely die, but the test results'
+ ewarn 'are interesting for arch testing. The tests may take quite some'
+ ewarn 'time to complete.'
+ fi
+}
+
+src_compile() {
+ local target bin
+ append-flags -fno-strict-aliasing
+
+ for target in compiler tools/acpisrc tools/acpixtract tools/acpiexec
+ do
+ einfo "Compiling in ${target}/"
+ cd "${S}"/${target}
+ case "${target}" in
+ compiler) bin=iasl;;
+ *) bin=${target#*/};;
+ esac
+
+ emake -j1 CC="$(tc-getCC)" || die "emake in ${target} failed"
+ einfo "Finished compiling ${target}"
+
+ mv ${bin} "${T}" || die "mv ${bin} failed"
+ einfo "Finished moving ${bin}"
+
+ make clean || die "make clean in ${target} failed"
+ einfo "Finished cleaning ${target}"
+
+ echo ${bin} >>"${T}"/binlist
+ done
+ einfo "$(<"${T}"/binlist)"
+}
+
+src_test() {
+ aslts_test
+ #aapits_test
+ #The aapits test currently fails, missing include probably.
+}
+
+src_install() {
+ local bin
+ for bin in $(<"${T}"/binlist) ; do
+ dobin "${T}"/${bin}
+ done
+ dodoc README changes.txt
+ if use test
+ then
+ cd "${ASLTSDIR}"/tmp/RESULTS || die "cd ${ASLTSDIR}/tmp/RESULTS failed"
+ ebegin "Creating Test Tarball"
+ tar -cjf testresults.tar.bz2 * || die "tar failed"
+ eend $?
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ doins testresults.tar.bz2 || die "doins testresults.tar.bz2 failed"
+ fi
+
+}
+
+aslts_test() {
+ export ASL="${T}"/iasl \
+ acpiexec="${T}"/acpiexec \
+ ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
+ export PATH="${PATH}:${ASLTSDIR}/bin"
+ cd "${ASLTSDIR}"
+ edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ make install || die "make install aslts test failed"
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+
+ #The below Do commands runs the tests twice and then dies if the results aren't
+ #Identical.
+ Do 1 || die "failed Do 1"
+ Do 2 || die "failed Do 2"
+}
+
+aapits_test() {
+ mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
+ cd "${S}/tools/aapits" || die "cd ${S}/tools/aapits failed"
+ edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+ make || die "make in aapits failed"
+ cd asl || die "cd asl failed"
+ make || die "make in asl failed"
+ cd ../bin
+ ./aapitsrun || die "aapitsrun failed"
+}