summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-06-23 23:42:08 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-06-23 23:42:08 +0000
commit2e5333b82bc37252661bb094685a9ed14da09117 (patch)
tree4d09b0bcf55c24307c32d06b61047f72dfb35ddb /sys-power
parentVersion bump upstream (diff)
downloadgentoo-2-2e5333b82bc37252661bb094685a9ed14da09117.tar.gz
gentoo-2-2e5333b82bc37252661bb094685a9ed14da09117.tar.bz2
gentoo-2-2e5333b82bc37252661bb094685a9ed14da09117.zip
Version bump, fixes bug #137396.
(Portage version: 2.1)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/cpufreqd/ChangeLog8
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.1.1.ebuild67
-rw-r--r--sys-power/cpufreqd/files/digest-cpufreqd-2.1.16
3 files changed, 80 insertions, 1 deletions
diff --git a/sys-power/cpufreqd/ChangeLog b/sys-power/cpufreqd/ChangeLog
index cad669346b33..b4e6a2ba7ca4 100644
--- a/sys-power/cpufreqd/ChangeLog
+++ b/sys-power/cpufreqd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/cpufreqd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.31 2006/06/20 22:45:56 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.32 2006/06/23 23:42:08 brix Exp $
+
+*cpufreqd-2.1.1 (23 Jun 2006)
+
+ 23 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
+ +cpufreqd-2.1.1.ebuild:
+ Version bump, fixes bug #137396.
*cpufreqd-2.1.0 (20 Jun 2006)
diff --git a/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
new file mode 100644
index 000000000000..00c8bd8576de
--- /dev/null
+++ b/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.1.1.ebuild,v 1.1 2006/06/23 23:42:08 brix Exp $
+
+inherit eutils
+
+NVCLOCK_VERSION="0.8b"
+
+DESCRIPTION="CPU Frequency Daemon"
+HOMEPAGE="http://cpufreqd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
+RDEPEND="sys-power/cpufrequtils
+ lm_sensors? ( sys-apps/lm_sensors )"
+DEPEND="sys-apps/sed
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e "s:acpi_event:acpi:" ${S}/cpufreqd.conf
+
+ if use nvidia; then
+ cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
+ epatch ${FILESDIR}/nvclock${NVCLOCK_VERSION}-fd.patch
+ epatch ${FILESDIR}/nvclock${NVCLOCK_VERSION}-fpic.patch
+ fi
+}
+
+src_compile() {
+ local config
+
+ if use nvidia; then
+ cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
+ econf \
+ --disable-gtk \
+ --disable-qt \
+ --disable-nvcontrol \
+ || die "econf nvclock failed"
+ emake -j1 || die "emake nvclock failed"
+ config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
+ fi
+
+ cd "${S}"
+ econf \
+ $(use_enable acpi) \
+ $(use_enable apm) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nforce2) \
+ $(use_enable pmu) \
+ ${config} \
+ || die "econf failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ newinitd ${FILESDIR}/${P}-init.d ${PN}
+}
diff --git a/sys-power/cpufreqd/files/digest-cpufreqd-2.1.1 b/sys-power/cpufreqd/files/digest-cpufreqd-2.1.1
new file mode 100644
index 000000000000..0cff2749149a
--- /dev/null
+++ b/sys-power/cpufreqd/files/digest-cpufreqd-2.1.1
@@ -0,0 +1,6 @@
+MD5 06383f704bdf612ba2b8c46b27594266 cpufreqd-2.1.1.tar.bz2 285824
+RMD160 06de622db37d67842133f6e1200f6fda24ec98d5 cpufreqd-2.1.1.tar.bz2 285824
+SHA256 8693c78dd7c7a0b7c02b0d2c0d1ae6f5ce3f18b23c1b7b5c59e78715a307f814 cpufreqd-2.1.1.tar.bz2 285824
+MD5 df36711124e08b3349692a8788755d14 nvclock0.8b.tar.gz 353127
+RMD160 66cac5993dc141d00efaa95d8f5ec38ed53854f6 nvclock0.8b.tar.gz 353127
+SHA256 a1fbdb82837c33869c0ebfcb95b6e11fc53b86919e8d1d17265d1af71eb04393 nvclock0.8b.tar.gz 353127